Jump to content

Recommended Posts

Hi all. Having a problem with tracks using step sequencer clips. When I start playback, sometimes it plays correctly, but other times it starts playing some other step sequencer clip from a different part of the song. It even does that whether or not the instrument supposed to be playing. And sometimes it starts playing the correct clip and then stops, even thought the clip extends much further.

The workaround is to stop and restart the song - not the end of the world, but can be quite frustrating at times. I can't find any references to this in here or the web generally - has anybody else ever come across this behaviour?

Thanks

Share this post


Link to post
Share on other sites

The first thing i would do is look at your 'Prepare Using ____ Millisecond  buffers'  int he preference menu

Click the 'Preference' menu,  the, click 'MIDI' and then click 'Playback and Recording' and try  raising your buffer or even lowering it. 

I'm assuming you are using an dedicated audio interface with your DAW, drivers are very important for your DAW's performance as well..

Share this post


Link to post
Share on other sites
3 hours ago, CJ Jacobson said:

The first thing i would do is look at your 'Prepare Using ____ Millisecond  buffers'  int he preference menu

Click the 'Preference' menu,  the, click 'MIDI' and then click 'Playback and Recording' and try  raising your buffer or even lowering it. 

I'm assuming you are using an dedicated audio interface with your DAW, drivers are very important for your DAW's performance as well..

Good idea, to try.  :)

The default size for this buffer USED to be 500 ms, but with one of the later Sonar releases - either in X1-X3 or Platinum, that default got changed to 250 ms, which lots of folks found to be too small, so the general approach by lots of folks was to increase that Prepare Using ______ Millisecond buffers back up to 500 ms, with some upping the size to 750 ms, and a smaller set of folks going up to 1000 ms.

I run mine at 500 ms, and that seems to work just fine - experiment with it and if you find improvement to your playback, then go ahead and leave it at whatever setting works well for you.  If one of your change attempts makes things worse, no problemo, just change it again to something different.  It won't mess anything up if you try a bunch of different settings for this.  For ME, I just changed it the one time to 500 ms and left it at that.

Bob Bone

Share this post


Link to post
Share on other sites

Thanks CJ and Bob... and many apologies for not getting back sooner. I have reply alerts turned on, but apparently didn't receive any.

Yes - the buffer was set to 250, so I'll try it at 500 and see what happens.

Richard

Share this post


Link to post
Share on other sites

500, 750, 1000ms makes absolutely no difference. Many times when I start a piece, it just picks any one of the drum patterns from somewhere in the song and starts playing it.

Honestly, I really appreciate what BandLab has done by picking up the software and continuing to develop it, but I seem to be experiencing many more random problems now than I can recall in the last several years.

Richard

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×