Jump to content

Recommended Posts

Hi all - please use this topic to post feedback specific to the 2022.06 release. Release-specific feedback is valuable to us, and consolidating it in a single topic is extremely helpful.

We request that  discussion in this thread be restricted to issues directly concerning this release, to make it easier for us to assist users. For other topics, kindly use the feature request section or create new posts.  Off topic messages will be deleted.

Thanks in advance!

2022.06 Release Notes

  • Thanks 3

Share this post


Link to post
Share on other sites

I have a Nektar Panorama P6 which has a control surface that supports cubase. will this work with the mackie emulation in the new cakewalk version?

Share this post


Link to post
Share on other sites
2 hours ago, Matteo Bosi said:

I have a Nektar Panorama P6 which has a control surface that supports cubase. will this work with the mackie emulation in the new cakewalk version?

At the risk this is what the release notes say regards Mackie control and Cubase.

Mackie control surface improvements, including performance enhancements and optional Universal and Cubase emulation modes that can be used if your control surface does not provide a dedicated Cakewalk/SONAR mode

Share this post


Link to post
Share on other sites

Studio Instruments Plug-ins Update. Anyone know what this is updating?

Share this post


Link to post
Share on other sites

Just wondering, but, apart from the MCU improvements, will you also update the Maeckie HUI support at some point? Some MIDI keyboards (like the Arturia Keylab controllers, or the M-Audio Impulse) use Maeckie HUI for DAW control. Last time I checked some versions ago, with the Maeckie HUI (Beta) protocol, some things didn't work, see this thread: https://discuss.cakewalk.com/index.php?/topic/34322-question-about-hui-protocol-implementation/#comments

Share this post


Link to post
Share on other sites
2 hours ago, chakko said:

Just wondering, but, apart from the MCU improvements, will you also update the Maeckie HUI support at some point? Some MIDI keyboards (like the Arturia Keylab controllers, or the M-Audio Impulse) use Maeckie HUI for DAW control. Last time I checked some versions ago, with the Maeckie HUI (Beta) protocol, some things didn't work, see this thread: https://discuss.cakewalk.com/index.php?/topic/34322-question-about-hui-protocol-implementation/#comments

The HUI protocol has been deprecated for a long time.  If a genuine Mackie HUI comes up on the second hand market at a reasonable price, I may get one and improve the HUI support... but until then, we don't plan on doing any other improvements.

Share this post


Link to post
Share on other sites
4 hours ago, msmcleod said:

The HUI protocol has been deprecated for a long time.  If a genuine Mackie HUI comes up on the second hand market at a reasonable price, I may get one and improve the HUI support... but until then, we don't plan on doing any other improvements.

Thanks for your answer. It's a bit of a shame, because, as I mentioned, there are current keyboards which use the HUI protocol to provide easy mapping of the knobs and faders in DAW's. Any other DAW I know provides HUI support (Cubase, Studio One, Reaper).

Here are a few keyboards which use HUI: Novation Launchkey mk3 keyboards, Novation Impulse keyboards, Arturia KeyLab mk2 keyboards, Arturia KeyLab Essentials keyboards, M-Audio Oxygen Pro keyboards etc. It's really pretty common, even today. 

Share this post


Link to post
Share on other sites
19 minutes ago, Skyline_UK said:

How do I initiate the new 'local Help'?

Disconnect from the internet or enable Always Use Local Help

A manual check for updates should prompt to install the local help file. If it does not, try enabling "Always Use Local Help."

 

  • Thanks 2

Share this post


Link to post
Share on other sites

Enabling local help also automatically does a check for updates when you OK preferences. So you should see the download listed (assuming you are online when you do that) 

  • Thanks 2

Share this post


Link to post
Share on other sites

 

I have an Arturia Keylab 61 essential. Previously it used the HUI protocol and some things worked if others didn't. With the update I switched to the Mackie MCU protocol in universal control mode and almost all functions now work including save and undo, loop, faders and panning. it really is much better!!! Thanks a lot!

  • Like 2

Share this post


Link to post
Share on other sites

This is a great release, it has fixed several annoying things for me (one crucial)! Thanks a lot Cakewalkers!

Share this post


Link to post
Share on other sites
Posted (edited)

The split-bug hasn't been fixed.

If you have MIDI control change events in the beginning of a clip followed by notes, place the now time somewhere between the CC#s and notes then split. Cakewalk is creating a new control event at the split point.

Edited by chris.r

Share this post


Link to post
Share on other sites
20 hours ago, sjoens said:

Studio Instruments Plug-ins Update. Anyone know what this is updating?

I too want to know this.

At least, some bad sample data that sounds slightly delayed remains uncorrected...

Share this post


Link to post
Share on other sites
8 minutes ago, HIBI said:
20 hours ago, sjoens said:

Studio Instruments Plug-ins Update. Anyone know what this is updating?

I too want to know this.

At least, some bad sample data that sounds slightly delayed remains uncorrected...

AFAIK, the plug-ins have not been updated in some time, but the installers have.

Share this post


Link to post
Share on other sites
5 hours ago, chris.r said:

The split-bug hasn't been fixed.

If you have MIDI control change events in the beginning of a clip followed by notes, place the now time somewhere between the CC#s and notes then split. Cakewalk is creating a new control event at the split point.

This isn't a bug - it happens when "Split MIDI Notes" is enabled.  When enabled, any notes or active CC's are retriggered at the split point. The primary purpose of this is to support arranger operations, so that the status of any CC's at that split point are honoured  regardless of where a section is moved.

Turn off "Split MIDI Notes" and you won't see this behaviour.
 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
5 hours ago, msmcleod said:

This isn't a bug - it happens when "Split MIDI Notes" is enabled.  When enabled, any notes or active CC's are retriggered at the split point. The primary purpose of this is to support arranger operations, so that the status of any CC's at that split point are honoured  regardless of where a section is moved.

Turn off "Split MIDI Notes" and you won't see this behaviour.
 

Thanks.

 

Sounds more like a trade off than a solution :D 

  • Haha 1

Share this post


Link to post
Share on other sites

I haven't posted since the old forum days.  I just wanted to say that I really appreciate the new updates and the continuing support of Cakewalk. I cut my teeth during the 12 tones days and I am just accustomed to the workflow.. I was disheartened with the all of the business decisions around ownership and did move to another platform.. I prefer this product and hope that it continues to grow and strive in its new environment.  Ok.. About the update.. I have the SSL UF8 (2) and this update makes me very happy.. I have not seen any issues at this point and I am glad that I can now use the controller more thoroughly in my preferred DAW.. Thanks Cakewalk and the bakers for this personally relevant and important update... Be well...

  • Like 5
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

I'm getting something weird in 2022.06.

After loading blank Cakewalk none of the menus work (File, Edit, Utilities and Help) when I click on them with a mouse (nothing happens).

Pressing ALT-F brings up the File menu and I can then operate the menus from the mouse but after closing the menus they no longer work again (either mouse or shortcut key).

Loading a project from the task bar Cakewalk icon loads the projects fine and the menus seem to work ok, but after a while pressing any of the menus causes them to do something (not sure what they do but I get an hourglass for a short period and the project refreshes) but not open the menu. 

All other DAWs that I tried were working ok (Reaper, Studio One).

UPDATE: I thought I would record an OBS screen capture video to demonstrate the problem, but with OBS recording the problem goes away! Stop and close OBS and the problem reappears. 🤔

Edited by ZincT

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...