Jump to content
Sidney Earl Goodroe

Still a bug in Ik Sampletank? SOLVED!!!!

Recommended Posts

Hi, guys!! 

Question:

Is anybody still experiencing the midi channel transmission bug? I am still on version 3 and STILL haven't figured out why the sliders, knobs, etc., all transmit on channel 1 but the keys transmit on channel 2!!!!

Yes, I have checked the channels on my Keystation 88 Pro. All set to channel 1. I don't get why just the keys are being recieved on channel 2.

Has anyone else experienced this and if so what was your fix.

Thanks!!!

Edited by Sidney Earl Goodroe
Problem solved

Share this post


Link to post
Share on other sites

@Sidney Earl Goodroe, I cannot say there is a bug or common issue with the SampleTank 3 MIDI Channels. In both stand alone and DAW use, MIDI Channels are working properly. I just double checked myself.

Make sure your keyboard's knobs, sliders, and faders do not require additional set up to change MIDI Channels. Try setting your MIDI Channel to "0" on your keyboard, some companies offer 0 - 15 as opposed to 1 - 16 for the 16 available MIDI Channels.

Please reach out to the support team if you need any extra help:

https://www.ikmultimedia.com/contact-support/

 

Edited by Ryan IK Multimedia

Share this post


Link to post
Share on other sites

There is no channel 0. Only 1-16. Thanks for the response. Just makes no sense that all controllers other than the actual keys transmit on one channel. I do not see an assignment for just the keys.

Back to my workaround, I guess,

Share this post


Link to post
Share on other sites
17 hours ago, Sidney Earl Goodroe said:

There is no channel 0. Only 1-16. Thanks for the response. Just makes no sense that all controllers other than the actual keys transmit on one channel. I do not see an assignment for just the keys.

Back to my workaround, I guess,

Technically there are only 16 MIDI channels, correct. I was referring to the fact that some companies I've personally used start the count at 0 which leads to the number going to 15. Sorry for any confusion with my reply. 

Checking your product's user manual I do see the option to assign MIDI channels to your different controls.  Check out page 6 and on  or Section 4 "Introduction to programming options".
 

Quote

4. Introduction to Programming Options

Each of the 60 controllers on the Keystation Pro 88 can send MIDI CC, RPN/NRPN, GM1 and 2 or SysEx messages. The controllers can also be assigned to individual MIDIchannels. MIDI CC (continuous controller) numbers are part of the standard MIDIspecification and typically used to control the real-time changes of parameters in MIDImusical equipment.


Hope this helps!

PS. If you still need any extra assistance, as mentioned, our team is more than happy to help. Feel free to reach out at the link below.

https://www.ikmultimedia.com/contact-support/

Share this post


Link to post
Share on other sites

I think your still misunderstanding my OP. The global channel is set for channel 1. You can assign any knob, slider, wheel, etc., to any channel you want. All are set to channel 1.

The problem is the keys themselves are transmitting on channel 2 and there is no setting to change just the keys to a separate channel. 

This only is so in the standalone version. The vst works fine. This has been a problem for a long while it seems. There was a post a long time ago on the original forum about this problem and I was wondering if anyone else was still experiencing it.

Thanks for the tips but I have the manual and also the editing software for the Keystation. I don't see anything out of the ordinary in the software editor.

Share this post


Link to post
Share on other sites

I found it!!! The zone channel for zone 1 had somehow got set to channel 2!!!!

You must remember on the M-audio Keystation Pro 88 (old model) to press global channel button TWICE to set the ZONE channel!!

Thanks for your help.

  • Like 3

Share this post


Link to post
Share on other sites
On 6/22/2019 at 8:35 AM, Sidney Earl Goodroe said:

I found it!!! The zone channel for zone 1 had somehow got set to channel 2!!!!

You must remember on the M-audio Keystation Pro 88 (old model) to press global channel button TWICE to set the ZONE channel!!

Thanks for your help.

Glad it is sorted!  And you were only one step away from also having to remember to stand on your head and spit wooden nickels to get it set up :)

Share this post


Link to post
Share on other sites

That's what is peculiar! I have had this thing since they came out and have never used the zone setup buttons! I had to have inadvertently hit that zone button by mistake. Anyway. Thanks

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...