Jump to content
Morten Saether

[CLOSED] Cakewalk 2022.06 Early Access [Updated to Build 22]

Recommended Posts

Posted (edited)

Using a Behringer X-Touch One (firmware 1.08) set to Cubase mode, with Mackie Control in Cubase emulation mode, the only button that doesn't do what it says is Automation-Write enable. Automation-Read toggles correctly, but not Write. Nothing happens but the mouse pointer activity wheel turns when I push the button on the controller.

Also the Ch. Select button on the X-Touch One seems to have no function. It just stays lit green and will not select/deselect the track in Cakewalk even if the track is displayed as active on the controller, or one of the track M/S/R/etc. buttons is highlighted using the controllers navigation arrows.

Fader had to be adjusted while the track was selected in Cakewalk to get them to pair, but after initial pairing, choosing the track on the controller then moving the fader in either Cakewalk or on the controller will move the other, and the motorized fader will then auto-adjust to the correct position instead of 0 when cycling through tracks.

Everything else works fine so far. Could not test with footswitch because I don't have one. Will keep playing around and update my post if I find anything screwy.

 

Windows 10 Pro (21H1);  Intel(R) Core(TM) i7-8850H CPU @ 2.60GHz;  32GB RAM;  NVIDIA Quadro P2000;  PreSonus Studio1824c; CbB v2022.06 (Build 013, 64 bit)
 

Edited by Beau Sterling
added system specs and fw rev

Share this post


Link to post
Share on other sites

Thank You, Morten Saether! 

Looking forward to this new EA update. 

My fingers are crossed that the updated MCU will work even better with my Komplete Kontrol S-88 mkII.

Installing now...

 

Timothy

Share this post


Link to post
Share on other sites
On 5/26/2022 at 9:50 AM, Morten Saether said:

Automatically extend final take when loop recording in Comping mode

My only quibble with how this is implemented is that Cakewalk still truncates the clip and makes the automatic splits if I stop recording in the middle of a take, rewind, and start again.

I'd rather have it extend all incomplete takes out to the end of the loop.

  • Like 4

Share this post


Link to post
Share on other sites
6 hours ago, Starship Krupa said:

I'd rather have it extend all incomplete takes out to the end of the loop.

Or just let them end where they end, without automatically splitting anything, it would effectively be the same thing. It's hard to understand the reasoning behind that automatic splitting.

  • Like 1
  • Great Idea 1

Share this post


Link to post
Share on other sites
On 5/26/2022 at 6:50 PM, Morten Saether said:

Shelf tool does not work with multiple clips in the same lane

This is one of the best bug fixes I have ever seen!!! 👍  (I have complained about it more than once) It improves working with Clip Gain a lot!

On 5/26/2022 at 6:50 PM, Morten Saether said:

Unable to enter "+" character for markers when using non-US keyboard

It works now correct also in the Event Inspector (as @Panu Pentikäinen mentioned)! Thanks!

On 5/26/2022 at 6:50 PM, Morten Saether said:

Automatically extend final take when loop recording in Comping mode

Also this change makes life much easier! Great improvement! 👍

The only criticism (IMO): The setting "Extend Takes to Punch Out Time" should be default! Though anyway, I don't understand the need of this setting to be off, because if you set a punch region you NEVER expect recording out of its range IMO!

Share this post


Link to post
Share on other sites

I just installed the latest Build 13 and on starting Cakewalk I'm getting the old 'Activation required' request.  This takes you to the Bandlab login.  After a couple of attempts I was able to get logged in to my Bandlab account and reactivate Cakewalk.  So far this seems to have stopped the message reappearing but I will keep testing.

Share this post


Link to post
Share on other sites
5 hours ago, Olaf said:

Or just let them end where they end, without automatically splitting anything, it would effectively be the same thing. It's hard to understand the reasoning behind that automatic splitting.

It seems clear to me. You set your loop to record a phrase, you record a couple of takes and get the second half of the phrase right, but not the first part.  So, you just record that a couple of times and don´t bother to continue playing  the whole phrase every time. CbB then splits the phrase in two in all the takes so you can comp it whith what you actually played. 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
12 hours ago, Olaf said:

Or just let them end where they end, without automatically splitting anything, it would effectively be the same thing. It's hard to understand the reasoning behind that automatic splitting.

Thats the way comping was designed. Without a split where one take ends there is not way to comp the other takes together consistet with the comping system. I am one that actually doesn't mind the splits since I use the take lanes exclusively for comping. They are easy enough to "heal" with a swipe as well.

  • Like 1

Share this post


Link to post
Share on other sites
6 minutes ago, reginaldStjohn said:

I use the take lanes exclusively for comping

i don't imagine why you think that's such an unusual thing. everybody does. it still doesn't justify the automatic split point. think about it a little: how often do you actually use that  automatic split point, instead of just having to remove it a million times over while tracking?

Share this post


Link to post
Share on other sites
10 hours ago, norfolkmastering said:

I just installed the latest Build 13 and on starting Cakewalk I'm getting the old 'Activation required' request.  This takes you to the Bandlab login.  After a couple of attempts I was able to get logged in to my Bandlab account and reactivate Cakewalk.  So far this seems to have stopped the message reappearing but I will keep testing.

If you have been logged out of your BL account for months, then Cakewalk cannot auto activate when needed. If you stay logged in, you won't have this issue.
Once in a while the token expires so you have to log in again but its not very often.

Share this post


Link to post
Share on other sites
11 hours ago, marled said:

The only criticism (IMO): The setting "Extend Takes to Punch Out Time" should be default! Though anyway, I don't understand the need of this setting to be off, because if you set a punch region you NEVER expect recording out of its range IMO!

 

It's not the default because the old behavior did not automatically cut out data after the stop playback point.

With the new option, if the new recording is longer than the existing clip, then the underlying clip could be removed. This could be unexpected for some some since it didn't do that before...

Share this post


Link to post
Share on other sites
On 6/2/2022 at 9:19 PM, Keni said:

I just updated to build 13

 

Melodyne clips are still becoming invisible in lanes (no talking parent) when muted. As I commented earlier, I reported this back in 2022.02 and was told it was fixed for next release. There is no mention of it in the list of fixes and it is not fixed. If I mute a melodyned clip in it's lane, it disappears!

It's fixed for the upcoming update.

  • Like 2

Share this post


Link to post
Share on other sites
6 minutes ago, Noel Borthwick said:

It's not the default because the old behavior did not automatically cut out data after the stop playback point.

With the new option, if the new recording is longer than the existing clip, then the underlying clip could be removed. This could be unexpected for some some since it didn't do that before...

Yes, exactly! And therefore it's even worse if the new recording goes up to the end of the loop region, instead of the punch out (if this is before the end of the loop)! And this is the new default ("Extend Takes to Punch Out Time" = off)!

But anyway a lot of thanks for improving it! If I set the flag to ON it runs perfectly! 😊

Share this post


Link to post
Share on other sites
14 minutes ago, marled said:

Yes, exactly! And therefore it's even worse if the new recording goes up to the end of the loop region, instead of the punch out (if this is before the end of the loop)! And this is the new default ("Extend Takes to Punch Out Time" = off)!

But anyway a lot of thanks for improving it! If I set the flag to ON it runs perfectly! 😊

Just to be clear,  if "Extend Takes to Punch Out Time" is off when recording in comp mode and you've recorded more than one loop iteration, it will now ALWAYS extend the clip to the end of the loop.

The Extend Takes to Punch Out Time  option is of use when you want to add to a single take to an existing set of comp takes, and don't want the split behaviour.

To put it another way:

Extend Takes to Punch Out Time off  + Comp Mode with > 1 loop iteration:   last take is extended to end of loop
Extend Takes to Punch Out Time on  + Comp Mode with > 1 loop iteration:   last take is extended to end of loop OR punch out time... which ever is earliest

Extend Takes to Punch Out Time off  + Comp Mode with < 1 loop iteration:   take is left as is, with clips being split at record end time
Extend Takes to Punch Out Time on  + Comp Mode with < 1 loop iteration:   take is extended to punch out time

Extend Takes to Punch Out Time off  + SoS or Overwrite Mode, with or without looping, regardless of # takes:  take is left as is, with clips being split at record end time
Extend Takes to Punch Out Time on  + SoS or Overwrite Mode, with or without looping, regardless of # takes:  last take is extended to punch out time

  • Thanks 1

Share this post


Link to post
Share on other sites
5 minutes ago, msmcleod said:

Extend Takes to Punch Out Time off  + Comp Mode with > 1 loop iteration:   last take is extended to end of loop

This is the only one that is strange IMO, because if you have set a punch out that is before the end of the loop, then you would not expect some recording after the punch out!

Share this post


Link to post
Share on other sites
9 minutes ago, msmcleod said:

Just to be clear,  if "Extend Takes to Punch Out Time" is off when recording in comp mode and you've recorded more than one loop iteration, it will now ALWAYS extend the clip to the end of the loop.

The Extend Takes to Punch Out Time  option is of use when you want to add to a single take to an existing set of comp takes, and don't want the split behaviour.

To put it another way:

Extend Takes to Punch Out Time off  + Comp Mode with > 1 loop iteration:   last take is extended to end of loop
Extend Takes to Punch Out Time on  + Comp Mode with > 1 loop iteration:   last take is extended to end of loop OR punch out time... which ever is earliest

Extend Takes to Punch Out Time off  + Comp Mode with < 1 loop iteration:   take is left as is, with clips being split at record end time
Extend Takes to Punch Out Time on  + Comp Mode with < 1 loop iteration:   take is extended to punch out time

Extend Takes to Punch Out Time off  + SoS or Overwrite Mode, with or without looping, regardless of # takes:  take is left as is, with clips being split at record end time
Extend Takes to Punch Out Time on  + SoS or Overwrite Mode, with or without looping, regardless of # takes:  take is extended to punch out time

But I must add that now I understand why "Extend Takes to Punch Out Time" = ON is not default!

In my first statement I have only considered the first 2 cases!

Share this post


Link to post
Share on other sites
On 5/29/2022 at 1:35 AM, Jacques Boileau said:

It depends on what is wanted. Using Bus will control the master fader and affect the level of any export done afterwards, unless there is something I am missing. Controlling the master reduces the level in the monitors and/or headphones but not what will be exported.

I don't know why this didn't occur to me before, but if you lock the Left & Right faders together within the console view, then keeping the Mackie Control set to controlling Master 1 will adjust both faders:

image.png.a4848355480b74b47dc79aba1fd70a3e.png
 

  • Like 1

Share this post


Link to post
Share on other sites
On 6/5/2022 at 5:36 PM, abacab said:

The metronome button sends this message (multiple presses shown):

KeyLab Mk II metronome button.PNG

 

This is the equivalent of pressing Function Key F3 on the Mackie Control,  which you can map to what you need within the Mackie Control Surface dialog.

FWIW
     - setting it to "Keypress: SHIFT + F3 " will make it open the metronome settings dialog
     - setting it to "Keypress: F3" will allow it to toggle the record metronome.

  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, Noel Borthwick said:

It's fixed for the upcoming update.

Thanks Noel!

 

Though I’ve managed with work arounds, it's been uncomfortable. Thanks for getting this one included.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...