Jump to content
Paul McDonagh

Amplitube 5 Max. Audio cracking when used on multiple tracks

Recommended Posts

Hi

I downloaded Amplitube 5 free a couple of months ago and last weekend, I upgraded it to Amplitube Max.

After spending time enjoying the different sounds and settings, I decided It was time to start recording.

Everything started off fine, however,  the more track I recorded, the audio started to crack, this has got worse with the more tracks I have added, causing audio dropout.

I have set everything correctly,  buffer size  ASIO etc, I can make the cracking stop by putting most tracks on standby via the fx bypass rack, this would be no problem if I was mixing or Gain staging. I have tried setting the buffer size to maximum,  during playback and it is still cracking.

For some recordings it would be fine to have no effects as I can add them later, a little bit like reamping, however,  the song I am currently working on, really needs effects, as it needs them for the recording vibe.

If any can help me fix this,  I would be more than happy. 

Cheers 

Paul 

Share this post


Link to post
Share on other sites

You don't tell us anything about your computer specs but AT5 is pretty resource-heavy.  You probably need to freeze your tracks.

  • Like 1

Share this post


Link to post
Share on other sites

If you're using a single amp in AT5 you can save a couple % of CPU if you select a dual routing and then go back to the single.

Share this post


Link to post
Share on other sites

Amplitube 5 takes some CPU horsepower, even with a fairly recent computer. Not an effect you are likely to put on every track.

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Mark Bonson said:

Hi

I downloaded Amplitube 5 free a couple of months ago and last weekend, I upgraded it to Amplitube Max.

After spending time enjoying the different sounds and settings, I decided It was time to start recording.

Everything started off fine, however,  the more track I recorded, the audio started to crack, this has got worse with the more tracks I have added, causing audio dropout.

I have set everything correctly,  buffer size  ASIO etc, I can make the cracking stop by putting most tracks on standby via the fx bypass rack, this would be no problem if I was mixing or Gain staging. I have tried setting the buffer size to maximum,  during playback and it is still cracking.

For some recordings it would be fine to have no effects as I can add them later, a little bit like reamping, however,  the song I am currently working on, really needs effects, as it needs them for the recording vibe.

If any can help me fix this,  I would be more than happy. 

Cheers 

Paul 

The CPU usage of Amplitube 5 has been discussed in this thread. And in last summers group buy thread, if I remember correctly.

 

@rsinger is right that changing the routing decreases the CPU usage. It is a known bug that I have reported to IK last September. It has yet to be fixed though. And in any case you would have to do it every time you start your project. There are 2 other solutions:

  • if you are not using the latest stuff, Mesa Boogie 2 and the X pedals, you can revert to version 5.0.3 which uses quite less CPU
  • or, as you are done with a track, freeze it before working on a new track.
Edited by Jacques Boileau
  • Like 1

Share this post


Link to post
Share on other sites

Yeah. V5 is great sounding but too resource heavy for much of my work. My workaround is to use v3 until the recording is done, then switch to v5 and freeze to get best sound.

  • Like 2

Share this post


Link to post
Share on other sites
10 hours ago, Mark Bonson said:

Everything started off fine, however,  the more track I recorded, the audio started to crack, this has got worse with the more tracks I have added, causing audio dropout.

As has already been mentioned, freeze is your friend! :)

  • Like 1

Share this post


Link to post
Share on other sites

Hi guys 

 

Apols for the late response,  thank you for your help and yes! Freeze tracks is now one of my best friends 😆

Best Wishes 

Paul 

Share this post


Link to post
Share on other sites

clickety clack scratch scratch with cakewalk and amplitude 5.   no problems with guitar rig 5 or 5guitar rig 6   

asio, wasapi ... adjust buffer....  

running i-7 8700 , 2 x m.2 2tb,  plenty of disk space, ASUS Prime 370A MB ,  win 10 x64

IK multimedia said to send them a video ... lets see what they say 

 

well ... after lots of anguish ... 

the only thing that seems to work is to record with another vst..   maybe can use AMPLITUDE 5 in mixdown...

 

had no problem in Reaper with AMPLITUDE clicking.. so may have to mix there.     

Cakewalk does not show much resource use.  i hit the alt G to watch during the playback... so very little reason for this that i can see.

if anyone can figure it out let me know.

 

 

 

 

Share this post


Link to post
Share on other sites
7 minutes ago, Gary E Gnaedinger said:

clickety clack scratch scratch with cakewalk and amplitude 5.   no problems with guitar rig 5 or 5guitar rig 6   

asio, wasapi ... adjust buffer....  

running i-7 8700 , 2 x m.2 2tb,  plenty of disk space, ASUS Prime 370A MB ,  win 10 x64

IK multimedia said to send them a video ... lets see what they say

 

well ... after lots of anguish ... 

the only thing that seems to work is to record with another vst..   maybe can use AMPLITUDE 5 in mixdown...

 

had no problem in Reaper with AMPLITUDE clicking.. so may have to mix there.     

Cakewalk does not show much resource use.  i hit the alt G to watch during the playback... so very little reason for this that i can see.

if anyone can figure it out let me know.

AmpliTube 5 is pretty computationally intensive (CPU usage), with their new modeling technology. If you are using it on more than one track at a time it will add up quickly. Don't know why Reaper and Cakewalk would be that much different, but there could be differences in their audio engines or load balancing. Even if you are maxing out only 1 of your 6 cores, that will result in audio breakup.

Anyway, try recording with AmpliTube 5, and then freezing your track as you go on to record the next track, etc. Freezing bounces that track down to audio in-place with the FX baked in, then sets the plugin to an offline state. Freezing is reversible as you can unfreeze a track with just a click if you want to modify the FX, then re-freeze it. The plugin is still there sleeping with settings intact if you need to access it again.

Share this post


Link to post
Share on other sites

here you all go for a potential solution...   that seems to work...

counter intuitive.... but switching to letting background 

 

Adjust Processor Scheduling

This optimization seems to allow the computer to run Cakewalk more efficiently.  (this was taken from Protools optimization suggestions)

  1. Click on the Start Menu, type System, and press Enter.  (or type in advanced system settings) in the search
  2. Choose Advanced System Settings.
  3. Under the Performance section, click the Settings button.
  4. In the Performance Options window, click the Advanced tab.
  5. Under the Processor Scheduling section, select the Background Services option.
  6. Hit Apply and then OK to close the Performance Options window.
  7. Click OK to close the System Properties window.
  8. Restart the computer for the changes to take effect.

then try to run...

Share this post


Link to post
Share on other sites
8 minutes ago, Gary E Gnaedinger said:

here you all go for a potential solution...   that seems to work...

counter intuitive.... but switching to letting background 

 

Adjust Processor Scheduling

This optimization seems to allow the computer to run Cakewalk more efficiently.  (this was taken from Protools optimization suggestions)

  1. Click on the Start Menu, type System, and press Enter.  (or type in advanced system settings) in the search
  2. Choose Advanced System Settings.
  3. Under the Performance section, click the Settings button.
  4. In the Performance Options window, click the Advanced tab.
  5. Under the Processor Scheduling section, select the Background Services option.
  6. Hit Apply and then OK to close the Performance Options window.
  7. Click OK to close the System Properties window.
  8. Restart the computer for the changes to take effect.

then try to run...

Interesting, and I have heard some folks recommend that setting for DAW use, and others say not to do that. In any case it can't hurt to try!

Glad that it worked for you, but that would also tell me that your PC is probably running pretty close to the edge of what it can do in real-time.

Share this post


Link to post
Share on other sites
16 minutes ago, Gary E Gnaedinger said:

here you all go for a potential solution...   that seems to work...

counter intuitive.... but switching to letting background 

 

Adjust Processor Scheduling

This optimization seems to allow the computer to run Cakewalk more efficiently.  (this was taken from Protools optimization suggestions)

  1. Click on the Start Menu, type System, and press Enter.  (or type in advanced system settings) in the search
  2. Choose Advanced System Settings.
  3. Under the Performance section, click the Settings button.
  4. In the Performance Options window, click the Advanced tab.
  5. Under the Processor Scheduling section, select the Background Services option.
  6. Hit Apply and then OK to close the Performance Options window.
  7. Click OK to close the System Properties window.
  8. Restart the computer for the changes to take effect.

then try to run...

I doubt anything has changed since @Noel Borthwick wrote in http://forum.cakewalk.com/XP-services-that-can-be-safely-turned-off-m1238330.aspx

Quote

I don't recommend this. Setting the sheduling to background for "better performance" with drivers is a myth. At best this is masking a real problem with the driver. All this does is change the quanta for the timeslice assigned by the windows scheduler. By making the time slice longer you are potentially setting up a scenario where the high priority audio threads in the host application might be denied frequent enough servicing by the scheduler! This might actually result in more dropouts or clicks.

Here is a quote from an MSDN article http://support.microsoft.com/kb/308417

• If you click Programs, the foreground program runs more smoothly and responds more quickly. If you want a background task such as a Backup utility to run faster, click Background services.
• The Programs option allocates short, variable time slices (quanta) to running programs, and the Background services option assigns long, fixed quanta.


Contrary to the SOS article that says "this is the most essential tweak of all, because ASIO drivers run as background services in Windows." An ASIO driver is just another a dll running in the process memory space, its NOT a background service - at least not typically. I've never seen an ASIO driver that installs an actual Windows service (you would see that in the services view otherwise). Its just a DLL running a user mode thread to service the audio device and asio callbacks. The thread is no different from the threads that run in the host application itself. If the driver is coded to have the thread priority set to time critical and its thread is not being blocked by something else there should be no need to change this setting. i.e. for the few people this "helps" its likely that all its doing is masking another more fundamental problem.
Additionally setting the sheduling to background is allowing ALL other background tasks on your computer to get a longer timeslice - i.e some other windows service or background application is now more likely might to start interfering with the host task.
 

Quote

ORIGINAL: epillarbox

Interesting. I also spotted this bit which was news to me:

Change Processor Scheduling to 'Background Services'

Navigate to the Advanced page of the System applet. Click on the Performance Settings button, select its Advanced tab and click on 'Background Services' for Processor Scheduling (see top pair of screens).
pcmusician 2
This is one of the few essential Windows XP tweaks, since it benefits the performance of ASIO drivers, which run as background tasks.

For anyone using ASIO drivers (and nowadays that includes just about every PC musician), this is the most essential tweak of all, because ASIO drivers run as background services in Windows. Music software and hardware developers Steinberg rely on this setting to ensure low latency without dropouts, and you may be able to run your audio interface at a significantly lower latency after this tweak.


So I did this. Result was ghastly on my system (my profile for details if you're interested) so I suppose the moral is to try out tweaks one by one and test their impact one at a time.

Thanks for the link, though.

Laurence


edited for typo

 

but as Noel noted later in the thread

Quote

BTW there are a few exceptions to when BG services might be benefical. An example is Rolands Reac system. The driver for that which Cakewalk developed, is a special ASIO driver that uses a network protocol to communicate with the hardware. This rely's on components/services in Windows to do some of the low level work, and as such benefits from processor scheduling set to BG services. However specialized use cases like this are relatively rare.

I have also read a couple of posts where users posted better results after tweaking for background process. Might be worth testing on a case-by-case basis.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...