Jump to content
Bruce Olsen

Resolved: Recording MIDI from Ample Guitar M II Lite

Recommended Posts

Posted (edited)

I'm trying to record the MIDI from¬†Ample Guitar M II Lite's strummer (I have no¬†MIDI controllers, only a mouse ūüėě).

Thanks to some of the previous answers here ūüôā¬†I've been able to arm a MIDI track, hit record, and then use the play button in the VSTi to generate the strums I've programmed.¬†

The good news is that some of the notes are recorded, so it appears the routing has been handled ("Enable MIDI Output" was the key to that). 

The bad news is that not all notes are recorded. An unscientific experiment shows the high E string's notes are not captured. One of the other answers discussed tweaking MIDI channels because each string is assigned to a different channel but I have the "MIDI Guitar" option off, and as I understand it the channel assignments aren't honored in that case.

I'd appreciate any guidance anyone can offer.

I have other questions about the VSTi's other mode (where hand-programmed MIDI notes outside the guitar's range are captured by the VSTi, and call up chords and articulation) but I'll add a separate post for that, since it's really a different thing (though I'm sure the resolution could easily be the same). 

Resolved: The main issue was forgetting that CW  uses different note names. Adjusting "Base Octave For Pitches" to -2 eventually resolved most of the issues. 

Edited by Bruce Olsen

Share this post


Link to post
Share on other sites

I think this was mentioned before but the free versions have limited functions. Check with the Ample web site for details. 

Share this post


Link to post
Share on other sites

Keep in mind if you haven't already that if the high E in your case is not played for that particular chord then it won't play for the midi record either. Check out the chords and what strings are enabled for each. Not every string plays on every chord. I haven't actually noticed that problem but then I haven't looked too hard either.

I do think this program is really a great one to get the ball rolling on a song.

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/6/2022 at 3:46 PM, billp said:

Look here:

image.png.1f4606ccb29a4073bd8dfd638e74d39c.png

Edit: Dragging that button onto a MIDI track will copy the selected strumming pattern onto the track. Your example will copy Pattern 2.

The strumming pattern consists of notes that control the plugin when it strumming mode is turned on. They produce no sound by themselves. Additional MIDI notes need to be created to specify which chord (chosen from a user-defined "Chord Bank" of 24 chords) will be strummed in the manner specified by the strumming pattern notes. Note that the current chord in the Chord bank is not copied when you drag the circled button onto the track, only the pattern is copied.

If you play the notes when the plugin is not in "strummer mode" the corresponding guitar notes will be played.

In strummer mode chords will be strummed.

Edited by Bruce Olsen
Documenting some facts about plugin operation.

Share this post


Link to post
Share on other sites
26 minutes ago, rfssongs said:

Keep in mind if you haven't already that if the high E in your case is not played for that particular chord then it won't play for the midi record either. Check out the chords and what strings are enabled for each. Not every string plays on every chord. I haven't actually noticed that problem but then I haven't looked too hard either.

I do think this program is really a great one to get the ball rolling on a song.

Thanks, I'm playing a D where the high E string plays G so that's not it.

Share this post


Link to post
Share on other sites
1 hour ago, John Vere said:

I think this was mentioned before but the free versions have limited functions. Check with the Ample web site for details. 

Thanks. This has a different UI than the full product does, so I'd assume anything on it works. I'll look again.

Share this post


Link to post
Share on other sites

Maybe change the base note from 0 to -2 in the preferences?

Share this post


Link to post
Share on other sites
17 hours ago, Kurre said:

Maybe change the base note from 0 to -2 in the preferences?

I think this is related to my other issues, thanks.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

√ó
√ó
  • Create New...