Jump to content
Sign in to follow this  
rsinger

USB 3.2 vs USB 2.0

Recommended Posts

I got a new laptop, an MSI Crosshair 15. When I plugged a Roland Quad-Capture into the USB 3.2 gen 1 port the QC didn't like it. It's fine in the USB 2.0 port and that's no problem. I'm curious if anyone knows what the problem is using some USB 2.0 devices with 3.2 ports?

Share this post


Link to post
Share on other sites

I have this with an old MOTU Ultralite - it works in a USB 3 port (as in detects and plays audio) but there is what I can only describe as "wow and flutter".

Share this post


Link to post
Share on other sites
Posted (edited)

That's interesting. Not many manufacturers are stepping up to USB 3; I wonder if they're they testing for compatibility? The QC is an old IF so, I'm not surprised there are compatibility problems.

Edited by rsinger

Share this post


Link to post
Share on other sites

I have an old Focusrite Scarlett 2i4 which causes absolute havoc if I connect it via USB 3.0 - I get blue screens and crashes all over the place. It took me ages to realise this was the issue. However on USB 2.0 - rock solid.

If and when I upgrade my laptop (five years old), I reckon I'll have to upgrade the interface as well.

Andy

Share this post


Link to post
Share on other sites

It's a bit funny that.

My pc have a couple of Usb3 connectors. I bought another external HD and together with that a Usb3 hub.

Connected the Usb3 hub to the Usb3 connector on the pc. Connected two external HD to the hub and they showed up in the file explorer.

The day after, restarted pc, it was only showing one HD. No matter what i do it would end with only one HD showing.

Thinking the hub was buggy i switched it out for an old Usb2 hub connected to the same Usb3 connector on the pc . And now it's working. I see both HD's and they are still there after restart.

I checked the info about the HD's and found out they was not Usb3 as i thought but Usb2.

The mystical thing is > Why did the Usb3 hub accept one HD but not two? 🤔

Share this post


Link to post
Share on other sites
15 hours ago, rsinger said:

I got a new laptop, an MSI Crosshair 15. When I plugged a Roland Quad-Capture into the USB 3.2 gen 1 port the QC didn't like it. It's fine in the USB 2.0 port and that's no problem. I'm curious if anyone knows what the problem is using some USB 2.0 devices with 3.2 ports?

Often times, USB 3.2 (gen2) ports are via 3rd-party controllers (not Intel).

Many older Audio and MIDI devices have problems with 3rd-party controllers.

 

The positive news is that there's no advantage to connecting to USB 3.2 (no performance benefit).

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I set the laptop up in my home studio and the Boss SY-1000 works fine with the USB 3.2 gen 1 port (SY-1000 is USB 2). The MOTU MIDI express XT works with it as well. I noticed that the USB 2 spec has a couple revisions, it may be that some older units have problems due to the revs.

Edited by rsinger

Share this post


Link to post
Share on other sites

On my Asus P8B75V motherboard, my 1st gen Scarlett 18i20 works far better using the USB 3.0 ports than on the USB 2.0 ports, but I suspect his is more to do with what other devices are using the same IRQ as the USB 2.0 port, rather than a USB 2.0 / USB 3.0 thing.

Looking at the IRQ assignment in Windows Device Manager, it looks like all USB 2.0 ports are going through the same IRQ (23) - so my trackball, keyboard, USB wifi adapter & USB midi devices will all be serviced by the same IRQ.

The USB 3.0 port however, has it's own dedicated IRQ.

Share this post


Link to post
Share on other sites
4 hours ago, satyabrata satapathy said:

The Type-C ports on laptops r usb c only, right? 

I'm not sure what you mean. Type-C is a connector, there are also Type-A, Type-B, Mini-USB, Micro-USB, and so on. Normally the USB standard will be specified as well. My laptop says - 1 x USB 3.2 Gen 1 Type C. I got an adapter for mine but haven't used it yet. I use a MOTU M4 with my DAW - it has a USB-C port, but it's USB 2.0.

m4_rear.png

Under specs it says -

Computer I/O - 1 x USB-C (compatible with USB Type A) 2.0 audio class compliant

 

Share this post


Link to post
Share on other sites

Virtually all USB audio interfaces that connect via USB-C port are actually USB-2 devices.

There's no performance advantage connecting via USB-C.

 

A USB-C port doesn't mean that a machine has Thunderbolt.

If you don't specifically see the lightning-bolt icon next to the port, it's USB-C (USB only).

If you see the lightning-bolt icon, the port is Thunderbolt 3 or Thunderbolt 4.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...