Jump to content
  • 0
Alan Perkins

Audio cutting off when midi exported to audio

Question

I have a pure-midi project that plays perfectly through the soft synths, but when I export the project or freeze the synths, some of them have notes cut off - they play "staccato" when the audio is played back, either as external audio files (e.g. WAV, FLAC etc) or internally in the frozen synth tracks. It seems somewhat intermittent sometimes the early notes will be fine early in a session, but the same notes will always render poorly once they start doing so.

I have a mixture of soft synths including LASS from Audiobro, and EastWest's Hollywood diamond orchestras through Play. It is the EastWest libraries through Play that appear to exhibit the problem.

The machine has Core i9 processor with 128GB RAM and the samples are stored on a M.2 NVME SSD drive, so should be no issues with performance. Audio interface is Focusrite Liquid Saffire 56.

Any help appreciated.

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 1

It's a Play (starting with version 5)  bug with the way they do streaming, it really doesn't work at all and will cause the release tails of notes to not be played.  The only way to work around it is to always use a SSD drive for samples,  if possible set the settings for sample cache (on some computers you won't be able to see any controls, another bug they have acknowledged but haven't fixed for at least a year maybe two), toggle the option to stream from disc to off (check box in the hamburger menu) so it loads everything, and never use fast bounce for render always use the slower render methods.  Sadly none of these work 100% of the time.  The best solution is to switch to another sampler/library that doesn't use Play.

  • Great Idea 1

Share this post


Link to post
Share on other sites
  • 0
18 hours ago, Chuck E Baby said:

This sounds like a classic case of midi buffers needing to be boosted. I would change it to 500 and see if that helps.

 

Thanks Chuck E Baby, I had it originally at 300, tried 500, 750, 1000 - none of these values  helped. I've also upgraded Play to the latest version. 

I'm at a loss as to what to try next. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

fwiw, aren't midi buffers only relevant to realtime playback? (ie, not freeze/bounce/mixdown, which just take as long as they need?)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×