Jump to content
  • 0
01John01

How to stop metronome being recorded

Question

Hello, looking for help to stop the metronome being recorded. My setup is a Yamaha P-125 connected to my laptop using the host to USB connection.
I have Cakewalk installed on the laptop.
I am recording an audio track not midi. After I record a track and select or un-selecting metronome during playback has no effect I still hear the metronome click.
It seems the metronome is being recorded. It doesn't matter if I use headphones or the Yamaha built in speakers while recording the metronome plays during playback.

When I add a track the input shows Yamaha Steinberg USB ASIO 2 in 2 out and the dropdown shows Digital Piano 1+2 S

I am new to DAW's so please don't assume I know anything, please give step by step and easy to follow help.

Just let me know if I need to add any other information.
TIA
 

IMG_20220429_102535705.jpg

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0
12 minutes ago, John Vere said:

The OP is using ASIO.  The Yamaha /Steinberg ASIO driver is a good driver. The set up is that you can not only record the Midi from the piano but the audio as well. So an Audio loopback is happening from Cakewalks Master output through the piano and  back to the Audio track.   I'll assume the OP is using the Piano for monitoring playback and the metronome.  Yamaha pianos have Aux inputs that feed the output, I'll also assume the USB audio return can also be patched this way internally.  Then the audio gets re sent back to the audio track and therefore mixed in with the pianos audio recording.  

So that video will explain the workings of the metronome but I now see the correct help would be the OP needs to go into the piano's settings and disable the USB audio input being sent through to the output. This would be essential not only for the metronome but any further overdubbing. 

 

Hi John thanks for your reply to my query it got me going in the right direction.
I found on the Yamaha P-125 the G5 and G#5 keys turn the Audio Loop Back on and off.
Pressing the G5 key to turn Audio Loop Back off did the trick.
Now the metronome icons work as they should.

So if anyone else is having this problem with the Yamaha P-125 and probably other Yamaha keyboards
this is the solution. 

I have been stump by this for over two days and now finally solved. Woohoo!!!

Thanks to everyone for your help. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

In the control panel/bar next to the big clock - you should see a metronome button/logo/icon. 

Right-click on it, a window (preferences) will pop up. Locate the recording and playback little boxes  and deselect the recording box. That should work. 

If you're using it as a bus remove its output from the Master channel. 

Share this post


Link to post
Share on other sites
  • 0

Tutorial # 17 covers this. If your new to using Cakewalk you will want to watch them all.  The best way to get something done is first learn how it works. 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

In case you're not into watching videos to get quick answers, the root of the problem is likely that the Input selection in your soundcard/interface's mixer app is set to record from the output. This is not usually an issue with external audio interfaces, but is common with onboard soundcards.. Creative called this input setting 'What U Hear'. Realtek generally calls it 'Stereo Mix'. You need to change the Input selection in the mixer app to something like 'Mic/Line'.

 

 

 

Edited by David Baay

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

The OP is using ASIO.  The Yamaha /Steinberg ASIO driver is a good driver. The set up is that you can not only record the Midi from the piano but the audio as well. So an Audio loopback is happening from Cakewalks Master output through the piano and  back to the Audio track.   I'll assume the OP is using the Piano for monitoring playback and the metronome.  Yamaha pianos have Aux inputs that feed the output, I'll also assume the USB audio return can also be patched this way internally.  Then the audio gets re sent back to the audio track and therefore mixed in with the pianos audio recording.  

So that video will explain the workings of the metronome but I now see the correct help would be the OP needs to go into the piano's settings and disable the USB audio input being sent through to the output. This would be essential not only for the metronome but any further overdubbing. 

 

Edited by John Vere

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...