Jump to content
  • 0
Rick Prescott

Midiplus 62 Origin as Control Surface

Question

I just added a Midiplus 62 Origin to my studio. It has transport controls, eight programmable sliders and 8 programmable dials. It is supposedly Mackie-compatible, and I've located the setting for "Mackie On/Off." But when I add it as a control surface, I cannot open the property page (it is listed on the menu but grayed out), and the actual keyboard part stops working. Of course, the Midiplus site is no help, and the manual is not much help. Just looking for ideas on how to get these controls to, well, control something. Thanks.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

When a keyboard supports Mackie Mode, it should show two sets of MIDI ports:  one for the keyboard part, and another for the DAW control part.

It sounds like you've picked the keyboard MIDI ports rather than the DAW control ports.

Also,  unless your keyboard has a specific SONAR or Cakewalk mode, you'll need to check the "Disable Handshake" checkbox within the Mackie Control dialog under the Utilities menu.

Share this post


Link to post
Share on other sites
  • 0

azslow,

There are different versions of the manual for this keyboard, but the one I got contains a section not found in the PDF on their site:

2.2.8 Mackie on/off
When the state cannot be set to “Mackie on”, “Mackie off” can be set.
- Press the "MIDI" Button and the LED under the button will light on.
- Press a key on the Velocity key Left. The LCD screen will display the current Mackie state ("on" or "off").
- Press the "MIDI" Button again (LED lights off) to save the edit.

Despite the confusing language, I was able to figure out what this meant (basically, turn on the settings mode, and hit an unmarked keyboard key just to the left of the "Velocity" setting key), and the keyboard did respond accordingly with "On" and "Off" messages. But no joy either way in Cakewalk.

As for two sets of MIDI ports, msmcleod, that's what I expected, but it only shows one. And I should note that I cannot even open the configuration window to disable the handshake. It is listed on the Utilities menu like any other control surface, but is grayed out.

Since I posted the question, I did get the play and stop transport controls working by using ACT instead of Mackie, but again none of the other knobs could be assigned, and the music part of the keyboard still went dead.

Maybe this controller is just overpromising.

Share this post


Link to post
Share on other sites
  • 0

Taking the art of this device into account, I don't think its Mackie emulation is useful, even in case it exists. Use ACT MID, deactivate Mackie on device and remove Mackie from Control Surfaces in preferences.

Is music part works without surface modules? If yes, ACT MIDI is not blocking not assigned controls, but Mackie plug-in blocks everything.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...