Jump to content
Sign in to follow this  

Reminder: Plugin not Found (CLSID)

Recommended Posts

I write this not because I want to mention a bug.  Essentially it is not one, only a difficult to understand "feature" for the DAW user and I stumbled about it yesterday.

I like Cakewalk's Plugin Manager and working with my plugin menu layout a lot. Since about a month ago I have begun to edit my layout only on my laptop  in CbB and use it in all CbB and Sonar instances, also on other computers. So far that runs fine, even if there are not all the plugins on each PC! In the past I had a layout for each PC , CbB and Sonar and I updated the layouts in parallel, how labor-intensive! So just coping /linking the layout saves a lot of time and reduces mistakes.

But then there was that transient plugin that was grayed on my studio PC (SleepyTime Transient). First, I thought it has to do with the renaming (I had to rename this plugin in the Plugin Manager, because there was another "Transient" plugin). I tried a lot of things to fix the issue (without resaving the layout on this 2nd PC). No success!

One thing that I had noticed from the beginning is that the CLSID of the plugin was not the same on the different PCs. Searching on the internet I found out that the CLSID is a unique plugin ID generated by Sonar/CbB based on the DOS file name (8 characters + extension).

The old thread talking about it (look more at the end): http://forum.cakewalk.com/SOLVED-How-to-solve-the-quotCakewalk-Missing-Plugin-StandInquot-error-m3258647.aspx

So it depends on the install order of plugins with similar name (or in my case the missing other plugin) what DOS name they get (e.g. TRANSI~1.DLL, TRANSI~2.DLL, ...). Knowing this, I removed the plugin above, created a pseudo plugin with similar name on the same folder, copied the plugin back again and removed the pseudo plugin. Voila, now the DOS name was TRANSI~2.DLL as it had to be and it appeared in the layout again. Success!

By the way, you can display the old DOS file names on a command prompt with "dir /x".

  • Like 1
  • Great Idea 1

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this  

  • Create New...