Jump to content
Waldemar

One key stroke: two midi events shortly after another?

Recommended Posts

Hi all,

I'm using:

  • Cakewalk 2021.09 (build 145, 64 bit) 
  • Piano VST: Garritan CFX Concert Grand
  • Kawai VPC-1

I regularly encounter a situation where I play one single(!) key stroke that seems to be interpreted by Cakewalk however as two(!) separate midi-events.
The second event follows the first one very quickly in time and normally has a much lower velocity.

I'm attaching a screenshot from the piano roll view where you can see this happening on a number of occasions.
I have indicated the problem areas with green rectangles.

Does anybody have any idea as to:

  • why this happens? (no, I don't wiggle the key or something)
  • what to do about it? (of course I can fix it on a note by note basis, but that is incredibly labor intensive and I'm looking for a structural reason and solution)

Cheers,
Waldemar Moes

 

Cakewalk one key stroke two midi events.png

Share this post


Link to post
Share on other sites

I saw this here... it may be what's causing the problem. It also suggests a solution. A more permanent fix would require knowing exactly what midi data was being sent by the keyboard.

"The VPC1 utilizes a 3-sensor keyboard action that has been developed to recreate the expressive touch of a concert grand piano. However, some virtual instrument hosts and sequencing software may not interpret these triple-sensor key events correctly, potentially resulting in prematurely cut or unintentionally repeated notes, especially when playing non-piano sounds. The VPC1 incorporates a 2-sensor compatibility mode, providing a work-around for such symptoms, albeit at the expense of reduced expression and keyboard responsiveness.

To enable the VPC1's 2-sensor compatibility mode (while the VPC1 is turned on):
1. Press and hold the power button.
2. Press the bottommost (bass end) black key (A#0).


The 2-sensor mode setting will be applied to all memories globally, and will remain active even after the VPC1 is turned off. To restore 3-sensor mode, repeat the steps above."

  • Thanks 1

Share this post


Link to post
Share on other sites

Also you might be having a Midi loopback issue. The midi signal is looping back out and the midi latency re records the same note again. Make sure the VST instrument you are using has midi output disabled. 

If you are using your piano as the playback then turn off input echo while recording to the midi track. 

Share this post


Link to post
Share on other sites

This is very interesting, My Roland RD700NX does this sometimes when playing very lightly. Usually the second note is such low velocity that I can just ignore it. But if my OCD gets the better of me I will sometimes go through a recording and manually 'glue' them to restore the full duration . It typically doesn't affect more than dozen notes in a 4-minute piece so is not a lot of work, but I've recently been considering  writing a CAL script to fix them for me. 

I had assumed it was a defect in the keyboard design that it could re-trigger so easily, but I just Googled and found that the RD-700NX has a 3-sensor keyboard.  It might still be considered a defect that it's so hyper-sensitive, but it's good to know it was designed deliberately to better emulate the repetition mechanism of a real keyboard action. It does play beautifully otherwise.

Share this post


Link to post
Share on other sites

The fact that that there are three notes in a row on the same key exhibiting the problem in the OP's screenshot suggests there might be a problem with the sensors on that particular key. It's also interesting that the velocity of the 'ghost' notes is at or near zero. I'll have to check some recordings and see if any particular keys are more common offenders on my keyboard and what the velocities are; I didn't think they were that close to zero.

Share this post


Link to post
Share on other sites
Posted (edited)

I was just given a Yamaha piano and it was dead in the middle. I managed to clean it up and it’s working but that octave doesn’t respond the same as the rest now you have to hit it a bit harder. The good news is brands like Yamaha, Roland and Korg all have inexpensive replacement parts for fixing these issues. Just be prepared to remove 150 screws. 
 

I made a video about the Yamaha. 

 

Edited by John Vere

Share this post


Link to post
Share on other sites

Many moons ago, I fixed a bad key on my RD-300s by swapping a strip of velocity sensors from the top of the keyboard where I almost never play to the middle where the problem was. If it turns out the RD700NX's problem is consistently on certain keys, I might try that, but I suspect it's more widespread.

Share this post


Link to post
Share on other sites

I got a CAL script working pretty nicely for this. It's got some awkward structure in places because I haven't worked with CAL for a long time, and couldn't recall how to do some things (like getting more than one thing done in the 'else' part of a conditional). And I'm sure it could be made to run faster but it works. I haven't tested much in the way of corner cases, but could share it after I've hammered on it a bit more.

As a test project, I found a particularly bad example of a 3-minute improvisation with 49 re-triggers. The highest velocity 'ghost' was a 16 with most well below that. I was playing so lightly that many notes had velocities in the single digits all the way down to 1 and some of the re-triggers were at higher velocity than the initial note. The gaps between them ranged from 1 to 9 ticks so there's no mistaking them for deliberate repetitions.

It was an interesting exercise and will be a useful tool so thanks to the OP for getting me motivated to do it.

Share this post


Link to post
Share on other sites

Many thanks to all for replying to my question!
That's the power of the community and I really appreciate it!

Since my VPC-1 is quite new - assuming that my keys are working just fine - I focused on Variorum's and John Vere's suggestions.
I tried all four possible combinations of VST midi output enabled/disabled and track input echo auto-on.
All four still gave me the ghost notes.

Variorum's suggestion then solved the problem for me.
Luckily I am not experiencing lack of expression sofar by switching from 3 sensor to 2 sensor!

Cheers,
Waldemar

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...