Jump to content
Morten Saether

2022.02 Feedback

Recommended Posts

4 hours ago, msmcleod said:

@gmp - we've found the cause of this issue and it's been fixed for the next release.

Super news! So glad you found the bug. I've been using this method for well over 10 years with never a hitch, Thanks for your sleuth work

Share this post


Link to post
Share on other sites

Greetings,

In Track view, when I mouse over the tracks in the left pane, while a project is playing, it introduces crackling to the audio playback.

Share this post


Link to post
Share on other sites
On 3/31/2022 at 11:45 PM, msmcleod said:

It's by design.  When folders were first implemented, they weren't implemented as first class citizens like tracks are - their order is dictated by the track order.  So if a folder has no tracks in it, it's put at the bottom of its parent track. 

The main two reasons this wasn't changed when subfolders were introduced were:
1. It was quicker (and much less risky) to follow the existing design, and;
2. It provides better compatibility with older versions - i.e. you can load a newer project into SONAR, do some work, save it and it'll load back into CbB with the structure intact ( assuming you've not moved around or deleted folders too much ).

Thanks for the explanation, I appreciate it. 👍

It's definitely not a biggie, but the bottom placement behavior is a bit inconvenient when dividing up a folder with many tracks into subfolders. If you have the chance of making folders "first class citizens" at some point in the future, that would be awesome. 😃 🙏

Share this post


Link to post
Share on other sites

Not 100% sure with this update but possibly this version brought this as solo related shortcuts are introduced here.

When I set exclusive solo mode on and solo on an instrument track, and then open piano roll and write some midi noted and then click whatever note and press delete. This somehow unsolos the track. 

I checked the keymapping but delete key is not assigned to anything assigned to anything it seems.

Can anyone reproduce or only me?

This originally happened on my project file I was working on but I could reproduce it on a new project file with random instrument.

 

Share this post


Link to post
Share on other sites

I updated to 2022.02 a little while ago and just noticed a new poblem.  The New window no longer shows all the templates at all in the Start Screen or in the New window.  Where did they all go?  How do I get all the default templates back for MIDI and Audio and channel selections.  I know I can make my own, but I want the defaults like I used to have them.  thanks for any help!

Share this post


Link to post
Share on other sites
2 hours ago, whipsmart said:

I updated to 2022.02 a little while ago and just noticed a new poblem.  The New window no longer shows all the templates at all in the Start Screen or in the New window.  Where did they all go?  How do I get all the default templates back for MIDI and Audio and channel selections.  I know I can make my own, but I want the defaults like I used to have them.  thanks for any help!

Check your template folder within preferences, and then navigate there within Windows Explorer to check the template files are there:

image.png.d399f2468a10ad441d9b43ded9b00843.png

If you've changed the template locations, you can copy the templates from the default location (shown above) to your new location.

If this still doesn't fix the problem, delete the following file before opening Cakewalk:

%APPDATA%\Cakewalk\Cakewalk Core\Offline.html


 

  • Like 2

Share this post


Link to post
Share on other sites

Was this mentioned? In Track View I am unable to move a track to the bottom of the list if a Track Folder exists there. It will automatically be included in the Track Folder instead. Even the move line disappears indicating it won't move there.

Share this post


Link to post
Share on other sites
On 4/22/2022 at 5:16 PM, sjoens said:

Was this mentioned? In Track View I am unable to move a track to the bottom of the list if a Track Folder exists there. It will automatically be included in the Track Folder instead. Even the move line disappears indicating it won't move there.

I had this type of experience but here is what I found out:

1)  IF the last track in the track view is a folder AND that folder is collapsed.  Grab your track (that you want to move) with the double up/down arrows and move it below your folder and place the double arrow as far LEFT as it will go, then release.   Your track should drop to the bottom and not be in the folder.

2) IF the folder is the last item in the track view, and the folder is expanded.  The track indicator (should be a colored line) will indicate where it will drop.  If it aligns with the last track in the folder - it ends up in the track.  IF the colored line is aligning to the extreme left (of the track view) then is should drop outside of the folder.

Set a dummy project and try these moves and you will get a hang for it.   The second method is the most accurate for doing this.  I think that it would be nice if the "track line" showed up when the folder was collapsed.   I would have included some screen shots, but I must in a bit.

I just tried this several times to be sure that what I saying above works - At this time I thing it is just a technique you have to get used to.  Once you get it working for it does not seem to be a big problem.

Oh, and if your folder is in the middle of you track view - watch the "track line"  - if it aligns with the folder, it goes into the folder.  If it touches to the far left, it sits below the folder by its self.

Hope this helps.

Syphus

Share this post


Link to post
Share on other sites

I see, thanks. It works but how silly when it used to work more intuitively. Something should be so simple now needs a learning curve or help.

"Let's make the visual que disappear so users will panic!" :S

Share this post


Link to post
Share on other sites

Hello!

At the risk of asking one question: since the old versions of Sonar, very rarely in single projects, after saving (manually) a working project, when trying to close the Cakewalk, a window appears with the options "Save; NO (do not save) and Cancel". If you select " NO", then the last changes in the project are not saved, despite the fact that before that I saved the project by clicking the "Save" option. I specifically checked it many times - I save the working project, then I specially add a few tracks, or make any other changes, save again, then close the project, this window appears with save options, if I select "No", then the next time I open the project, the added changes will not are saved. I still have the "Autosave" option activated, and it works as expected, it's very strange.

I do not consider this a serious "problem", but I would like to know at least the approximate reasons for this behavior of Cakewalk in single projects.

Thanks in advance for any ideas and tips!

Share this post


Link to post
Share on other sites
1 hour ago, IgoRr said:

Hello!

At the risk of asking one question: since the old versions of Sonar, very rarely in single projects, after saving (manually) a working project, when trying to close the Cakewalk, a window appears with the options "Save; NO (do not save) and Cancel". If you select " NO", then the last changes in the project are not saved, despite the fact that before that I saved the project by clicking the "Save" option. I specifically checked it many times - I save the working project, then I specially add a few tracks, or make any other changes, save again, then close the project, this window appears with save options, if I select "No", then the next time I open the project, the added changes will not are saved. I still have the "Autosave" option activated, and it works as expected, it's very strange.

I do not consider this a serious "problem", but I would like to know at least the approximate reasons for this behavior of Cakewalk in single projects.

Thanks in advance for any ideas and tips!

My Cakewalk start with the "basic" template. Empty. I then open one of the saved projects in my list and continue to work on that.

I seldom remember to close the "basic" template so it still is there in the background.

I then save the work in the open project and close Cakewalk with the "X" exit button. The save question come up and i say no. When i start Cakewalk next time and open the project i was working on it have saved the things i told it to save.

First times the save scenario happen it had me wondering why. Because i knew i had saved my project that i worked on. I now get it that it has to do with my start template window. Even without doing anything in it, it ask me if i want to save it. It obvious has to do with the template turning itself into a project just by being opened.

I like to look at a track view with something in it on start so i keep saying no to saving the hidden empty project. 🙃

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Kurre said:

First times the save scenario happen it had me wondering why. Because i knew i had saved my project that i worked on. I now get it that it has to do with my start template window. Even without doing anything in it, it ask me if i want to save it. It obvious has to do with the template turning itself into a project just by being opened.

Many years ago, I did this too, but then I just made my own "template" with fully configured options, a certain number of tracks, groups and buses, added "standard" plugins, customized display of meters, and now I always open it at the beginning so as not to deal with this every time again.

And if I start a new project, I immediately rename this open "template" to what the next project will be called, and save it with this new name. And everything (99.9%) is perfectly preserved, without the slightest anomalies. But, in isolated cases (as I said earlier), an already finished project (without opening a "template") is not saved in any way by standard actions, the last changes are saved only when the project is closed by selecting "Save" in the save options window.

Edited by IgoRr

Share this post


Link to post
Share on other sites

@IgoRr

Well then. My guess would be about what has the focus for the time when you are saving. You're not saving what you think you're saving.

Share this post


Link to post
Share on other sites
1 hour ago, Kurre said:

You're not saving what you think you're saving.

You inattentively read my words, if all (!!!) my projects behaved with such deviations, then your assumptions could make sense. But I always save projects in the same way, and in 99% the saving happens properly without any additional actions or expectations. And in quite isolated cases, such an anomaly occurs, which I wrote about in great detail in the very first post.

Share this post


Link to post
Share on other sites
3 hours ago, Kurre said:

Sorry if i made you angry

Absolutely not, where did you get it? Simply, you repeated 2 times essentially the same thing, which is a bit different from what I spoke about at the very beginning in great detail.

Share this post


Link to post
Share on other sites

I seem to have had a number of crashes in this version or perhaps the last few versions, but basically it happens when working with clip gain sometimes it just completely dumps me out of the DAW.

Share this post


Link to post
Share on other sites

noting a similar crash with a PA bx_plugin which was solved by reverting to a previous version of the plugin as well as a number of screen draw bugs littering the screen with leftover bits that persist for the entire session. annoying, but not a shostopper. other than that, it's been running quite well.

Share this post


Link to post
Share on other sites
On 5/23/2022 at 1:50 PM, IgoRr said:

Absolutely not, where did you get it? Simply, you repeated 2 times essentially the same thing, which is a bit different from what I spoke about at the very beginning in great detail.

I have never had a CTRL-S or a  menu - file - save not save a song unless my drive was corrupted.

I am still paranoid about losing hard work done on a song so-

I always use "save as"  This allows me to have multiple backups ->

Song 01

save as Song 02

save as Song 03

And if I press CTRL-S between the numbered ones, I get the "Cakewalk" backup file.  Song 03.cwp.~2022-05-31-00-45-03-717

(These are hidden to Cakewalk until you rename them and take off the .~2022-05-31-00-45-03-717 part)

 

You might have some hidden backups in the directory of your song. File Explorer will see them.  You can rename them.

You might have to use Song 03b.cwp because the file name Song 03.cwp might already be in use.

I don't want to make anyone mad either lol!!!  I hope you already do incremental backups and don't need any of this.

Are you using CTRL-S or the menu file-save? Did you look for the cakewalk backup?

 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...