Jump to content
Morten Saether

2022.02 Feedback

Recommended Posts

@IgoRr - the dump file would seem to indicate some heap corruption, but I can't see how this error could occur. 

Can you PM me your project?  I've tried to build up a similar project, but everything is working for me.

Share this post


Link to post
Share on other sites
13 minutes ago, msmcleod said:

Can you PM me your project?  I've tried to build up a similar project, but everything is working for me.

It wasn't any specific project, I just jotted down a few dozen random notes on one track, copied it 4 times to other tracks, copied all those tracks, and then pasted (Paste Special) all those tracks into a new empty project with the option selected "new track". It was just a test of the crash that my friend told me about. You can try to do exactly the same thing that I told you, it will be interesting to see if the insert works for you under the same conditions.

Edited by IgoRr

Share this post


Link to post
Share on other sites
45 minutes ago, IgoRr said:

It wasn't any specific project, I just jotted down a few dozen random notes on one track, copied it 4 times to other tracks, copied all those tracks, and then pasted (Paste Special) all those tracks into a new empty project with the option selected "new track". It was just a test of the crash that my friend told me about. You can try to do exactly the same thing that I told you, it will be interesting to see if the insert works for you under the same conditions.

I've tried various combinations (e.g. copying the tracks, copying just the clips from 4 different tracks,  normal copy, copy special etc), and all are working fine for me.

  • Thanks 1

Share this post


Link to post
Share on other sites

@msmcleod 

I'll try different options for such copying, maybe it was one random crash. That friend of mine has a rather weak computer, for copy-paste he is forced to first create a new project, close it, open a project with source material, copy tracks, close it again, open a new one, and only after that paste, he does not open two projects at the same time.

Thank you very much for your attention and time!

Edited by IgoRr

Share this post


Link to post
Share on other sites

I can't tell if this is due to 2022.02 or if this always happens when we upgrade, but all of my control surface configurations do not work anymore. I use AZ Controller for DAW control and it does not even receive midi events at all as I can see in its UI. I also use ACT Midi Controller for plugin control and it does receive midi but all my previous plugin configurations do not work at all. Hopefully there are ways to get these back but I haven't tried anything yet.

Edit: Ok, I removed AZ Controller and ACT MIDI Controller from the Control Surfaces, in preferences, and added them back in. I now have control back through AZ Controller for DAW functionality as I had before. But for plugin control through ACT MIDI Controller I lost all my assignments.

Where are ACT assignments saved? In what file? I am ok with having to save and restore a file before installing if that is possible. But it still would be nice that control surfaces work as before after an update.

Edited by Jacques Boileau

Share this post


Link to post
Share on other sites

Something is eluding me. Never experienced this before and i can't seem to figure this out. The clips doesn't line up with the snap settings on the grid at the end of the clip. So when ever I duplicate the clip, its out of time with the the project tempo - either before or slightly late in time. 

 

Edited by Will_Kaydo

Share this post


Link to post
Share on other sites
20 minutes ago, Will_Kaydo said:

Something is eluding me. Never experienced this before and i can't seem to figure this out. The clips doesn't line up with the snap settings on the grid at the end of the clip. So when ever I duplicate the clip, its out of time with the the project tempo - either before or slightly late in time. 

This is a setting on the Editing tab of the Preferences:

image.png

 

Otherwise it will duplicate the exact clip length on purpose.

Share this post


Link to post
Share on other sites
1 hour ago, Jonathan Sasor said:

This is a setting on the Editing tab of the Preferences:

image.png

 

Otherwise it will duplicate the exact clip length on purpose.

They were all ticked, so, that doesn't seem to be the case. 

UPDATE: Found the culprit in  Preferences>Customization>Snap to Grid. Under Magnetic Test: Snap to Nearest Audio Zero Crossing should be unchecked. 

Now the question is: How did that get selected? 🧐

Edited by Will_Kaydo
  • Like 1

Share this post


Link to post
Share on other sites

I don't see how your video relates to Duplication, but that looks like maybe you have Snap to Zero Crossing enabled...?

EDIT: Oh, I see you discovered that.

.

Edited by David Baay

Share this post


Link to post
Share on other sites
1 minute ago, David Baay said:

I don't see how your video relates to Duplication, but that looks like maybe you have Snap to Zero Crossing enabled...?

.

Try it. 

Share this post


Link to post
Share on other sites
1 minute ago, Will_Kaydo said:

Try it. 

Yeah, I can imagine Snap to Zero Crossings would affect duplication as well; I just meant your video isn't showing duplication; it's showing slip-editing.

Share this post


Link to post
Share on other sites
18 minutes ago, David Baay said:

Yeah, I can imagine Snap to Zero Crossings would affect duplication as well; I just meant your video isn't showing duplication; it's showing slip-editing.

I think you've misread what I had said. Cropping the clip did not crop/snap to the grid. It either cropped it before or after the grid line - meaning: when ever i duplicate (as what was said above) the clip either go sits infront of the grid line or after right against where cropped clipped ended. So, it gets thrown out of the project tempo. 

The second video shows me in the editing tab in preferences as what Jonathan suggested, but I never have them selected. That's why i unchecked them and selected them again. (Hence me "questioning" why these 2 with the snap to the nearest zero crossing were selected.) So, clip duplicate was just mentioned because it was affected by the zero crossing snap, seeing its in the steps i was doing while discovering this. I dont use any other steps when wanting to copy or paste something. I duplicate and delete what I dont need. Its works faster foe me. Anyway, it was about slip snap. 

Edited by Will_Kaydo

Share this post


Link to post
Share on other sites

after reinstalling version 2022.02 i cant find the demo projects that were part of the cakewalk by bandlab daw for reverse engineering and demonstration of how the power usage of it sounds like. Why cant i find the default demo projects in the daw or in it "audio data" directory ?

and ive observed a very clean install of the daw. need further assistance with this.

best regards - #SOMETHINGELSE

Share this post


Link to post
Share on other sites
3 minutes ago, SomethingElse Osey said:

after reinstalling version 2022.02 i cant find the demo projects that were part of the cakewalk by bandlab daw for reverse engineering and demonstration of how the power usage of it sounds like. Why cant i find the default demo projects in the daw or in it "audio data" directory ?

and ive observed a very clean install of the daw. need further assistance with this.

best regards - #SOMETHINGELSE

Demo projects install to C:\Cakewalk Content\Demo Projects by default, and should appear as a separate tab on the Start Page once installed. If you need to reinstall the demo projects, they're available from the Cakewalk Web Installer.

Share this post


Link to post
Share on other sites

Alright Team, how do i permanently remove "melodyne 5" from PC so that it doesn't appear in my "bandlab assistant" account as checked?
please relay a feedback.

best regards
#SOMETHINGELSE 

Share this post


Link to post
Share on other sites

Alright Team, how do i permanently remove "melodyne 5" from PC so that it doesn't appear in my "bandlab assistant" account as checked?
please relay a feedback.

best regards
#SOMETHINGELSE 

Share this post


Link to post
Share on other sites

reinstalling the demo projects from "CakeWalk web installer" did not work.
please fix this in future updates because i dont understand why my DAW is in malfunction state after following through with basic steps during installation.

#somethingelse

Share this post


Link to post
Share on other sites

since 2022.02 VST scan exceedingly slow for some plugins- taking 2minutes per plugin - 45mins to load all of mine that used to take a minute or so (even tho I have a lot of them).

This has occurred on 2 machines I have BL Cakewalk installed on. I can remove folders then it scans quicker, but that doesn't solve the problem as I am missing plugins.

I have done a manual scan to grab the logfile. Prior to 2022.02 I had no problems.

This is just one example  of many:

Thursday, 24 Feb 2022, 15:23:26 
-------------------------------------------------------------------------
LogFile: C:\Users\Paul\AppData\Roaming\Cakewalk\Logs\VstScanSandbox.log
Thursday, 24 Feb 2022, 15:23:26 
Opened Log File -----------------------------
Command line: /VSTRegPerUser/VSTRegKey:"Software\Cakewalk Music Software\Cakewalk\Cakewalk VST X64"/Background/NoRescanning/SONARHWND:1115758/ScanVst:"c:\program files\common files\vst3\bx_shredspread.vst3"/ToastGuid:{8AA18684-EA94-41D0-89BB-9301F34F6191}
Flag: VSTRegPerUser
Flag: VSTRegKey:"Software\Cakewalk Music Software\Cakewalk\Cakewalk VST X64"
Flag: Background
Flag: NoRescanning
Flag: SONARHWND:1115758
Flag: ScanVst:"c:\program files\common files\vst3\bx_shredspread.vst3"
VST to scan - c:\program files\common files\vst3\bx_shredspread.vst3
Flag: ToastGuid:{8AA18684-EA94-41D0-89BB-9301F34F6191}
VSTSCAN: ******* Analyzing VST plugins...
VSTSCAN: ---- 1: c:\program files\common files\VST3\bx_shredspread.vst3 ----
VSTSCAN: [ShortPath] c:\PROGRA~1\COMMON~1\VST3\BX_SHR~1.VST
VSTSCAN: [RegKey] Software\Cakewalk Music Software\Cakewalk\Cakewalk VST X64\Inventory\c:/program files/common files/VST3/bx_shredspread.vst3
VSTSCAN: ---- Loading VST plugin c:\program files\common files\VST3\bx_shredspread.vst3 ----
VSTSCAN: VST plugin successfully scanned
VSTSCAN: WRITE VST DATA...
VSTSCAN: WRITE VST DATA - successfully wrote complete VST plugin inventory record...
VSTSCAN: Finished analyzing VST plugins - 1 of 1 VST plugins were scanned in this run
Closing log file
Thursday, 24 Feb 2022, 15:25:36  

VstScanSandbox.log.txt

Share this post


Link to post
Share on other sites
23 hours ago, SomethingElse Osey said:

reinstalling the demo projects from "CakeWalk web installer" did not work.
please fix this in future updates because i dont understand why my DAW is in malfunction state after following through with basic steps during installation.

#somethingelse

Can you elaborate on the problem? What demo projects are you looking for and where are you trying to find them? There are 2 currently shipping demo projects, "Sophia Jane - Living For Now" and "LORD - Time to Fly". The demo projects installer launched by the Cakewalk web installer places these into your existing Cakewalk Content folder, defaulting to C:\Cakewalk Content\Demo Projects

 

45 minutes ago, Under A Mile said:

since 2022.02 VST scan exceedingly slow for some plugins- taking 2minutes per plugin - 45mins to load all of mine that used to take a minute or so (even tho I have a lot of them).

This has occurred on 2 machines I have BL Cakewalk installed on. I can remove folders then it scans quicker, but that doesn't solve the problem as I am missing plugins.

I have done a manual scan to grab the logfile. Prior to 2022.02 I had no problems.

If you turn off sandboxing for the plugin scan does it complete normally? 

  • Thanks 1

Share this post


Link to post
Share on other sites

hi, before I saw your last message I rolled back to 2021.12. I scanned with the settings as per screenshot (no project loaded)- sandbox off - it took longer than I remember in the normal case, but it completed in 5mins (~10x faster than what I was seeing) I have loaded my project up and it's doing the same.

Let me know I can replace 2022.02 - but I think I didn't usually have sandbox ticked (if it's not a default) IIRC I ticked it just out of curiosity.

scan-BL.PNG

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...