Jump to content
jmp909

Groove Clip Looping bug after edit?

Recommended Posts

Hi,

New Cakewalk user here...please excuse me if I've misunderstood something here!

I'm not sure if this is a bug but it doesn't seem intuitive:

  • create a 1 bar midi clip with a 1/16th note on C3
  • convert to Groove Clip Loop (Ctrl + L)
  • stretch out to 2 bars (observe C3 note is repeated on Bar 2 as expected)
  • add a 2nd note (C4) in Bar 1 (observe note is not repeated in Bar 2)
  • stretch clip out to 4 bars

=> observe Bar 3 and 4 both have the2 notes, duplicated from Bar 1, but Bar 2 doesn't

What should be the expected behaviour here?

thanks

J

image.png.d060c80af14eaf172392bbb9ffe5b02a.png

Share this post


Link to post
Share on other sites
20 minutes ago, Kevin Perry said:

That is working as expected.  Bar 2 isn't part of the original groove clip which is being rolled out.

Thanks for the info. Makes sense I guess.

I've discovered if I want to make the 2-bar clip be the new loopable Groove Clip then I can "Bounce to clip", correct the length (since it clips any blank space off the end), and then convert back to a Groove Clip

(Leaving this here for reference)

1) Add 2nd note to Bar 1 of Groove Clip

image.png.93269f5243a9cfd90cb76e28a8aa73e0.png
 

2) Bounce to clip (length needs fixing)

image.png.a1d9de6972d4393fd49936de05b7f3bc.png


3) Fix length to 2 bars and convert back to Groove Clip - now repeats as expected

image.png.ab3a208764b7f0977140959f130c417c.png

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...