Jump to content
  • 0
DSL

external controller

Question

Hi,

I have been looking at the Presonus single fader control surface but it doesn't say if it will work with Cakewalk. Does anyone happen to know?

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

I'm not sure I fully understand - if I get one will it not work at all, or will it just have limited functionality unless I upload the file you show?

Share this post


Link to post
Share on other sites
  • 0

The device will not do anything in Cakewalk out of the box. With Cakewalk standard surface plug-ins you can get partial functionality, like transport, but it will be rather limited (no LEDs, touch sensitive motorized fader will work as dummy fader, etc.).

If you install AZ Controller and use mentioned preset for it, the device will have reasonable functionality in Cakewalk (and with some effort you can adjust/extend it).

Share this post


Link to post
Share on other sites
  • 0

Greetings! I am trying to install the Faderport V2 with AZ Controller (or any other controller, for that matter) but not having any luck. I would appreciate any help!

Here is what I have done:

Requirements
1. Download and install the latest AZ Controller (http://www.azslow.com/index.php?action=downloads;sa=view;down=28).    Done
2. Put Faderport into native mode (as in the documentation).      Done as in fig.1
3. Install attached preset using Cakewalk Plug-in Manager            Fig. 2
4. In Sonar Preferences, Control Surfaces check that AZ Controller MIDI input and output are set correctly to Faderport.      Fig  3 & 4
5. Select the preset (AZ Faderport V2) in AZ Controller (when updating preset, do not forget to "re-select" it after installing).    Fig. 5

I have tried installing other controllers- ACT, various Mackies, with native mode selected and not selected, but not managed to have the Faderport operate at all- zero. Can you tell me what I must be missing?

Thanks in advance, dennish

 

Faderport Native.JPG

AZ Controller preset install.JPG

Preferences 1.JPG

Preferences 2.JPG

AZ Controller preset installed.JPG

Share this post


Link to post
Share on other sites
  • 0

In Cakewalk Preferences, visit MIDI/Playback and recording section and make sure at least Notes, Controller and Pitch Wheel are checked in the Record section.

In the Windows task bar, where app icons like language switch, sound controls, etc. are, you should see MIDI icon from Cakewalk (when it is running). When you operate the unit (f.e. Move fader, press buttons), "LED" on this icon should blink (a bit hard to see, they just change the color a bit).

Do you have other MIDI devices which are working properly?

 

Share this post


Link to post
Share on other sites
  • 0

Thanks for the quick reply!

In Cakewalk Preferences, visit MIDI/Playback and recording section and make sure at least Notes, Controller and Pitch Wheel are checked in the Record section.

Done

Do you have other MIDI devices which are working properly?      My keyboard is working normally (with Addictive Keys)

In the Windows task bar, where app icons like language switch, sound controls, etc. are, you should see MIDI icon from Cakewalk (when it is running). When you operate the unit (f.e. Move fader, press buttons), "LED" on this icon should blink (a bit hard to see, they just change the color a bit).

The icon blinks when the keyboard is operated

I have gone back to the documentation and tried to get the Faderport working in Studio One. It says that a firmware download is needed to bring it to Faderport 2018 which i have done, but Studio One does not show  the required Faderport 2018 selection when I go to add an external device as directed. (And now cakewalk does not see the faderport at all)

I have sent a query to Presonus- hopefully they can set things straighter. I will report back here what happens. Thanks again.


 

Midi Devices.JPG

MIDI-Playback.JPG

Share this post


Link to post
Share on other sites
  • 0

Update: After a long back and forth with Presonus technical support, the device was diagnosed with "connectivity problems", i.e. not working.They referred me to a repair place in Saskatchewan (I am in British Columbia). That's kind of like Seattle to Kansas City! But, thankfully, the vendor eventually agreed to accept a return. 

I am leary of trying another Faderport after putting in this many hours of time for nothing- maybe there is another option.

Share this post


Link to post
Share on other sites
  • 0

There was not many single track controllers: Faderport Classic (old one, discontinued), Faderport V2 (which you have tried), Frontier Alphatrack (old one, discontinues) and Behringer X-Touch One.

Any of them can work throw AZ Controller (when hardware works). May be you can find locally second handt Faderport Classic or Alphatrack for cheap (with check possibility).

Any controller can have initial problems or stop working later (especially touch sensitive motor fader).

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...