Jump to content
cldmrqs

Cakewalk crash after trying setting my controller

Recommended Posts

Hi all,

I think I hurt Cakewalk pretty badly after trying to configure my M audio Hammer 88 Pro oping to start to use all the DAW buttons (yet to configure in the controller). BTW, anyone has done this ? Is there an editor preset file that exists already somewhere ? Can't find it.

Anyway, I was trying to set up the input ACT and Mackie controller in the preferences. I was following instructions that I found on the net and was supposed to be helpful.

Now, I get instant crash whenever I try to launch Cakewalk.  A restart does nothing. I have a crashdump file if it can be helpful.

Can anyone help me, please ? Thanks in advance.

Claude

Share this post


Link to post
Share on other sites

To get Cakewalk working again, probably disconnecting the keyboard and starting Cakewalk will work (cleanup MIDI and Control Surfaces in Preferences, exit, connect the keyboard again and start Cakewalk again).

If not, delete TTSSEQ.INI and ctrlsurface.dat in the %APPDATA%\Cakewalk\Cakewalk Core folder.

Before configuring surface in Cakewalk, check you have chosen Mackie mode. From the documentation I guess you can try to select Studio One or REAPER  (see keyboard documentation how to select target DAW).

You need to enable correct MIDI ports first. Do NOT enable all of them! Try enable just the first one and play some soft synth with keys. Probably that should work (different sources in the Internet mention different numbering), if not enable one after another (disabling previous) till you find "keyboard" MIDI port.

Enable DAW ports (Input and Output), all sources suggest they should be the 3d. Add Mackie and assign these ports (so most probably 3d) to it. Try some DAW operations. If not working, open Mackie interfaces (from Utilities menu in Cakewalk) and set "Disable handshake".

If (and only if) everything works so far...

If you have some hardware connected to physical MIDI (5 pin) ports of the keyboard, you can enable port 2.

There is one pair of ports for M-Audio Editor, enabling them in Cakewalk is looking for troubles (by default keyboard sends some information to all enabled ports, who know how EDITOR port interpret that).

In case you want add ACT, assign the same port as you use for keys to it (NOT port you use for Mackie).

I hope that helps. Note that I don't have that controller, all suggestions are from device documentation (and personal experience with Cakewalk).

Share this post


Link to post
Share on other sites

Hi azslow3.

I removed the two files and I managed to launch Cakewalk with no more issues. Yeah !! I did a little test and after replacing one or the other file in the core folder and relaunching Cakewalk, I think it is the ctrlsurface.dat that was at fault.

I am going thru your information and tips to add DAW control.  I hope I will succeed.

Thanks for your help. It is really appreciated !!

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...