Jump to content
Sign in to follow this  
Anders Madsen

MCU support for Komplete kontrol seems to be on its way

Recommended Posts

2 minutes ago, Moxica said:

This is where I'm experimenting with different combos between the two devices.. (Still no luck)

Control surfaces.jpg

The In Port should be set to "Komplete Kontrol A DAW", and the output "Komplete Kontrol A DAW".

The other interface is for the keyboard itself.

Oh, and it won't work setting the control surface to "Mackie Control" - that's Cakewalk's one.

Set it to "MMcL Mackie Control #1" and check the "Disable Handshake" in the dialog.

Edited by msmcleod
  • Thanks 1

Share this post


Link to post
Share on other sites

So it would seem.
I am generally struggling with understanding MIDI. I do not understand why the keyboard is listed as output, and it is a tad confusing to me.

Share this post


Link to post
Share on other sites
3 minutes ago, Moxica said:

So it would seem.
I am generally struggling with understanding MIDI. I do not understand why the keyboard is listed as output, and it is a tad confusing to me.

That's quite common with Windows MIDI devices.

However, in NI's case it may actually be used for updating the display when using Kontakt?

Share this post


Link to post
Share on other sites
7 minutes ago, Moxica said:

This constellation seems to make most sense:

 

Mackie.jpg

Is it working with this setup?

If not, check:

1. Disable Handshake has been checked with in the dialog - save this setting as a preset.

2. The Kontrol is set to MCU mode

Then:

Shutdown Cakewalk

Turn your Kontrol off and back on

Start Cakewalk again

 

One more thing... don't play with the transport buttons while the MackieControl config dialog is up. It can crash Cakewalk. This is an issue with all the control surface config dialogs.

Edited by msmcleod
  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks a big bunch, msmcleod.
I believe I'm getting closer.  But:
How do I set the Kontrol to MCU mode?

Edited by Moxica

Share this post


Link to post
Share on other sites

Thanks msmcleod, got my a49 transport controls to work (using your Mackie surface enhancement), now off to try with Studio One.  Or maybe quit while I'm ahead and play with it here in CbB.  My a49 just arrived yesterday, so this update to Komplete Kontrol came at a very good time for me.

Share this post


Link to post
Share on other sites
9 minutes ago, shawker said:

Thanks msmcleod, got my a49 transport controls to work (using your Mackie surface enhancement), now off to try with Studio One.  Or maybe quit while I'm ahead and play with it here in CbB.  My a49 just arrived yesterday, so this update to Komplete Kontrol came at a very good time for me.

What did you update? 
My only download was for Komplete kontrol application. I can not find any new firmware.

Share this post


Link to post
Share on other sites
25 minutes ago, Moxica said:

How do I set the Kontrol to MCU mode?

I didn't have to do anything.  It seems setting up the midi devices properly takes care of it.  I have Komplete Kontrol running in this project, and can play and record midi with it, and the transport controls work as expected.  Pressing SHIFT and the middle button on the right changes the KK mode from plugin to midi, but it works in either mode.

Share this post


Link to post
Share on other sites

I did a firmware update yesterday, I think the first time I launched KK.  It downloaded a firmware updater that had to be run separately.  Don't recall where it can from or if it is relevant to this functionality or not.  I will check to see if I can find the link.

Share this post


Link to post
Share on other sites
3 minutes ago, Moxica said:

But what updates did you perform?
I only got to update the Komplete kontrol appliocation.

My a49 arrived yesterday, so it's firmware was not current.  You may already have the current firmware.  I updated KK from Native Access, the firmware updater came from somewhere else

Share this post


Link to post
Share on other sites

I ran that one, but it reports no newer versions.
I wonder where the update that provides MCU support is?
Is it the komplete kontrol app only?

Share this post


Link to post
Share on other sites

OK, finally got it working for both at the same time! 

in frustration before, I just shut down CbP  and walked away for a while, restarted CbP and it was working.

Transport Control works, 4-way Encoder works (turn to scroll timeline, click up down to move tracks, click left right to scroll through track property fields)

for Mute,Solo and Arm, once highlighted, just press Enter on your keyboard to engage/disengage.  Fields with Context Menus, press enter, up/down arrow to highlight a selection and enter again.

Keyboard works, plays any VSTi in the synth rack...

Also works perfectly with Komplete Kontrol Plugin.

Maybe the fact that I was frantically changing drivers that it (or I ) got confused and restarting/walking away just made everything fall into place.

Peace

 

Blindeddie

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Moxica, is the play button green, and the record red (on your keyboard)?  If not press SHIFT and the middle button on the right (above the big wheel) to change modes.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...