Jump to content
Sign in to follow this  
white flowers

should ripple editing produce an automatic crossfade?

Recommended Posts

In Samplitude, for example, deleting a section of audio with ripple editing  with (auto crossfade turned on) results in a crossfade at the new join. I'm not seeing this behavior in Cakewalk. Is there a setting I can toggle? I can't think of a reason why, if I didn't want a crossfade after ripple editing, I couldn't just turn off automatic crossfades for a moment. Thanks!

Edited by white flowers

Share this post


Link to post
Share on other sites

You really only get a crossfade when things overlap and if you ripple edit, only the part you delete would be removed - nothing on either side would be overlapping, so this is working as I'd expect.

I could see this being a big can of worms if there was an option to automatically crossfade a certain amount of either side after the section was removed.  We have looping groove clips, MIDI and automation which may not correspond correctly with what the audio is now doing, or some clips may not have that data at the start to fade past the cut if you do a Ripple All on the project.... I think this would be super tricky to get right to cover all scenarios in complex projects.

Share this post


Link to post
Share on other sites

Auto-crossfade can easily be turned off. Since ripple editing is already kind of a specialized use case requiring attention to the ripple-edit state, and since the auto-crossfade button is right next to the ripple-edit button, it's reasonable to expect to attend to the state of auto-crossfade.

On the other hand, it's pretty much always going to be necessary to crossfade at the point where newly ripple-edited clips join - at least if you're editing a classical music performance, for example, which is a common use-case for ripple editing. I can see how with more midi-oriented music it could be complicated, but again, that's when you simply turn off the automatic crossfade. Those scenarios already exist, anyway, since if for example you quasi-ripple-edit manually by selecting everything after a section and moving it to the left, the automatic crossfade happens as expected.

In the interesting case where there is no data at the beginning of a clip, Samplitude simply does not apply the auto-crossfade. Samplitude's ripple-editing is imported from Sequoia, widely recognized as an excellent implementation of ripple editing. Since in Cakewalk it's possible to drag a clip beyond the boundaries of its audio (not possible in Samplitude), an easily implemented solution would be to just crossfade away, exactly as happens if you do it manually. This would require attention from the editor, but again, ripple-editing already requires attention.

So: it's easy to disable auto-crossfade whenever necessary, but currently impossible to have automatic crossfades after a ripple delete. Having those crossfades would improve the workflow.

Edited by white flowers

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...