Jump to content
Ann Ominous

Setting up Roland V-Drums

Recommended Posts

I just purchased a Roland TD-1 V-drums unit, and I can't figure out how to get it to work.

It's connected to my laptop through a USB port, but when I add a MIDI channel and try to select it as the input, it doesn't show up. I've tried setting the track to Channel 10, and I've also added the SI Drum Kit instrument plugin, but that ends up creating its own track and I can't map that to the controller either.

I'm sure there's some simple thing that I'm missing, but I've never done this before and I can't figure out how to set it up so that I can play and record drums through Cakewalk.

Any tips? If more information is needed, I'm happy to provide whatever I can. 

Share this post


Link to post
Share on other sites

Okay, this is getting really annoying. Is anyone else using the TD1-DMK unit through Cakewalk and if so, what is their experience?

It's inconsistent in recognizing when the device is connected, and in playing the soft synth drums when it does recognize it (i.e., half the time there's no sound produced, even when I can see that the soft synth is being triggered when I hit one of the pads). 

And when it is "working," there's a major delay that makes it impossible to use.

So at this point I'd be interested in hearing if anyone else is using them and, if so, what they've had to do to get them to work well.

Edited by Ann Ominous

Share this post


Link to post
Share on other sites

I don’t have a Roland but I use a Yamaha kit. They are all the same watch this video which covers the details of troubleshooting midi issues 

 

  • Like 1

Share this post


Link to post
Share on other sites
18 hours ago, John Vere said:

I don’t have a Roland but I use a Yamaha kit. They are all the same watch this video which covers the details of troubleshooting midi issues 

John, thank you very much! GREAT video! A couple of comments:

  • You could make a short video of how to connect your MIDI drums if you're an idiot. The steps  would  be:
    1. Watch the above video on how to connect MIDI instruments in Cakewalk
    2. Once you've connected your MIDI instruments, CHECK TO MAKE SURE NONE OF THE OTHER TRACKS ARE SET TO SOLO! 

            Yeah, I'm an idiot. Turns out it was working fine from the very outset, I just had one of the tracks set to solo so none of the other tracks could actually output any sound. 🤦‍♂️

  • Even though I figured out what the problem was, I'm still really glad I watched your video. It was incredibly helpful. So much so that I'll have to watch it again. I'm very impatient, and I immediately set the playback speed to 1.5. I do this with all instructional videos I watch, and usually it's exactly what I need. But in this case about halfway through it became evident to me that there was a ton of great information in this video, and I was going to have to watch it again at normal speed so I could truly learn how to really get started with MIDI.

Again, thanks very much, REALLY appreciate the help! 

Edited by Ann Ominous

Share this post


Link to post
Share on other sites

Thanks for the positive feedback. I just posted another that’s all about setting up your VST’s. 

 

Edited by John Vere

Share this post


Link to post
Share on other sites

Since I can't delete a post, I'll just edit it with this note. Found the answer to the problem I was working on with this post.

Edited by Ann Ominous
Because I can't delete my own post.

Share this post


Link to post
Share on other sites
16 hours ago, Ann Ominous said:

Since I can't delete a post, I'll just edit it with this note. Found the answer to the problem I was working on with this post.

You can edit your posts title to read "solved". If someone else has a similar problem, they can read how you fixed it.

Share this post


Link to post
Share on other sites
3 hours ago, 57Gregy said:

You can edit your posts title to read "solved". If someone else has a similar problem, they can read how you fixed it.

Fair point, and in fact, my issue did not get resolved.

When I create MIDI tracks in CW, I'm not getting the channel/bank/patch drop down lists in the track controller. My worskpace (upper right corner of the UI) was set to None, and I changed that to Advanced when I was first running into the issue, which appeared to have fixed it, but for some reason, now, even though I still have the Workspace set to Advanced, I'm not seeing these drop downs. Any help anyone can provide is appreciated, thanks!

Share this post


Link to post
Share on other sites

It’s real dumb that they even added that option. There have been dozens of folks with issues, including myself once, since they added it. They seem to be on some sort of mission to dummy down Cakewalk but between Basic Workspace and that Stupid track control manager I think they made things worse. 
 

If Cakewalk ever returns to being a paid for program I hope they offer a version like Home Studio again.
Almost all other DAW’s have a basic LE version  often for free so you can try the software. I have free versions of ProTools and Studio 1. They are pretty easy to use. 
But here we are with the flagship $500 retail version for free so ya folks, it will be fully featured and complicated. I don’t hear anyone complaining about that. 

Edited by John Vere

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...