Jump to content
Damian Keavney

Internal PC microphone recording simultaneously with instrument

Recommended Posts

I'm a newbie and I'm having this issue.  If anyone can help, I sincerely appreciate it. 

I'm using a Yamaha keyboard and going directly from the USB output into my PC.  When I activate a track, the PC's internal mic is picking up and recording room noises. Do I need an audio interface to stop this from occurring or is there a way to turn off the microphone when recording an instrument. I thought that would happen automatically but it doesn't. I've looked at every button and can't figure out how to stop it. Thanks again for any help.

Share this post


Link to post
Share on other sites

A proper audio interface with proper ASIO drivers will instantly solve 90% of audio issues. Proper setup of the computer itself will solve another 9.9%

Edited by bdickens
  • Thanks 1

Share this post


Link to post
Share on other sites

Before you go off and buy an external audio interface hoping it will solve this issue,  it is possible to hook an audio interface up to your computer and still accidentally record audio from the computer's built-in mic. External audio interfaces are not necessary for recording MIDI or playing back audio. As soon as you decide you do want to record audio, that's when you'll want to have a good external interface.

 

The only way to record from an audio source to a Cakewalk track is to set that track's input to that audio source, arm the track for recording, and then either hit "R" for record or click on the record button in the Transport module. As in the following diagram, arrow "A" points to where you set the track's input, and "B" points to the button for arming it for recording:

 

image.png.8a18f6ab6374f46467abc887350dc69a.png

In the above example, when button "B" is pressed, Cakewalk will be ready to record audio from the first channel of my audio interface as soon as I hit record. If the track's input isn't set to the internal mic, or the track isn't armed for recording, audio from the mic won't get recorded.

 

When you say that you "activate a track," what do you mean by that? Do you mean arm it for recording? If so, then simple, don't arm an audio track with its input set for the internal mic.

 

If you wish to record MIDI information from your Yamaha keyboard to an Instrument track in Cakewalk, you should arm only that Instrument track for recording, as below:

image.png.c89a55cfd3514c71662a7f05005357db.png

In my case, the input is set to be the MIDI input on my interface.

 

Cuation: If you use the Record button in the Control Bar Mix module to arm your tracks for recording, it will result in all the tracks being armed, so don't do that:

Mix module: image.png.1bdcd06633b0efd1c93059cd50578484.png

Only arm the tracks you want to record, do not arm any others.

 

The way to "turn off" the PC mic is just  to not have it selected as the audio source for a track that's armed for recording.

 

You could do it on a system level by disabling the mic in your computer's BIOS or in Windows' Device Manager, but we're talking Cakewalk here. The other way to prevent it from showing up as an available audio source in Cakewalk is to go into Preferences/Audio/Input Devices and uncheck the box next to the internal mic:

image.png.cf6ed361a2f4d9d645bfeecc249abe31.png

 

One last note: if you're trying to record the audio that comes out of your Yamaha keyboard, then that is a job for an external audio interface. It's possible to do it using the 1/8" input jack, but few would recommend it.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...