Jump to content
Daryl L. Samuel

Grid / Snap Alignment Issue (Track View + Piano Roll)

Recommended Posts

In the video above, you would notice that the audio clip is not lining up correctly with the grid.

 I can’t say this is new because I’ve been dealing with similar alignment issues since the days of SONAR X3.

Even in the piano roll, I can sometimes see what appears to be notes / grid lines shifting slightly.

For a long time I’ve always lacked that sense of confidence when moving things around because I always have to make sure that clips are actually on the grid. This issue is more common when creating groove clips.

Have anyone else experienced this before?

Share this post


Link to post
Share on other sites

Looks like you've got a snap offset set on the clip.  You can tell by the small corner on the bottom left of the clip.

Check the clip properties:
image.png.a86c5c74753c1fa13583931fb778bf4b.png



 

Share this post


Link to post
Share on other sites
7 hours ago, Daryl L. Samuel said:

Thanks for responding!

I wish it was…

 

C43604E5-3C6F-4D3A-800A-3EA8F5B7C1FB.png

Have you checked your snap settings? Make sure all those little boxes are ticked in Preferences. 

Share this post


Link to post
Share on other sites

I've not delved into this deeply, but I suspect if this is a groove clip, and you've set beat 1 to the first transient in the waveform then what it is doing is aligning beat 1's transient to the grid rather than the edge of the clip.  Which makes sense if you think about it.

 

Share this post


Link to post
Share on other sites
11 hours ago, msmcleod said:

You can tell by the small corner on the bottom left of the clip.

So I figured out why… Stretch to Tempo was turned on. That’s why it had those little cropped corners like you pointed out.

That still doesn’t explain how ‘Stretch to Tempo’ would cause an issue like that… Stretch to Tempo shouldn’t change where a clip starts, right?! So I want to believe that it’s a bug.

Share this post


Link to post
Share on other sites
18 hours ago, Will_Kaydo said:

Have you checked your snap settings? Make sure all those little boxes are ticked in Preferences. 

The Landmarks stuff… At first I thought it because of that but I have the main “switch” turned off so it couldn’t be that and as it turns out, it wasn’t.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...