Jump to content
  • 0
tulamide

The strangest issue with audio buffering

Question

I really hope somebody has a tip, although I doubt it. I searched the whole internet and couldn't find a single matching issue.

I start Cakewalk and everything is just fine. I load my VST instruments and start making music. But somewhere between 5 to 15 minutes in, the typical crackling sound, you normally get when audio buffers are too small, appears. However it's not the buffer size! Whatever I change it to (large or small), after a change it's all working again for 5 to 15 minutes.

I have this issue for a while now. First on an i3 4th gen, which I used as an itermediate. Now I have a brand new PC, with Ryzen 5 5600G, 16 GB RAM 3200 MHz and M.2 NVME, and it still is present. This new PC also has a newer version of Win 10 (20H2), whereas the older one had, I think, 1900 or something like that.

The issue occurs, no matter the driver. I tested ASIO4ALL, FL Asio and WASAPI. Even more, I don't even need to change driver settings. When the issue appears, it is sufficient to just start any other application (a text editor, a browser, even the calculator, etc.) and then go back to the DAW and all is good again - for 5 to 15 minutes.

I was carefully preparing the PCs (the old one and the new one) for use as a music production tool. No background apps, no updates while running Cakewalk, no energy saving, CPU runs always at 100%, etc. And I have no other issues. Wether video editing, UX design, gaming - everything works just fine.

Cakewalk is the newest official version (but not the test versions), Win 10 Pro 64 bit 20H2, no third party AV (just Windows Defender).

I'm out of ideas and extremely frustrated that I can't do what I love most, music making sessions of several hours. Please, if you think you know the solution, or at least have a not so common tip, help me!

(Don't feel insulted if I don't react immediately, I might not have the time to check the forum several times a day)

 

EDIT: I didn't mention that this only happens with VSTs. Pure mixing of audio tracks with no VSTs involved works fine. Also, it seems (but I'm not sure), that whenever the issue comes up, even after the playback is stopped and all tracks silent, the audio engine still does some work (the load isn't 0%), while stopping playback without the issue seems to go to 0% all the time. It doesn't matter which VST though. All of them are affected.

Edited by tulamide

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Have you tried to figure out if this is caused by a certain VST? From what you have said this would be the first thing I would try. It could be an effect or a instrument

Also you don’t say if you’re using an audio interface or on board sound chip. If using on board totally get rid of ASIO4ALL and Real tech ASIO drivers and use WASAPI shared or exclusiveThe Real tech ASIO driver is a well known issue  

 

 

Share this post


Link to post
Share on other sites
  • 0

Thank you so much for the tips!
 

20 hours ago, reginaldStjohn said:

I think that if you run Resplendence LatencyMon while it is doing the cracking you may find what is causing this.

I installed and ran the software. Unfortunately, I can't interpret, what it tells me! I attached, what it said. Maybe you see something, that shouldn't be as it is?

 

22 hours ago, John Vere said:

If using on board totally get rid of ASIO4ALL and Real tech ASIO drivers and use WASAPI shared or exclusive

I did that before and I had issues. But I did it again, and this time ran the Waves Analyzer. After that I had a setting of 411 samples buffer and 11 ms latency, which is equal to ASIO. I worked for 20 minutes, during which the issue didn't appear! That's good news. But I have to do a longer session, before I know if this really fixed it.
 

On 9/15/2021 at 3:23 PM, bdickens said:

You will have much better luck with a real audio interface that has a dedicated ASIO driver.

It's on my list! But after my new PC, there wasn't enough money on hand to buy that as well.

cpu.png

driver.png

main.png

summary.txt

Share this post


Link to post
Share on other sites
  • 0

Well that's a good report from the latency monitor so seems your PC is not the issue. To make sure run it while your working in Cakewalk for a few hours. Most times it just internet stuff causes issues. 

At this point it looks like you need to run the correct audio driver. An Audio interface with a good ASIO driver will ultimately be the best solution, But for now you should be able to use on board audio with WASAPI mode. But as I said just make sure none of those other drivers are conflicting. Make sure your computers sound card is the only device showing in all the audio preferences and especially in the Sync and Cashing - Device box. 

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...