Jump to content
Sign in to follow this  
Starship Krupa

Tales from my system recovery (bad clicks and pops with system reset)

Recommended Posts

A few days ago I suffered a failure on my main DAW apparently due to the system losing power during a disk operation. I know this isn't supposed to happen there are lots of failsafe measures to prevent it, but I wound up in the dreaded Windows Repair loop. All my stuff was there, I could see it from the command line, but just could not get Windows to start up. Finally I submitted to a "reset," where it nukes your Windows installation and installed programs and keeps the rest of your files. Bone stock Windows.

One of the first things to go back on was Cakewalk, with the dread that accompanies having around 700 plug-ins installed on my just-crashed system. Fortunately, I keep my iLokables on a physical iLok and my Waves on a USB stick, and most of the rest seems to be trusting that I still have the same computer.

So I started Cakewalk and created a simple two chord drone using Xpand!2. Looped it and let it run, and sure enough, about every 8 seconds or so, a big CLICK. No indication from Cakewalk's Performance module that the engine had suffered a buffer underrun.

Next stop, LatencyMon:

1525148778_LatencyMonbefore.thumb.png.5ca2b86fcac33be0f3ce27b083f4aafd.png

I looked at the Drivers tab, and sure enough, NDIS.SYS was eating humongous interrupt time. I'd seen this before, when I first upgraded my system from 7 to 10. What fixed it was rolling the NIC driver back. Of course there was nothing to roll it back to with my fresh install, so hit Dell's website to get the older driver.

Here's the Microsoft/Intel driver that was installed with the reset:

1330622358_StockNICDriver.png.67fb46670307596430ac9e251c28f992.png

When swapped out with this one, from Dell's website:

image.png.8ad0a5a98e2babcbd5203d7184bd93c7.png

All was well:

DelNIC.thumb.png.9a75ca15e234e6382c4fb9b81f144178.png

One theory I have is that these "clicks and pops" that come with Windows updates, and the regular admonitions to disable your network interface whenever you're doing DAW work may be down to network card drivers that are too grabby with the interrupts. So if you're seeing this issue, of course, run LatencyMon, and if NDIS.SYS is causing trouble, see if you can find an earlier version. If you have a Dell or Lenovo or HP or some other brand name, usually their drivers run a revision or two behind the curve.

Where Microsoft used to be too conservative with hardware drivers, they now seem too aggressive about pushing out the latest shiny driver. If you have something go sideways, and you haven't just done a reset like I had to, most drivers can be rolled back using Device Manager.

 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...