Jump to content
Billy86

MIDI notes continue sounding after transport stop

Recommended Posts

Sending up a flare to the MIDI gurus... Playing a song with an audio track and with Midi triggering a Kontakt piano. When I stop the transport, the last notes ring on and on, slowly fading, but never completely stopping. I have to hit the reset MIDI and Audio button in the control bar to stop it. Doesn't happen every time, but it's the rule more the exception.

I've tried checking/unchecking a few boxes in the Preferences/Project Midi... [including "Zero Controllers When Play Stops" and "MIDI Event Chase on Play" ] but nothing seems to help. 

Any ideas? Thank you! 

 

Share this post


Link to post
Share on other sites

If Kontakt is inserted in the FX bin of the audio track, try moving it to the Synth Rack.  Using the FX bin to host a synth is a legacy configuration that is still supported for backward compatibility, but is not the preferred configuration and has been known to cause stuck notes.

If that's not it, I dunno...

When I first saw the post, I suspected Zero Controllers When Play Stops was not enabled to zero CC64 (Sustain) which is a pretty common issue with piano synths,

I know you've already checked that, but it might still be worth pressing/releasing your sustain pedal to see if it stops the notes.

Share this post


Link to post
Share on other sites

If it's intermittent, does it depend on where you stop playback?

If you happen to stop playback after a pedal-down event but before the corresponding pedal-up event, the piano will keep playing the note until it decays.

 

Share this post


Link to post
Share on other sites
On 7/21/2021 at 4:51 PM, David Baay said:

If Kontakt is inserted in the FX bin of the audio track, try moving it to the Synth Rack.  Using the FX bin to host a synth is a legacy configuration that is still supported for backward compatibility, but is not the preferred configuration and has been known to cause stuck notes.

If that's not it, I dunno...

When I first saw the post, I suspected Zero Controllers When Play Stops was not enabled to zero CC64 (Sustain) which is a pretty common issue with piano synths,

I know you've already checked that, but it might still be worth pressing/releasing your sustain pedal to see if it stops the notes.

Thanks, yeah, it's in the synth rack.

Share this post


Link to post
Share on other sites
On 7/21/2021 at 6:55 PM, bitflipper said:

If it's intermittent, does it depend on where you stop playback?

If you happen to stop playback after a pedal-down event but before the corresponding pedal-up event, the piano will keep playing the note until it decays.

 

Thanks for the thought. There are a lot of sustain pedal up/down, so I think that's probably it. If I'm reading the PRV 64-Pedal controller correctly, 127 is pedal down, and 0 is pedal up. I converted it to an envelope, and that's what I'm seeing a lot of.  

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...