Jump to content
  • 0
Timtrinox

How can I disable clips automatically trimming to MIDI content?

Question

Okay, so I must've changed some setting to start making Cakewalk automatically trim the upper limit of a clip down to the midi content when moving a clip as shown in the supplied link.

How can this be changed? As I know for sure that it wasn't always a thing.

The issue in question:

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Actually, this has always been a thing. Cakewalk came late to the concept of MIDI 'clips, and their boundaries have always been defined by the starting and ending event times. The exception is a MIDI Groove clip which has a defined number of Beats in Clip that allows it to have empty space at the end. So one way of dealing with this is to convert the clip to a Groove Clip.

Their are ways of preserving empty space in a MIDI clip when doing certain operations, but the only surefire way is to preserve space no matter what you do is to insert dummy controller events ( I usually recommend Pedal Up, CC64=0) or silent, zero-velocity note events in the clip at the desired start and end times.

Share this post


Link to post
Share on other sites
  • 0
11 minutes ago, David Baay said:

Actually, this has always been a thing. Cakewalk came late to the concept of MIDI 'clips, and their boundaries have always been defined by the starting and ending event times. The exception is a MIDI Groove clip which has a defined number of Beats in Clip that allows it to have empty space at the end. So one way of dealing with this is to convert the clip to a Groove Clip.

Their are ways of preserving empty space in a MIDI clip when doing certain operations, but the only surefire way is to preserve space no matter what you do is to insert dummy controller events ( I usually recommend Pedal Up, CC64=0) or silent, zero-velocity note events in the clip at the desired start and end times.

What, no way. Then what was going on for the past year with my install, then? A bug?

Share this post


Link to post
Share on other sites
  • 0

Preferences | Customisation | Editing > Enable “Non-Destructive MIDI Editing”

Share this post


Link to post
Share on other sites
  • 0

Hmmm...  yeah. that may help in some cases. I leave it disabled because it has other side-effects I don't like, and some actual bugs, so I kind of forgot about it.  It's been so long since I thought about it, I'd have to go hunt up some threads on the old forum to remember all the issues. With all the work the Bakers have done in the last few years, some may have been fixed in the mean time.

Share this post


Link to post
Share on other sites
  • 0

In a similar thread "Clips are Automatically Shortened' at

https://discuss.cakewalk.com/index.php?/topic/29371-clips-are-automatically-shortened/

one suggestion was to Copy the MIDI clip and then "Paste as new clips".

Share this post


Link to post
Share on other sites
  • 0
On 5/17/2021 at 11:06 PM, Promidi said:

Preferences | Customisation | Editing > Enable “Non-Destructive MIDI Editing”

Odd that doesn't seem to change anything at all.

Share this post


Link to post
Share on other sites
  • 0
9 minutes ago, Timtrinox said:

Odd that doesn't seem to change anything at all.

Maybe try Paste into existing clips (In the paste dialogue box).

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...