Jump to content
Czeslaw

Cakewalk by BandLab + Vienna Ensemble Pro

Recommended Posts

Posted (edited)

Hello everybody!
It has long been an urgent problem!
In such DAW as Reaper, Cubase, Studio1, when the Vienna Ensemble Pro5/6 window is active, starting playback of the project in these DAWs with the Space key is normal.
When Vienna is working with CbBL, playback does not start! And this is very uncomfortable and upset.

Can this be fixed?

Edited by Vyacheslav
  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, Vyacheslav said:

When Vienna is working with CbBL, playback does not start! And this is very uncomfortable and upset.

Make sure that you have Cakewalk highlighted and not VEPro when you hit the spacebar,

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Jeff Bowman said:

Make sure that you have Cakewalk highlighted and not VEPro when you hit the spacebar,

This is how Cakewalk works. The question was "How to solve this problem"? Because other DAW's do not require focusing on themselves and will start/stop normally even from under a remote desktop on another machine.

Edited by NGC 598
  • Thanks 1

Share this post


Link to post
Share on other sites

Well, neither do Cakewalk. It doesn’t matter whether the VST has focus or not. The only way to have the VST catch a spacebar key-stroke is to enable the option Give All Keystrokes to Plugin-in in the VST window. Otherwise, and of course under the condition that you haven't remapped the spacebar in Preferences > Customization > Keyboard Shortcuts,  it will trigger the Play/Pause function in CbB.

Share this post


Link to post
Share on other sites
39 minutes ago, Canopus said:

The only way to have the VST catch a spacebar key-stroke is to enable the option Give All Keystrokes to Plugin-in in the VST window.

This also does not work if the CbBL window is out of focus, i.e. the window of Vienna is opened as a host, not a plug-in.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Jeff Bowman said:

Make sure that you have Cakewalk highlighted and not VEPro when you hit the spacebar,

If the CbBL window is active, the Vienna window is hidden by it and vice versa.

Edited by Vyacheslav

Share this post


Link to post
Share on other sites
4 minutes ago, Vyacheslav said:

This also does not work if the CbBL window is out of focus, i.e. the window of Vienna is opened as a host, not a plug-in.

That should come as no surprise. If Vienna is run as a stand-alone executable and has focus, of course it will receive all keystrokes. That's how every Windows application works.

3 minutes ago, Vyacheslav said:

If the CbBL window is active, the Vienna window is hidden by it and vice versa.

Are you sure you're running Vienna as a VST and not as a stand-alone executable? It shouldn't be possible for CbB to hide a plug-in that has been instantiated from within the application.

  • Confused 1

Share this post


Link to post
Share on other sites
1 hour ago, Canopus said:

That should come as no surprise. If Vienna is run as a stand-alone executable and has focus, of course it will receive all keystrokes. That's how every Windows application works.

Are you sure you're running Vienna as a VST and not as a stand-alone executable? It shouldn't be possible for CbB to hide a plug-in that has been instantiated from within the application.

This is very interesting, but  want to get a simple answer to a simple question-)  From VEP manual: "Transport Play/Stop button, which is transmitted to the master host as well (Space key). Now you can start and stop your playback from within Vienna Ensemble PRO"   It works with Сubase, Studio 1 and Reaper and doesn't work with Cakewalk. Is there a solution?

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
14 hours ago, Canopus said:

Are you sure you're running Vienna as a VST and not as a stand-alone executable?

Absolutely.

Maybe you don't know how the DAW+VEP works? Sorry, but judging by this post of yours, you do not know.

14 hours ago, Canopus said:

That should come as no surprise. If Vienna is run as a stand-alone executable and has focus, of course it will receive all keystrokes. That's how every Windows application works.

The VEP VST plug-in from the DAW connects to a host instance on the same computer or on another (connected over your home network) and runs VEP as a host. And as NGC 598 said:

 

12 hours ago, NGC 598 said:

It works with Сubase, Studio 1 and Reaper

Is this a surprise for you?

Edited by Vyacheslav

Share this post


Link to post
Share on other sites
Posted (edited)

Surprise surprise !!! This works in versions 26.04.0.151 (2020.04.build151)!!!

https://drive.google.com/file/d/1BvF2iiDTPLcRVDMLj2wRX6v4SmBbDXSs/view?usp=sharing

And in the next version 2020.04, playback starts immediately after loading the project with the VEP window in focus, but if you activate the CbBL window and then the VEP window again, playback will no longer start.

I have installed sequentially versions of CbBL one after the other, starting with 24.4.0.13.

Edited by Vyacheslav

Share this post


Link to post
Share on other sites

Out of interest, does this setting make any difference?

I suspect it might have to be unchecked when using VEP.

image.png.dfca669501143c76a103d3419a44c9d3.png
 

Share this post


Link to post
Share on other sites
12 hours ago, Vyacheslav said:

Maybe you don't know how the DAW+VEP works?

No, sorry. I’m using Kontakt almost exclusively. Great that you got it working.

  • Confused 1

Share this post


Link to post
Share on other sites
11 hours ago, Canopus said:

Great that you got it working.

But this is a very old version. And in new ones it doesn't work.

Share this post


Link to post
Share on other sites
Posted (edited)
19 hours ago, msmcleod said:

Out of interest, does this setting make any difference?

I suspect it might have to be unchecked when using VEP.

This parameter was disabled for me, but enabled it does not change anything.

msmcleod, can we hope to fix this problem in newer versions?

Edited by Vyacheslav
  • Like 1

Share this post


Link to post
Share on other sites

Dear msmcleod, is it possible to download the full installer of version 26.04.0.151 somewhere?

Share this post


Link to post
Share on other sites

I’m having trouble understanding the exact problem since there seem to be conflicting reports.

 

On 5/11/2021 at 2:13 PM, NGC 598 said:

This is very interesting, but  want to get a simple answer to a simple question-)  From VEP manual: "Transport Play/Stop button, which is transmitted to the master host as well (Space key). Now you can start and stop your playback from within Vienna Ensemble PRO"   It works with Сubase, Studio 1 and Reaper and doesn't work with Cakewalk. Is there a solution?

Are you trying to start playback from within the VEP window and is this the plugin version or the standalone version runnng on a different PC?
i.e when it says “start and stop your playback from within Vienna Ensemble PRO” are you referring to an instance running within Cakewalk or external to Cakewalk. It may be helpful if you post a video so we can see what you are doing.
We normally intercept the spacebar and it should start the transport. 

PS: binary thinking like it works in x/y/z but not cakewalk is not useful for diagnosing problems so lets focus on trying to find out what is happening. The problem could be in Cakewalk or could be in the plugin until we find out what the issue actually is. 

Share this post


Link to post
Share on other sites

@Vyacheslav Thanks for the video. So let me verify whether I understand what you are doing:

You open a plugin window from within the VEPro window
When that plugin window has the focus you press space bar and the spacebar does not start the transport in CbB

Is this correct?  In your video you have not enabled the "give all keystrokes to plugin" button in the main VEP plugin window. Does it make a difference if that button is enabled?
Also to clarify - the video you posted is with it working properly correct?

BTW we had a case for this already logged. Unfortunately it did not get investigated in this release. I will escalate it and we'll address it since it appears to be a regression.

  • Like 1

Share this post


Link to post
Share on other sites

So I tried this out with VEPro and I can see that you cant start the Cakewalk transport from within VEP. 
However it also does not work in the 26.04.0.151 release. So this is NOT a regression. I'm not sure why it seems to work for you.
I'm using an older build of VEPro 7.0 demo server so maybe we aren't running the same version.
In fact even pressing the transport in the server doesn't start playback in CbB so this is not related to the spacebar.

I'll see if I can find out what the plugin is relying on to start the transport in the host. In any case this doesnt seem to be a bug but some missing communication.

  • Like 1

Share this post


Link to post
Share on other sites

I figured it out. The plugin is posting spacebar messages to the main application window. Cakewalk currently doesn't accept random processes sending keyboard messages to the app window so it throws such messages away. 
Lets say ahem that this is pretty unorthodox behavior for a plugin to do and I've literally never seen any other plugin do this.
My guess is the developers tried it in a couple of DAW's and it happened to work so they started doing it. This is exactly the kind of thing I'm referring to when I say you cannot infer anything by looking at how a plugin works in one DAW.  Most plugins send keystrokes to the PLUGIN window not the host window. If VEP had done that it would have worked properly.

I have made a couple of changes to listen to keystrokes at the app level, and now the play button and spacebar work in VEP.  However we'll have to test it and make sure there aren't any unwanted side effects to this. 

  • Like 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...