Jump to content
Misha

Midi Program changes / Volumes in VST question in Halion Sonic / SOLVED!

Recommended Posts

Posted (edited)

Hi Folks.

Can somebody help me please.  I have several Midi tracks in Cakewalk that I use with Halion Sonic.  Sonic has 3 modes for program changes: Gm, Multi and OFF.  Mine is set to OFF.  I set my Halion Sonic mixer to desired values.... As soon as I stop and play from beginning, volume parameters are resetting in Halion Sonic...  I have tried moving volumes to desired position and save VST preset and re-open, but have same issue.  Is it possible to disable those program changes in Cakewalk tracks... or what would be the right way to deal with this?

 

Thank you in advance!

 

 

Edited by Misha

Share this post


Link to post
Share on other sites

Scook,

thanks for trying!

Unfortunately disabling  "Zero Controllers" in project did not help. Still some (not all) volumes snap to center after Stop-->Play...

Any other suggestion please?

Share this post


Link to post
Share on other sites

Ok, Figured it out!  It is Sonic that is acting up.  For those who might encounter same issue. You have to right click on individual Sonic mixer slider and click tiny menu "forget CC" on specific channel, then it would not reset on start/stop. 

Share this post


Link to post
Share on other sites

This is a VERY common problem with multiple different product lines of plugins.  The fix is similar in all of these - they are resetting because they are tied to CC control for volume.

In Kontakt, whenever I load up an instrument I haven't used before, I always go into the Instrument Options (click the wrench to get into the instrument's settings, than click on Instrument Options, then click on Controllers),  and then I remove the check for the box labeled Accept standard controllers for Volume and Pan, and then I save the modified instrument in the same folder, with "Bob's - " added to the front of the name. I also make sure to pull the master volume for the instrument down quite a bit, so that it is close to where I generally have things set for use in the project.  (The instrument's initial volumes are always way too high for my liking).

The other choice would be to skip the above, and set the instrument's volume using the fader on the Cakewalk midi track for that instrument.  I almost always do the above, and then, because I save the instrument with the change - adding "Bob's - " to the front of the instrument's name, so next time I want to use that instrument I already know those changes were made.

Anyways, good luck with it all, hope the above helps some, 

Bob Bone

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×