Jump to content
Morten Saether

2021.04 Feedback

Recommended Posts

10 hours ago, Štefan Gorej said:

@Noel Borthwick, the dump file, that I sent in my previous post, was from my "experiment" with .FXC chain loading to already opened Cakewalk project.
I'm sending the dump that came from crash during Cakewalk project load. Exact steps were as follows:

1. I created a new, completely empty project, added one bus track
2. Added an instance of Presswerk VST3 to FX slot of this bus, switched the FX chain and the plugin itself
3. Opened the plugin window to ensure that it's successfully loaded and initialized
4. Saved the project as a new .CWP
5. Exited Cakewalk and started it again
6. Loaded .CWP project saved in step 4

=> Crash on Presswek VST3, dump file from this cras is attached.

So, as I experimented, plugin crashes in this two scenarios:

a) When loading .CWP project that already contains Presswerk or Satin VST3
b) When loading FX Chain that contains Presswerk or Satin VST3 into already opened Cakewalk project

I also tried following scenario:

1. Created empty .CWP project
2. Added Presswerk VST3 plugin instance
3. Loaded existing preset into it using CAKEWALK PRESET functionality (.vstpreset file)

This scenario was successfull, without crash, all parameters values from VST preset loaded successfully into existing plugin.

See my attachments.

Hope this may help to better understand my specific problem.

Thank you,
Stefan

 

EDIT: Btw. How to roll back to previous Cakewalk build to be able to load my projects and manually note Presswerk and Satin values to be able to manualy set them the same way in VST2 plugin instances (until solved in software)?

_05022021_093720.zip 322.21 kB · 0 downloads

@Štefan Gorej The stack is identical in the new one as well. You can roll back by following the instructions in the current release notes.

Share this post


Link to post
Share on other sites
10 minutes ago, Fred's Gratis Scores said:

I use Cakewalk with BandLab and was excited to see the feature where you can open from and publish to BandLab directly. I've spent a little time playing with it this morning and noticed a few things:

  • Muted tracks in my Cakewalk project are not muted when uploaded to BandLab. My use case is that I want to upload the MIDI tracks with audio stems so that when the project is forked, others can use the stems and have the MIDI to figure out the chord progressions or just start fresh with their own versions. Unmuting tracks that I set to muted renders them on the revision when they are not supposed to be there.
    To work around this I need to manually open the project on BandLab, mute the tracks, and save which creates another revision.
  • After fighting this for a while, I found out that an instrument track counts as 2 tracks toward the publish limit of 16 tracks. I had to manually spit the instrument track and select only the MIDI or audio that I wanted included to publish. Perhaps you could only count an instrument as 1 track, and automatically publish the MIDI if the instrument is not frozen, or the audio if the track is frozen.
    If we really do want to publish both the MIDI and audio, then the user can split the track and select both (or ideally not have to select both if the track count is still below the maximum).
  • I understand the track limits as each audio track takes up space on your servers. However, this makes collaborating using the publish feature difficult for those that compose in the "Classical" category (all the woodwinds, brass, and strings alone are already much higher than the limits). If I ask a collaborator to add a solo violin that I don't have, they would have to render the audio, and increase the audio track count. 
    I'm not sure what the solution is that respects BandLab's servers and allows higher track count composers to collaborate using this feature.

 

Thanks for the feedback. We'll review and make changes as necessary. 
PS: We had early access available for more than a week. We encourage users to try the early access since it allows us to get early feedback and make changes before we release.  :) 

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Noel Borthwick said:

Thanks for the feedback. We'll review and make changes as necessary. 
PS: We had early access available for more than a week. We encourage users to try the early access since it allows us to get early feedback and make changes before we release.  :) 

I almost did this time. I'd like to take part in the early access if I can time it so I'm not trying to finish up a project. ;)

  • Thanks 1

Share this post


Link to post
Share on other sites

Has anyone else had this ?

When I freeze a VSTi once the operation has completed the track view jumps to another location lower down the screen  

Share this post


Link to post
Share on other sites

@Noel Borthwick, thanks for your reply. I've updated my crucial projects using VST2 u-he plugins, so no need to roll back anymore (I also like new features of current Cakewalk build).

I've reported these crashes to u-he support as well, with explanation and with direct link to my post here (so they can download the memory dump). So hope they can and will fix this on their side.

As a side effect, replacing Presswerk and Satin with VST2 alternatives in my projects allowed me to create better mix (we all are still learning)! 😄

Thanks again, Stefan

Edited by Štefan Gorej

Share this post


Link to post
Share on other sites

Hi folks,

Thanks for all your feedback. There have been a few reports of record sync, some crashes on load and a few other cases.

[Updated to fix punch record issue]

Here is a new build 147 that should resolve these issues. We'd appreciate you trying this build if you are affected by any of these problems.

Issues resolved:

  • Recorded audio clips placed late on timeline by the ASIO record latency
     
  • New Preferences | File | initialization file setting to control the sensitivity for error detection. 2020.01 has stricter error checking and as a result some projects with plugin's that internally cause errors errors may not open.  You can work around this by adding the option ExceptionHandlingSeverity and set it to a value of 5After restarting the application this may allow projects that crashed to open. (assuming they opened in a prior version)
    To go back to the default setting, delete this value (the actual default value is currently 7)
     
  • Staff View not updating after nudging nodes 
     
  • Loading pre Tempo Track projects by default will not attempt to create envelope shapes from the tempo map. 
     
  • Track View no longer visible in Keyboard Shortcut category dropdown 
     
  •  PRV Aim Assist line slightly off when left is scrolled beyond zero
     
  • Tempo Node delete can delete selected clips 

 

  • Like 3
  • Thanks 6

Share this post


Link to post
Share on other sites
3 hours ago, Štefan Gorej said:

@Noel Borthwick, thanks for your reply. I've updated my crucial projects using VST2 u-he plugins, so no need to roll back anymore (I also like new features of current Cakewalk build).

I've reported these crashes to u-he support as well, with explanation and with direct link to my post here (so they can download the memory dump). So hope they can and will fix this on their side.

As a side effect, replacing Presswerk and Satin with VST2 alternatives in my projects allowed me to create better mix (we all are still learning)! 😄

Thanks again, Stefan

@Štefan Gorej please try the build I posted above and set the ExceptionHandlingSeverity value to 5.

Share this post


Link to post
Share on other sites

For those unfamiliar with 

11 hours ago, Noel Borthwick said:

Preferences | File | initialization file

in preferences, it is an advanced setting, make sure the Advanced radio button at the bottom of Preferences is selected.

By default, there are no values showing so ExceptionHandlingSeverity will need to be added.

To do this, type ExceptionHandlingSeverity in the Option Entry and 5 in the Value entry then click the Set button

Here is what preferences looks like before clicking Set.

NgbOiwX.png

 

  • Thanks 2

Share this post


Link to post
Share on other sites

Yes, they are documented

Initialization documentation starts here http://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=INI_Files.1.html

Variables used in Preferences | File | initialization file are here http://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=INI_Files.4.html

Of course, ExceptionHandlingSeverity is new and not yet added to the table.

  • Like 1

Share this post


Link to post
Share on other sites
32 minutes ago, Noel Borthwick said:
  • Track View no longer visible in Keyboard Shortcut category dropdown 
  •  PRV Aim Assist line slightly off when left is scrolled beyond zero

 

Thanks for this quick update.

On my PC, these issue are now resolved with Build 145.

Share this post


Link to post
Share on other sites

I think I have an item not reported, as yet.  I just installed the 2021.04 (build 144) version today, and I imported 3 new projects for mixing.  I encountered the same tempo-reversion issue with each project.  I think the steps to reproduce are:

  1. Create a new project with sample rate, bit depth, and tempo (& name & location, of course) using File | New
  2. Import audio tracks
  3. Start assigning audio tracks to track folders

Note now that the tempo indicator in the control bar has reverted to 100 bpm (no matter what initial tempo was assigned).

--------------------------------------------------------------------------

Update 5/25/21 -- downloaded and installed 2021.04, build 175, perhaps a week ago.  This tempo-changing issue hasn't happened on the new build (and I've imported another 3 projects, since the new install).  Thanks, guys!

--------------------------------------------------------------------------

Edited by Mark
Issue resolved, 2021.04, 175

Share this post


Link to post
Share on other sites
14 hours ago, Mark Morgon-Shaw said:

Os ícones não correspondem !!! ... Por favor, cure para o meu TOC   😀

(Excelente atualização BTW ... incrível) 

 

My TOC solved it through the Theme Editor. 🙂

Tempo.PNG

Share this post


Link to post
Share on other sites

I would like to have the option to log the plug-in exceptions (assuming that this isn't already being done). I don't want to keep running buggy plug-ins, and this information would allow me to either avoid them or report the bad behavior to the plug-in developer.

Also, it would be great if there could be a mode where Cakewalk pops a message indicating that a plug-in has misbehaved and allowing me to click through it and save and exit immediately or keep going if I know the issue to be benign.

  • Like 1

Share this post


Link to post
Share on other sites

I have had a problem with TTS-1 since last update and this latest did not fix the issue.  When I load a project that is using the plug-in in a track or try to load up an instrument track with it I get a pop up saying it’s not registered or something to that effect. I have found a workaround for now, opening Cakewalk as ‘admin’, that gets me around the issue but would be great if this can be addressed. I had a couple replies on the user groups in FB that they are experiencing same issue so that sort of suggests it’s an app issue. Any advice to get this back to normal much appreciated. Cheers. 

Share this post


Link to post
Share on other sites
Just now, Worthy said:

I have had a problem with TTS-1 since last update and this latest did not fix the issue.  When I load a project that is using the plug-in in a track or try to load up an instrument track with it I get a pop up saying it’s not registered or something to that effect. I have found a workaround for now, opening Cakewalk as ‘admin’, that gets me around the issue but would be great if this can be addressed. I had a couple replies on the user groups in FB that they are experiencing same issue so that sort of suggests it’s an app issue. Any advice to get this back to normal much appreciated. Cheers. 

Are you sure this is related to the Cakewalk update? i.e have you verified by rolling back that this problem doesnt occur? Its more likely system related since we aren't seeing this problem. 

Share this post


Link to post
Share on other sites
2 minutes ago, Noel Borthwick said:

Are you sure this is related to the Cakewalk update? i.e have you verified by rolling back that this problem doesnt occur? Its more likely system related since we aren't seeing this problem. 

I haven’t had the time to do that extensive a troubleshoot yet as I’m in the middle of 3 projects at the moment (not on Cakewalk) so have been trying to get answers on the FB groups as a first step. One suggestion recently that I’ve not had a chance to get to yet is to try opening folder properties where TTS-1 is located and change access settings. Will have a go at that later today and see if that resolves it. 

Share this post


Link to post
Share on other sites

I'm still getting an issue with MPC Beats hanging the DAW when loading projects, UNLESS I laod it as an Effect rather than a VSTi - but then I only have sterio so it's not really usable.

Share this post


Link to post
Share on other sites
48 minutes ago, Keith Lane said:

I'm still getting an issue with MPC Beats hanging the DAW when loading projects, UNLESS I laod it as an Effect rather than a VSTi - but then I only have sterio so it's not really usable.

Is this after installing build 145 and then heading to Preferences | File | initialisation file and adding the option ExceptionHandlingSeverity and setting it to a value of 5 and then restarting CbB?

To go back to the default setting, delete this value (the actual default value is currently 7)

Share this post


Link to post
Share on other sites

I posted this elsewhere, but after seeing Noel's message on Facebook, I'm putting it here:

 

I upgraded to the Current Release: 2021.04 yesterday and started getting problems with audio stuttering, dropping out and choking of the system.

I've been running previous versions of CbB seamlessly on my i5 laptop but the latest update is overloading the system.

I've found it doesn't play well with the Spitfire libraries, in particular Firewood piano and OPW.  Firewood can be a bit system heavy, but OPW has never caused me problems in the past. With the current build I am unable to run three Spitfire libraries on the same session, the whole system chokes up, stutters and stalls. If I add izotope or Raum, the system buckles completely.

I've rolled back to the previous build and, so far, it seems to have resolved the issue. I thought I'd report this here so the dev team can consider it.

Thanks

  • Thanks 1

Share this post


Link to post
Share on other sites
9 minutes ago, Philip G Hunt said:

I upgraded to the Current Release: 2021.04 yesterday and started getting problems with audio stuttering, dropping out and choking of the system.

 

Do your projects contain lots of automation? 

Under “High resolution plug-in automation improvements” it mentions that “Plug-in automation envelopes were previously being decimated at a uniform 50 msec interval”   This has been changed to 5 milliseconds

The decimation interval can be changed via the audio configuration (Preferences | Audio | configuration File)  property AutomationDecimationMsec (2-30) in preferences.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...