Jump to content
Morten Saether

[CLOSED] Cakewalk 2021.04 Early Access 2

Recommended Posts

Dear Cake bakers, I have little problem with the new BandLab integration. Whenever I go File --> Browse BandLab Projects... the sign in window open way too large blocking the top and bottom area of my screen, I can not resize nor close it unless I hit Alt + F4. No way I can access the regular minimize, resize or close button on the top right corner of the opening windows. I'm using my native LED resolution 1366x768, but even when I set it larger the sign in window is still too large. Tried in 2 different computer, same result. Not a big deal for now, just to let you know about it and hope you can look into it and fix it. Thank you!

 

Regards,
Jaymz

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

I'm a noob. New to music production, Cakewalk, Bandlab. So, the developers came up with a lot of nice fixes to issues I didn't even know they existed. I am very impressed (and overwhelmed) with the capabilities of the software. Very glad too it is free to use.

What I noticed in the Early Access 2021.04 version: 'Browse Bandlab Projects' fails to load a project when that project has a slash (/) in it's title (e.g. Pina Colada - Kpop/Tropical House in Eb Minor - 120BPM ).

 

Edited by Rene van der Lende
typo

Share this post


Link to post
Share on other sites
8 minutes ago, Rene van der Lende said:

I'm a noob. New to music production, Cakewalk, Bandlab. So, the developers came up with a lot of nice fixes to issues I didn't even know they existed. I am very impressed (and overwhelmed) with the capabilities of the software. Very glad too it is free to use.

What I noticed in the Early Access 2021.04 version: 'Browse Bandlab Projects' fails to load a project whenthat project has a slash (/) in it's title (e.g. Pina Colada - Kpop/Tropical House in Eb Minor - 120BPM ).

 

Thanks for the report. I’ll look into it.

Share this post


Link to post
Share on other sites
2 minutes ago, Glenn Stanton said:

"/" "\" ":" etc are restricted characters for file names in Windows. also: https://docs.microsoft.com/en-us/windows/win32/fileio/naming-a-file

Good call Glenn, however the issue seems to be in the 'title', the online filename itself is the default Bandlab encoded hash (in this case 'pina-colada-eb-minor-kpoptropical-house-120-bpm-071c25ec-f9440d9')(full link with changed 'title':  Pina Colada - Kpop - Tropical House in Eb Minor - 120BPM ). When I removed the slash from the 'title' the Mix Editor, Cakewalk was able to load the file.

Strangely enough, when initially loaded in Cakewalk and hitting the 'play' button it gave the error 'file stopped the audio engine: error 9' (can't recall the exact error descr.). I may be focussing on the wrong cause for not being able to load the only project. Will try with inserting a slash in another 'title'/file.

Share this post


Link to post
Share on other sites
Posted (edited)

Double checked slash (/) in 'title' load error: My forked project: Harder They Come - Jimmy Cliff Cover with  space dash space ( - ) in the 'title' loaded just fine in Cakewalk. When I changed those characters into a single slash the project failed to load with Cakewalk 'Browse Bandlab Projects...'[Load].

Probably some Regex() parameter in the 'translate title to filename' routine not properly set. (Yah, software engineer as a dayjob...just can't help myself, sorry...)

Edited by Rene van der Lende
update
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, James Argo said:

I can not resize nor close it unless I hit Alt + F4. No way I can access the regular minimize, resize or close button on the top right corner of the opening windows. I'm using my native LED resolution 1366x768, but even when I set it larger the sign in window is still too large. Tried in 2 different computer, same result

@James Argo can you sign in successfully regardless? Can you also provide your system specs? Thanks.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Another thing I noticed in both the regular and the 'early access' version of Cakewalk:

In Track View with Clips Pane focussed [Ctrl-A]  (MS-Windows 'select all') will select all clips, but [Ctrl-D] (MS-Windows 'deselect') will not only deselect all current selections, but also appends a copy of the previously selected clips to their respective tracks,  makes those copies selected and positions the Time Ruler at the end of the farthest clip.

So [Ctrl-A] acts in accordance with MS-Windows specs, [Ctrl-D] does not. For a newbie (and long time MS-Windows user, 35years or so) this is very confusing, especially with hitting [Ctrl-D] a few times in succession.

Probably too late to change this behaviour with so many user being used to this, but [Ctrl-A][Ctrl-C] combined with [Ctrl-V] or [Ctrl-D] are so commonly used in MS-Windows (as are [Ctrl-Z] and [Ctrl-Y] ) that I'd give it a second thought....

Edited by Rene van der Lende
added my 2 cents
  • Great Idea 1

Share this post


Link to post
Share on other sites

You’d be surprised how many DAWs use Ctrl+D as a shortcut for Duplicate. CbB is just one of them.

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

@Jesse Jost same problem here as with @James Argo, I am unable to resize the main window. [Maximize Window] (top right button) will toggle its icon, but MS-Windows resize capabilities are not active (using 'previous size' in the app top-left Window Menu, yields the same result). Cakewalk only opens in full screen view, whatever option is used.

System: Windows 10-x64 Home (build 19042.928) PC: Intel(R) Core(TM) i5-6402P CPU @ 2.80GHz   2.81 GHz 8Gb internal memory, Graphics: NVidia GeForce GTX 750 Ti 2Gb memory.

Edited by Rene van der Lende
changed the '@'s

Share this post


Link to post
Share on other sites
Posted (edited)

I copy and pasted this tempo map from a different version of the project but the tempo values aren't showing in the waveform.  The original from which it was copied does show the numbers.  How do I get the numbers on the curve?  Also adding nodes doesn't show the nodes on waveform but entries are made on the left in Tempo Track.

351722763_TempoMapValuesMissing.thumb.png.15576fc094a55227259b5ef347ae2f00.png

Edited by craigr68
  • Thanks 1

Share this post


Link to post
Share on other sites

Como excluir todos os efeitos de uma faixa? Existe um comando/teclado de atalho para executar esta operação?

Share this post


Link to post
Share on other sites
4 minutes ago, Rene van der Lende said:

@craigr68 [Right-click] in the 'Tempo Track' pane and check 'Show Tempo Values on Envelope' (so it seems, at least, in MS-Windows).

Thanks for the quick response.  I found "Show Tempo Values on Envelope" was already checked.  So I toggled that off/on and still same problem.  It seems the problem is related to copying and pasting the tempo between project versions.  On the original I did Ctrl-Alt-C, had only Tempo checked - then went to this other project version and did Ctrl-Alt-V and pasted it in.  It seemed to paste ok but no numbers.  I can add Tempo point to the curve but it does not show the node.  However, it does add an entry on the left.  Without the numbers and the nodes, it's pretty hard to work with it.

Share this post


Link to post
Share on other sites
Posted (edited)

@craigr68 I'm a Cakewalk beginner, but it seems the safest way in the app is to copy/paste through the various menu options of a clip/track. BTW: [Ctrl-C] and [Ctrl-V] are default keyboard shortcuts for MS-Windhose for copy/paste, leaving out the [Alt] part....

...and the checkmark next to 'Show Tempo Values on Envelope' works for me...

Edited by Rene van der Lende
little addition

Share this post


Link to post
Share on other sites
2 minutes ago, Rene van der Lende said:

@craigr68...and the checkmark next to 'Show Tempo Values on Envelope' works for me...

It works for me but not if I copy/pasted the tempo.  Did you check that?

Share this post


Link to post
Share on other sites
30 minutes ago, craigr68 said:

I copy and pasted this tempo map from a different version of the project but the tempo values aren't showing in the waveform.  The original from which it was copied does show the numbers.  How do I get the numbers on the curve?  Also adding nodes doesn't show the nodes on waveform but entries are made on the left in Tempo Track.

351722763_TempoMapValuesMissing.thumb.png.15576fc094a55227259b5ef347ae2f00.png

@craigr68 - thanks for the report, we'll look into this.

Share this post


Link to post
Share on other sites

Hello, Cakewalk Team

1: Thanks for updating this program. I've been a user since it's very first (pre-Sonar) incarnation. It's still my favorite.

2: Like many other users, I'm experiencing recorded MIDI notes are planting about a 32nd note ahead of where there are actually played on the timeline resulting in midi performances that are too early on the timeline. I know not everyone experiences this or, if they are, are just not sensitive to it. But, for enough people, it's there.

I've researched this and the one common theory is that this is a windows 10 issue that is impacting MIDI. Will there be a switch added to offset a problem like this?

  • Like 1

Share this post


Link to post
Share on other sites
14 minutes ago, PE Musik said:

Hello, Cakewalk Team

1: Thanks for updating this program. I've been a user since it's very first (pre-Sonar) incarnation. It's still my favorite.

2: Like many other users, I'm experiencing recorded MIDI notes are planting about a 32nd note ahead of where there are actually played on the timeline resulting in midi performances that are too early on the timeline. I know not everyone experiences this or, if they are, are just not sensitive to it. But, for enough people, it's there.

I've researched this and the one common theory is that this is a windows 10 issue that is impacting MIDI. Will there be a switch added to offset a problem like this?

What is your recording timing master set to within Preferences->Audio->Driver Settings?  Having this set to the wrong device is the most common cause of this issue.

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...