Jump to content
J Budd

Midi Instrument Assignments

Recommended Posts

Posted (edited)

In a project I'm working on, I have two VSTis (shaker and Hammond organ, via Native Instruments Kontakt Player 5). Without any intervention by me, suddenly the shaker MIDI data is being played by the organ, and the organ MIDI data is being played by the shaker. I was working on a completely different track ( Roland TD-11 midi drums & Addictive drums via USB, when I noticed this. These two tracks are Simple Instrument tracks, and I don't know how to change things back. Has anyone seen this, or can suggest a way to fix this? Thanks.

Windows 7 64 - Cakewalk by Bandlab - Focusrite Scarlett 18i8 2nd generation

Edited by J Budd

Share this post


Link to post
Share on other sites
Posted (edited)

The instrument slots in Kontakt are each assignable to a selected MIDI channel (1-16, or omni) in the Kontakt plugin. So if you are using a single instance of Kontakt, you can insert up to 16 Kontakt instruments in one VSTi, and control them from multiple Cakewalk MIDI tracks based on the MIDI channel number.

If you are using multiple instances of the Kontakt VSTi with one for each instrument, then you do not need to be as concerned about the individual MIDI channels. Just make sure that the correct MIDI data is on the Cakewalk track  routed to that instrument that you want it to play.

Check the output selection for the tracks in Cakewalk that are assigned to Kontakt, to make sure that something there has not been changed. Each MIDI track in Cakewalk can be assigned to a different slot in Kontakt, as well as a different instance of the VSTi.

 

Edited by abacab

Share this post


Link to post
Share on other sites

If it was me I’d create two midi tracks  and drag the data there. Then assign midi channels and point outputs to the vst.  I dislike simple instrument tracks for many reasons and this is one 

  • Like 1

Share this post


Link to post
Share on other sites

Why would he want to replace the synth?  He just want's the proper instruments in Kontakt to play correctly. The channels have somehow gotten swapped. 

  • Like 1

Share this post


Link to post
Share on other sites
23 minutes ago, Cactus Music said:

Why would he want to replace the synth?

I'm guessing that would be one way to undo the "crossed" synths, by replacing the shaker with the organ and the organ with the shaker. Doesn't explain how this could have happened, but might be a workaround.

Share this post


Link to post
Share on other sites

I should have mentioned that I was using multiple instances of the Kontakt Player on this project. Also I have five other projects set up in the same manner and this issue hasn't occurred...yet! Thanks for the feedback and I'll try some of the suggested fixes.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, J Budd said:

I should have mentioned that I was using multiple instances of the Kontakt Player on this project. Also I have five other projects set up in the same manner and this issue hasn't occurred...yet! Thanks for the feedback and I'll try some of the suggested fixes.

Yes, if you don't provide as much detail as possible, you leave folks that are trying trying to help with guessing. So you will get a lot of random suggestions in that case. Too much detail is always better than too little!

Preferably give a step by step list of exactly what you did to setup the project, so that others can either attempt to reproduce the issue., or guide you to a better workflow!

 

Edited by abacab

Share this post


Link to post
Share on other sites
4 hours ago, CosmicDolphin said:

Sounds like you might have the midi input set to Omni in Kontakt..so it's picking up other midi tracks

That is possible when you are talking about live MIDI controller input, since that could potentially end up in any track via omni if you are not careful. But playing back MIDI data shouldn't cause this behavior.

In Cakewalk, each MIDI track has an independent set of 16 MIDI channels that talk to a single instrument assigned to that track. Recorded MIDI data  in each track is only being sent to one instrument at a time, regardless of the channel used. So an instrument in another track cannot see that MIDI data, omni or otherwise.

 

Share this post


Link to post
Share on other sites
On 4/6/2019 at 9:31 PM, abacab said:

That is possible when you are talking about live MIDI controller input, since that could potentially end up in any track via omni if you are not careful. But playing back MIDI data shouldn't cause this behavior.

I've had it happen where two instances of Kontakt are playing the same thing even though only one of the instrument tracks contains midi data. 

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, CosmicDolphin said:

I've had it happen where two instances of Kontakt are playing the same thing even though only one of the instrument tracks contains midi data. 

Since Cakewalk MIDI tracks can only have one target for output, this shouldn't happen by default.

The only way that I can deliberately make this work is to use the MIDI out option from one instance of Kontakt (Engine > Send MIDI to outside world > incoming notes). If the other instance has MIDI input selection set as "None" or "All Inputs > MIDI Omni", or the other Kontakt instance,  it can pick up the incoming notes.

The easiest way to prevent, or disable this behavior is to uncheck "Enable MIDI output" in the Cakewalk VST header menu for the offending instance of Kontakt. Or you could uncheck "incoming notes" in the Kontakt settings for "Send MIDI to outside world" .

 

 

Edited by abacab

Share this post


Link to post
Share on other sites

Is it possible that you plugged external midi controllers into different USB ports?  That can confuse things.

Bob Bone

 

Share this post


Link to post
Share on other sites
16 hours ago, Robert Bone said:

Is it possible that you plugged external midi controllers into different USB ports?  That can confuse things.

Bob Bone

 

I think it was mentioned that it was playing MIDI data in Cakewalk, rather than playing a MIDI controller.

Share this post


Link to post
Share on other sites
2 hours ago, abacab said:

I think it was mentioned that it was playing MIDI data in Cakewalk, rather than playing a MIDI controller.

Yeah - I just remember things in my projects getting reassigned after I accidentally plugged things into different USB ports. It has been a LONG time since then, but I thought I would ask,...

Bob Bone

Share this post


Link to post
Share on other sites

Hello.. 

If each track is an "Instrument Track" select one by one and select the "track" tab and select "Split Intrument Track". Now the Instrument track is splited in a midi track and an audio track with the kontakt player. Check and see the output of the midi track and the input of the audio track... The output of the midi track have to be with the corresponding kontakt player and the input of the audio track the same way.. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×