Jump to content
Keni

[Solved]Got Fooled Again - Waves v12 plugin vs. win8.1

Recommended Posts

Posted (edited)

Yeah, my fault. But trying to see if I can find a way...

 

I bought the waves puigchild 670 without thinking. No returns on software.

v12 plugins require win10 and I’m trapped at win8.1

so, I forced the install but it doesn’t appear after a vst scan so I searched for the plugins, found them and copied the dll to my vstplugins folder. Still no luck.

Does anyone know of anything I’m missing or some trick, I would love to know. Thankfully, not a huge amount of cash to throw away, but.........

Edited by Keni

Share this post


Link to post
Share on other sites

Thanks Matthew!

 

That sounds like a good solution. I'll give it a try later this morning when DAW is up and running...

Share this post


Link to post
Share on other sites
7 hours ago, Matthew Sorrels said:

Can you run the older pre-v12, Windows 8.1 compatible version?

https://www.waves.com/support/how-to-roll-back-to-waves-v10

V10 looks like it runs on 8.1:

https://www.waves.com/support/tech-specs/system-requirements#plugins|version-10

 

Thanks again Matthew!

 

That solved the problem very nicely. V10 is up and running fine and I'll never know what v12 has that I'm missing. It preforms as I expect just the way it is!

 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...