Jump to content
John Vere

Why ASIO is Important

Recommended Posts

@John Vere the WASAPI works with my mixer - all modes do - and generally i run with the WASAPI Exclusive mode. but since i had the ASIO4ALL installed (my Alesis IO2 won't work with the WASPI and needs ASIO4ALL, but recently had one of the channels die), i figured i would run some tests. 🙂 

and in practice, i simply do a quick alignment if i find a track is offset. takes only a few moments. it's only live parts that typically need this when i'm running my remote rig. at home with the UMC1820 + ASIO drivers - it's pretty accurate all the time.

Share this post


Link to post
Share on other sites
49 minutes ago, Glenn Stanton said:

@John Vere the WASAPI works with my mixer - all modes do - and generally i run with the WASAPI Exclusive mode. but since i had the ASIO4ALL installed (my Alesis IO2 won't work with the WASPI and needs ASIO4ALL, but recently had one of the channels die), i figured i would run some tests. 🙂 

and in practice, i simply do a quick alignment if i find a track is offset. takes only a few moments. it's only live parts that typically need this when i'm running my remote rig. at home with the UMC1820 + ASIO drivers - it's pretty accurate all the time.

Right on- I knew you had it figured out, just wasn't clear. I really do appreciate the test. I just could not figure out how to get ASIO4all as an input? It shows in Windows and it shows as an option in Cakewalk but when you choose it nothing happens. This was both with on board and with my Scarlett. But your tests sort of confirmed my expectations. I'm just working on my next video which is about using on board sound. I've been screwing around with different set ups and on different computers. 

My conclusion is for playback there is absolutely no issues at all. But for trying to input audio you are right back to needing an interface. First the better drivers, next the proper connectivity and third there's no easy way to have real time monitoring . Your stuck with turning on input echo and suffering the slap back delay. Fine if your recording Elvis tunes. 

So I was only hoping that asio4all might be a solution to the timing offset issue and get the RTL down lower. Looks like WDM or WASAPI is the no brainer. 

 

  • Like 1

Share this post


Link to post
Share on other sites

you have to check the ASIO4ALL control panel - mine sometimes slips into using the Realtek audio or the webcam instead of the mixer, but opening the CP and touching the USB (mixer) enables it.

image.png.7e3e01a88fcbb9333021056dd85a404b.png

Share this post


Link to post
Share on other sites

@Glenn StantonYa I did that , This is what is weird. Everything showed as active and OK, The mike was active in Windows sound settings etc. 

 But the input just wouldn't be available in the Cakewalk audio tracks. It just said "none" 

I've never seen a case where an input is checked in preferences that was not available so I just wrote it off as bad driver. Anyhow I'm permanently done with this and have happily returned to my Interfaces with ASIO drivers. I will still use on board on my office computer which seems real happy with WASAPI exclusive or Shared. 

Edited by John Vere

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...