Jump to content
CMilli

Mackie midi signal problem

Recommended Posts

Hi

The Problem:
I have a Mackie Control Universal, the old grey one. It seems to have developed a problem in that it sends intermittent, uncommanded midi signals which cause the virtual master fader in cakewalk to move rapidly up and down about a decibel in volume.
It seemingly happens randomly, several times a minute, sometimes once a minute or less, lasting a few seconds at a time.

I have used Midi-Ox to record the output signals - see the attached pic.

My Mackie has the upgraded cpu chip (v3.0.0 up from v2.1.2) and two PWM chips, upgraded to v3.50. 

Things I've Tried:
Tried 2 different Midi interfaces - a Focusrite 4i4 and a Miditech 4x4.
I have taken the Mackie all apart and undone and redone all the connectors.
I have swapped all the chips with the other upgraded ones from my mackie extender. 
I've also tried putting the old chips back in (v2.1.2).
I've tried pressing every button and turned every knob and moved ever fader to see if something was sticking. 
I disabled the physical Master Fader on the Mackie by pulling its connector off and ran Cakewalk to see if that would stop the problem. It didn't, the virtual Master Fader still recieved a midi signal from the Mackie and randomly shook the fader up and down.
Checked the Mackie is in MCU mode.
Checked the controllers setup in cakewalk - Mackie first, Extender 2nd amd C4 third.
Ran Cakewalk with just the Mackie and no extender or C4 controller.

The whole setup seems ruined now. It was working fine before the weekend. 

As it only affects the virtual Master Fader (or the Bus Fader - depending upon what I have the physical fader set too in the Mackie options), is there a way of disabling  the Mackies input to cakewalk's Master Fader? I don't really use it so I wouldn't miss it. I know I can select in Cakewalks Mackie options which fader to assign to the physical Master fader - either 1.Master Fader or 2.Bus Fader. I would like to be able to disable it completley.

Any help would be really appreciated. I've spent all weekend on this. And as I said, my whole Cakewalk/Mackie setup is ruined by this.

Regards,
Chris

MIDI-OX REPORT.jpg

Share this post


Link to post
Share on other sites

I've got an almost identical setup to you (i.e. old grey MCU/ XT / C4, with the MCU + extender upgraded to 3.0.0 / PWM to 3.5.0) - I'm also running through a MidiTech (it's the 8x8 tho). I'm not having any issues with mine.

I'm assuming this happens with every project,  and you've tried it with a blank project with no VSTi's present (and also without MidiOX running) ?

If this is the case, it sounds like a hardware problem with the MCU.  Each PWM chip controls 4 faders, so the two PWM faders control faders 1  - 4, and 5 - 8. I'm not sure what is used for controlling or sensing the master fader.

The first thing I'd try, is to switch the MCU off and just use the XT & C4.  If the problem is no longer happening, you know its coming from the MCU.

Also double check everything else in your setup. I'm running in MME mode for MIDI as UWP gives me issues with other MIDI interfaces.

You could also try an earlier version of CbB, or even Sonar Platinum to see if this makes any difference. The MackieControl.dll hasn't changed in a while, but the automation in CbB was overhauled for 2021.01 - so it might be worth ruling that out. Given that I'm not seeing this issue though, I'm doubtful this would make a difference.

In the meantime, the only other thing I can suggest is to leave the master fader disconnected, and insert a new "dummy" bus before the master bus. This way it won't be controlling anything that could be affecting your sound.

The only other solution would be to get a used MCU from eBay... but be 100% certain it is actually the MCU first.

FWIW, there's a MCU main board on eBay at the moment for £45 : https://www.ebay.co.uk/itm/283941583200  - you'll need to check with the seller that it's definitely an original grey MCU rather than an MCU Pro tho, although from the looks of it (v3.0.2 PWM chips) it's probably an original MCU.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you very much for your lengthy reply. I have managed to make a workaround that I'm happy with.

It does seem to be a hardware issue, there is always an intermittent midi signal being sent from the MCU. The xt and c4 are fine. I connected the mackie up to a laptop and midi-ox still showed intermittent signals. The input light also flashed randomly on the Miditech interface.

I was researching ways of doing what you said regarding "insert a new "dummy" bus before the master bus" and realised that I may have got some of the terminology wrong regarding the "faulty" virtual fader. The Mackie midi signal was affecting the Hardware Output control (the fader hidden on the far right of the fader pane). The rogue signal would move the left channel of my Focusrite USB ASIO 1 output. The right speaker output is fine by the way.  I had the left and right channels padlocked so both channels volumes were affected.

So to manage the problem, I went into the Focusrite Control panel and selected the outputs as Output 3 and 4 (having taken the speaker cables out of outputs 1 and 2 and put them in 3 and 4). I then went into cakewalk and routed the output of the Master fader to output 3. It worked, but i found out that the Focusrite 4i4 interface volume control only affects output 1 and 2. It has no effect on 3 and 4.

So i put the speaker cables back into outputs 1 and 2 on my interface, then went back into Focusrite Control software and set the source for monitor outputs 1 and 2 as 3 and 4. Back into cakewalk and set the Master fader output as Focusrite USB ASIO Output 3. I then unplugged the mackie Master fader so it doesn't move randomly. I can control what was the "faulty" virtual fader by pressing the CONTROL GROUP/Main button on my Mackie which brings up the fader on my Mackie eXtender. That's fine with me.

Thanks for your help, it led me to a solution I can live with. I've included some pics which may help someone in the future to see how i coped with this very annoying problem.

Regards,
Chris

faders.jpg

Focusrite Control.jpg

Edited by CMilli

Share this post


Link to post
Share on other sites

Ah... this is a slightly different issue....

You've probably got things set up like this:

image.png.83526966df1bb75a9a3f8b4bf8046944.png

If it's set to Master, channel 1, then changes to the master volume in CbB end up changing the Left Master output fader of your audio interface.  You don't want this.

Set it to this:
image.png.ad3aeaa5f5e38d5adbf1aaea081bccd6.png

This tells CbB / MackieControl to use the First Bus for the master fader, which is usually the Master Bus.

If you're getting random signals from the Mackie on the master fader, inserting a dummy bus before the master bus will mean that it'll control that bus instead (which will do nothing, since nothing will be sent to it).

 

Share this post


Link to post
Share on other sites

Yes, that is a much simpler way to do it. I've tried it and it works.

Alternatively, instead of setting it to control Bus1, I can also set the mackie Master Fader to control any of 4 different Master faders.  So i have set it to control number 4. My outputs are on 1 and 2. This way I don't have to watch a dummy Bus  constantly twitching. I can just hide the offending Master volume control off to the right of the screen.

Is this a viable way of doing it? I can't see any shortcomings from doing it this way. It's quick and easy to set it up I can hide the twitching Master volume fader so I am not distracted by it.

 

Share this post


Link to post
Share on other sites
11 hours ago, CMilli said:

Yes, that is a much simpler way to do it. I've tried it and it works.

Alternatively, instead of setting it to control Bus1, I can also set the mackie Master Fader to control any of 4 different Master faders.  So i have set it to control number 4. My outputs are on 1 and 2. This way I don't have to watch a dummy Bus  constantly twitching. I can just hide the offending Master volume control off to the right of the screen.

Is this a viable way of doing it? I can't see any shortcomings from doing it this way. It's quick and easy to set it up I can hide the twitching Master volume fader so I am not distracted by it.

 

Yes, that makes total sense.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...