Jump to content
  • 0
wa7saka

audio unable to playback

Question

Hello, I need some help.

I've never used a DAW before and only have experience with audacity and a few other stuff. I loaded in an mp3 file and hit play to try to listen to it, but instead I got an error message saying "unable to open audio playback device". I'm only using Realtek audio and don't have an audio interface. I'm not a tech person so I'm not sure how to do anything... anyone know how to fix this?

I only just downloaded today and am trying to figure things out and tried watching Youtube videos too but nothing worked. Help would be appreciated

Edited by wa7saka

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Hi wa7saka and welcome to the Cakewalk forums.

What driver mode is your project currently set at?  (see Edit | Preferences > Audio > Playback and Recording > Driver Mode)

image.thumb.png.7e3b96909447fc33560122245c0c2312.png

Kind regards,

tecknot

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

This is common.  As Mr Tecknot has recommended- Use WASAPI mode -DO NOT us asio4all that was 15 years ago.  

And always check your Master bus is set to your speakers and not the Digital output.  

Share this post


Link to post
Share on other sites
  • 0

ASIO4all is simply a wrapper for WDM mode. It is not a true ASIO driver.  Only an ASIO driver can calculate the timing offset properly.  Don't get me wrong I used asio4all for 2 years on a laptop and it was great.  But it is no longer needed due to WASAPI and if the OP purchases a proper audio interface then asio4all becomes a problem on some systems and has to be removed. WASAPI works real good on W10 systems if all your doing is midi or loops. You cannot expect to overdub new tracks and have them sync properly in any other mode.  

This is a loopback test using different modes.   I have never tried a loopback with asio4 all and it would be interesting to see the results. 

1511239984_4-OfficLoopbackbest.thumb.png.097295db16c74fd106ab4fa78c1aeca7.png

Share this post


Link to post
Share on other sites
  • 0
On 2/16/2021 at 9:14 AM, Jeremy Murray-Wakefield said:

ASIO4ALL still performs more reliably, provides better latency, and is more flexible than WASAPI on both my laptops. So why the "DO NOT" in capital letters?

Are you using W7? I downloaded asio4all and it installed and I get the PDF file and it shows under apps but my system does not recognize it as a driver so I couldn't test it. Last time when I used it was on this same laptop using W7. The Laptop is now W10. And there should be a icon in the tray to access settings etc. I noticed the documentation only mentions W XP and Vista??? So anyhow I uninstalled it and that's that.  

Anyhow I see this is yet another "waste of time thread" as the OP obviously has wandered off after only 1 post. I wonder how many 1 post users there are on file now?  This whole Q&A thread is sort of a waste of time. Nobody ever votes best answer. 

Edited by John Vere

Share this post


Link to post
Share on other sites
  • 0
31 minutes ago, John Vere said:

Are you using W7? 

No, both are on W10 with latest updates - it's still the best performer for me overall, and can normally cope under circumstances where nothing else copes.

31 minutes ago, John Vere said:

Anyhow I see this is yet another "waste of time thread" as the OP obviously has wandered off after only 1 post.

Ah well. Maybe one day they'll be back 🙂

Share this post


Link to post
Share on other sites
  • 0

 

1 hour ago, Jeremy Murray-Wakefield said:

No, both are on W10 with latest updates - it's still the best performer for me overall, and can normally cope under circumstances where nothing else copes.

 

I might try a different computer then as I'm know curious. Is there more than one place to download? I used this   https://www.asio4all.org/

The home page is pretty offensive. 

Share this post


Link to post
Share on other sites
  • 0
On 2/16/2021 at 8:13 AM, tecknot said:

Hi wa7saka and welcome to the Cakewalk forums.

What driver mode is your project currently set at?  (see Edit | Preferences > Audio > Playback and Recording > Driver Mode)

image.thumb.png.7e3b96909447fc33560122245c0c2312.png

Kind regards,

tecknot

Hello thanks

my driver is on ASIO right now

Share this post


Link to post
Share on other sites
  • 0
On 2/16/2021 at 9:06 AM, John Vere said:

This is common.  As Mr Tecknot has recommended- Use WASAPI mode -DO NOT us asio4all that was 15 years ago.  

And always check your Master bus is set to your speakers and not the Digital output.  

oh... so I should switch to WASAPI driver rather than ASIO? I'll try that. How do I check if master bus is set to my speakers and not digital output? 

Share this post


Link to post
Share on other sites
  • 0

Hello everyone, thank you.

After switching to WASAPI shared instead of ASIO I can play audio now thanks. Sorry for the very late response I was busy with stuff.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...