Jump to content
  • 0
Orvil Ivie

Copy and paste leaves blanks between measures

Question

I get around pretty well on CbB and I’ve been using Cakewalk products’ starting back in the mid 90’s mostly to edit MIDI files for backing tracks and some audio recording (still love it)!

But, a lot of times (not always) when I edit the arrangement either in MIDI or audio when copying and pasting sections (using multiple paste repetitions) after a few of the pasted parts there’s a black space (1 or more measures or partial measures ) between them and I have slide the measure(s) over to close the gaps…this also happens when I copy & paste audio.

Of course I set the grid and make sure my copy sections are correct. I find the pasted sections seem to start sliding right or left of the nearest ¼ note!

Would appreciate any advice….

Edited by Orvil Ivie
Make question more clear and add a tag

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Thanks...I've never used ripple edit!

I'll study up on it...does it also effect MIDI clips...is it enabled by default?

 Thanks again, I so much appreciate the help!

Share this post


Link to post
Share on other sites
  • 0
28 minutes ago, Orvil Ivie said:

Thanks...I've never used ripple edit!

I'll study up on it...does it also effect MIDI clips...is it enabled by default?

 Thanks again, I so much appreciate the help!

Ripple edit effects everything, including MIDI clips.

I don't use it much either - you would want to only use it when needed.

The ripple edit is the button under the min/max/close buttons on the track view window.

There are no keybindings to it by default.  However, it you have set some (I suspect you have not though), you might be pressing the key by mistake.

See:

http://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=Arranging.33.html
 

Share this post


Link to post
Share on other sites
  • 0

Make sure you only have highlighted the material you want to copy. sometimes you will see that previous measures have been selected, even though there is no material in them. If that is the case, de-select them. i think I do it by holding down Control so only the measures I don't want in the selection are affected. 

Share this post


Link to post
Share on other sites
  • 0

 

I usually highlight the track and use the select tool to copy the part to be pasted! Also, sometimes I select the measures while in notation view.

I see there are a few options along with the select tool...I'll experiment with them.

Thanks for the reply I appreciate the help!

Share this post


Link to post
Share on other sites
  • 0

Yes, I'll make sure the ripple button is off!

Back in Cakewalk 8.5 I would have same problem...I would just open the same midi file in Sonar x3 and it pasted fine (maybe ripple was on in 8.5 and not in x3).

Thanks for the help

 

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Orvil Ivie said:

Yes, I'll make sure the ripple button is off!

Back in Cakewalk 8.5 I would have same problem...I would just open the same midi file in Sonar x3 and it pasted fine (maybe ripple was on in 8.5 and not in x3).

Thanks for the help

 

If it happened in Cakewalk 8.5, then it's not ripple edit.  Ripple edit was not a thing until the Sonar Platinum years.

One other thing it might be is in the advanced Paste Dialogue box, you may have ticked “Slide over to make room” instead of "Blend old and New".

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...