Jump to content
MisterX

Cakewalk freezing caused by a foobar plugin [solution]

Recommended Posts

If you have a program called "ASIO Proxy" installed on your machine you'd probably notice, that your CW is freezing for 40-50 seconds. Not instantly - it happens about 45-55 seconds after CW launch. After that CW unfreezes and you can work normally. Until next CW launch, that is...or until you change anything in preferences in current CW session.


So guys,  if you want to avoid this problem simply uninstall "ASIO Proxy", at least while working with CW.
Strangely I've had no issues with "ASIO Proxy" on other DAWs or audio programs; seems like it's just Cakewalk, that hates it so much ;)


My suggestion to CW devs will be to EXCLUDE either:

1. reading of Registry entries for this driver, which would make it non existent for CW (since it's completely useless for CW anyway)
2. loading the driver itself (foo_dsd_asio.dll and/or foo_dsd_asio_x64.dll)
3. both of above

I'm not sure if it's already possible, but in case it isn't - I'd also suggest to implement a function in future CW editions to let users choose which ASIO drivers to exclude / load on CW startup (be it from within preferences), should other ASIO drivers conflicts arise. I mean totally exlude from loading into CW, not just unchecking in audio devices list, as this driver freezes CW even if inactive, see screenshot.

 

PS. 1

"ASIO Proxy" is kind of dedicated ASIO (?) driver that helps foobar reproduce DSD streams on DSD capable DACs.
For more see: https://sourceforge.net/projects/sacddecoder/files/foo_dsd_asio/


PS. 2

Respective locations for "ASIO Proxy" dll files may be:

a) for 64 bit systems = c:\Program Files (x86)\ASIOProxy

or

b) for 32 bit systems = c:\Program Files\ASIOProxy


PS. 3

Location for "ASIO Proxy" Registry entries for both 32 and 64 bit systems is:


[HKEY_LOCAL_MACHINE\SOFTWARE\ASIO\foo_dsd_asio]


Regards, and happy unfreezing
MisterX

asioproxy.jpg

Edited by MisterX
typo

Share this post


Link to post
Share on other sites

i found foobar had too many things going on on my systems, surprising given all the accolades. so i uninstalled everything single thing i could find related to foobar, and the system is happier for it... ymmv

Share this post


Link to post
Share on other sites
Just now, Glenn Stanton said:

i found foobar had too many things going on on my systems, surprising given all the accolades. so i uninstalled everything single thing i could find related to foobar, and the system is happier for it... ymmv

It's not a foobar issue, it's this "ASIO Proxy" (3rd party) driver to blame, I guess.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...