Jump to content
James Meyerhoffer

Cakewalk won't launch/open

Recommended Posts

Hello everyone. Long time user in need of a bit of technical help. My install was working fine, I moved locations, now Cakewalk won't open. When I click on the Button in the Assistant, the outer frame of the app with flash, and then disappear. I have removed and reinstalled both only to have the same condition. I think it might somehow be Audio device related in Windows 10, but honestly I've exhausted many options. Cakewalk simply will not open. Flashes, then crashes instantly back to a desktop. 

What can I do to narrow this down? Not sure what caused this out of the blue, but it's brought my entire rig to halt. Is there a diagnostic log I can dive into to see wtf is happening with it? I'm sitting in a room full of instruments and can't record a note. :( Help!

Edited by James Meyerhoffer

Share this post


Link to post
Share on other sites

You shouldn't need to run Cakewalk via the assistant.

Does it work running Cakewalk directly?

Share this post


Link to post
Share on other sites
2 hours ago, msmcleod said:

You shouldn't need to run Cakewalk via the assistant.

Does it work running Cakewalk directly?

No, same behavior. It flashes like it about to open, then crashes to desktop. No change with Admin or Compatibility modes. 

Share this post


Link to post
Share on other sites

Just re install Cakewalk. When you say you moved location do you mean you moved your computer to a different location or your files? 

Share this post


Link to post
Share on other sites

I physically moved the PC to another home. I have removed and re-installed Cakewalk, and the Assistant MULTIPLE times... it does nothing, nor does it change the behavior. Install location is always default. No matter WHERE I start Cakewalk from, it flashes to outline of the Program for a split second, then crashes....every....single....time. I have disabled AV, given it Admin rights, almost everything I can think of.... It just stopped for some reason and now it simply will not start. It has to be leaving a log record somewhere right?  

Share this post


Link to post
Share on other sites

Do you get a crash dialog? That is the log. If so send a link to the dump file and we can tell you why its crashing.
Link in my sig.

Share this post


Link to post
Share on other sites

I am having the same issue.  I installed it got it to open the first time.  never could get any output sound after trying all drivers and audio options, so shut down and unplugged all controllers and restarted the PC.  When i tried to re-open the same thing.  splash screen with the grey kernel screen loading behind it, and back to desktop.  Windows 10.  My Rekordbox works just fine, Komplete Kontrol and Kontakt also, using the same audio profiles, that do have sound output.  But Cakewalk simply will not load, uninstall, re-install repeat, take two pills and call me in the morning. No crash dialog at all, just like it never happened.

Share this post


Link to post
Share on other sites
Just now, Enig-J said:

I am having the same issue.  I installed it got it to open the first time.  never could get any output sound after trying all drivers and audio options, so shut down and unplugged all controllers and restarted the PC.  When i tried to re-open the same thing.  splash screen with the grey kernel screen loading behind it, and back to desktop.  Windows 10.  My Rekordbox works just fine, Komplete Kontrol and Kontakt also, using the same audio profiles, that do have sound output.  But Cakewalk simply will not load, uninstall, re-install repeat, take two pills and call me in the morning. No crash dialog at all, just like it never happened.

 

Share this post


Link to post
Share on other sites
On 1/22/2021 at 8:48 AM, Noel Borthwick said:

Do you get a crash dialog? That is the log. If so send a link to the dump file and we can tell you why its crashing.
Link in my sig.

no crash report. Upon uninstall, i combed the registry and system for any lingering files that might cause it to act the same.  No luck at all.

Share this post


Link to post
Share on other sites

I just refreshed windows 10, and then i've got the same issue.

- no matter how I launched the application, it shows up as a flash and then nothing.

- also tried uninstall/reinstall few times, no luck.

- checked the Task Manager, didn't see the applicaiton/process 

Share this post


Link to post
Share on other sites
4 hours ago, Leo Chen said:

I just refreshed windows 10, and then i've got the same issue.

- no matter how I launched the application, it shows up as a flash and then nothing.

- also tried uninstall/reinstall few times, no luck.

- checked the Task Manager, didn't see the applicaiton/process 

You could try the following:

1. Run RegEdit
2. Within RegEdit, locate  Computer\HKEY_CURRENT_USER\SOFTWARE\Cakewalk Music Software\Cakewalk
3. Rename the Core subkey to _Core
4. Run Cakewalk 

This will force Cakewalk to act as is if it is installed for the first time. 

Share this post


Link to post
Share on other sites
On 6/5/2021 at 7:07 PM, msmcleod said:

You could try the following:

1. Run RegEdit
2. Within RegEdit, locate  Computer\HKEY_CURRENT_USER\SOFTWARE\Cakewalk Music Software\Cakewalk
3. Rename the Core subkey to _Core
4. Run Cakewalk 

This will force Cakewalk to act as is if it is installed for the first time. 

Hi, I just tried, same result...

i'm thinking if this issue is not fixed when MSFT launched Win 11, then I for sure will drop Cakewalk.

thanks.

Leo

Share this post


Link to post
Share on other sites

@James Meyerhoffer @Leo Chen if the app starts and immediately exits the most likely cause is that your Microsoft VC redistributables are not up to date.
Follow the instructions in this thread to make sure you update them and then retry. Let me know how it goes.
The latest redistributables are here.

 

 

Share this post


Link to post
Share on other sites

The thread is off the rails because people are posting issues but not returning to say if they resolved the issue. Please people if you need help start your own thread and be community mindful and please check back if you solved the issue and let us know what the solution was. 
 

Oh and it’s been reported that if you try and use ASIO mode with on board audio you will have issues. Always use WASAPI mode with on board audio. Only use ASIO that comes supplied with your audio interface drivers 

Share this post


Link to post
Share on other sites

Agree with John Vere, "use WASAPI mode with on board audio. Only use ASIO that comes supplied with your audio interface drivers". Worked for me after most recent update.

Share this post


Link to post
Share on other sites
On 7/12/2021 at 12:00 PM, Willie Scoggins said:

Agree with John Vere, "use WASAPI mode with on board audio. Only use ASIO that comes supplied with your audio interface drivers". Worked for me after most recent update.

I just launched CbB right after booting up and it never opened. Turns out it went directly to Background Processes, it's favorite hiding spot these days. 

For me it's almost always an audio or USB conflict.

Share this post


Link to post
Share on other sites

Hi all,

1. just updated Microsoft VC redistributables

2. reboot computer

the result is the same, the cakewalk loading screen showed up and then ... nothing. no error log, no service running...

Leo

Share this post


Link to post
Share on other sites

Are there any entries in

HKEY_LOCAL_MACHINE\SOFTWARE\ASIO

If so, what are they

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...