Jump to content
Morten Saether

[CLOSED] Cakewalk 2021.01 Early Access

Recommended Posts

15 hours ago, forkol said:

Cakewalk Developers:

I was asked to test this bug fix by Support for the issue that I submitted to you guys:

1) On the sample I sent you guys to replicate the ACID-wave file issue, if you start that sample at measure #1, and are running WASAPI shared mode driver, you will get some noise/static at the start of playback of this sample.  Here's what I know about it:

-- Seems to only happen on WASAPI shared.  Seems to play fine on ASIO and WASAPI Exclusive.  

-- The weird thing, is that it will go away if you leave Windows Media Player open.   While it is open, no static if played.  If it is closed, then there is static if played from Measure #1.

-- There is no static if the sample is moved/dragged from starting at Sample #1 and started from another spot.

-- I don't see this issue in SoundForge 10 or Studio One 4.  But, I'm running ASIO for StudioOne4, so that is probably the reason why.

I would posture to think this is a strange interaction with Windows WASAPI Shared driver with the Audio engine of CBB.  Seems whatever resource it needs is there if Windows Media Player is open, but if it closed, I suspect CBB audio engine has to create/re-create the resource, and the time or memory in doing so, causes crackles in the audio playback if played from measure #1.

 

There is a logged issue with WASAPI shared where the first buffer has some clicks. I'll investigate this for the next major release. 
WASAPI shared uses the windows Audio engine for mixing and has somewhat different requirements as compared to ASIO or WASAPI shared so there must be some factor related to this that we need to handle differently for the first buffer. Its not related to measure 1 it has the same issue whenever playback is started irrespective of the playback position.

Share this post


Link to post
Share on other sites
17 minutes ago, Noel Borthwick said:

Re 1 there are no changes in this update to change behavior. This is a per project / template setting so you must have inherited it from your project file.
As scook noted this is in the media browser settings.

Re 2. This has nothing to do with 32 bit files. If its set as a one shot it will not loop. Its an authoring problem if its intended to be a loop.

 

1) Ok, cool.  From @Jonathan Sasor reply above, it implies that maybe some templates MIGHT have this set.  Apparently, the Basic one (which I used) does not.  Is it documented/known which ones might?  Also, as some have pointed out, it's not apparent knowing if "Preview samples at Tempo" is set, and it would be nice to be able to see it and toggle it on/off as an indicator button rather than the somewhat obscure current method. I'll write a FR for this.

2) Yes, I believe it's an authoring problem, and I will get with the vendor to see if they decide to fix it (probably not).  I think another feature would be nice would be to color-code one shots in a different font color, something similar to the Instruments/Effects menu that lets you know which are DirectX and VST2/VST3 based on font color. Also, the little message window at the bottom of the browser you can't see the full info about the sample, would be nice if we could get the full info shown with maybe something like a expanded tooltip when 'hovering' over that line.

Thank you very much for the fixes so far.

  • Like 1
  • Great Idea 1

Share this post


Link to post
Share on other sites
On 1/17/2021 at 7:13 PM, Colin Nicholls said:

Nope... you're using a custom theme. See here.

 

Thanks Colin.
Actually I was using Mercury .
Anyway, after a couple of restarts it seems to be working fine with Mercury an Tungsten.

image.png.54520690e3c56e5dbe59acfa24a0ceef.png

image.png.0c03829721dbe524475163310db21839.png

So far so good, thanks.

Share this post


Link to post
Share on other sites

2021.01 has now been made public! Thanks for your participation and please refer any additional feedback to the official release thread:
 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...