Jump to content
Diana Chahine

Errors, errors, and more errors...

Recommended Posts

On 1/11/2021 at 1:59 AM, Diana Chahine said:

SO, I've just bought an XLR Rode NT1 mic along with a M-Audio 192 6 Audio Interface and was excited about recording with less background noise than my previous USB mics!

But since getting it, I've had a hard time actually recording! I was using Audacity and Cakewalk previously, so I tried recording on those, ultimately gave up and downloaded Pro Tools (since it came with the AI), had even more errors, so I decided to come back to Cakewalk since I figured at least I'd know how to use it once I got rid of the errors, HA!

I'm operating on a Windows 10 (64 bit) HP laptop. I downloaded all the M-Audio drivers and had hoped I'd be all set to go!

LatencyMon told me that "One or more DPC routines that belong to a driver running in your system appear to be executing for too long. At least one detected problem appears to be network related. In case you are using a WLAN adapter, try disabling it to get better results. One problem may be related to power management, disable CPU throttling settings in Control Panel and BIOS Setup. Check for BIOS updates." -- To which I did disable CPU throttling in the Control Panel, but not through BIOS as I don't think I have that option?

I downloaded the ASIO4ALL driver, but I can't seem to set my output settings to my laptop speaker, so I can't use that as I don't have a compatible headphone to connect to my AI, so I've been using WIndows WASAPI.

In Audacity it'll just stop recording randomly.

In Cakewalk, the errors that I will constantly get are

- Unable to open audio record device (even though no settings have changed)

- The above audio device was disconnected from your system (happens during the recording multiple times)

- Audio Engine dropout errors (I literally get SO MANY of them - 0, 14, 15, 16)\

Any and all help/tips would be appreciated!!!

You need to set your sample rate in windows the same with that of your interface. 16bit/44.1khz or 24bit/48khz 

Read here

Make sure to uninstall ASIO4ALL from the computer completely. M-Audio comes with it's own Asio drivers and it way better than Asio4all that cause issues with every interface drivers. 

Also make sure to update your laptops usb drivers. 

Share this post


Link to post
Share on other sites
4 hours ago, Diana Chahine said:

Hi John,

Yes, I have read the instructions, a few times, but somehow it's still not working right for me! The input echo isn't on, but I still hear that echo, from the 2nd audio track, not from the recording track.

From what I understand in the manual, the USB/Direct knob mixes the input and output so that they'll blend together. Turning the knob to the USB side will result in a louder audio output from the computer (Track 2), while turning the knob all the way to the Direct side will result in a louder result from the recorded track (track 1). Am I understanding that correctly? The problem is, that knob seems to just be a volume knob. It treats both tracks the same and never gives a preference to one or the other regardless of where I turn it too. Turning it towards the USB side increases the volume of BOTH track 1 and 2, and turning it to the Direct side decreases the volume of both...

So just to be clear. When you say "The recorded track" is that the new track you are recording or is this a already recorded track in Cakewalk?

 If it is, then yes of course it will be part of the "USB" output. The Direct  is for monitoring you live mike input of the interface. When you use headphones and speak into your mike, it should be louder when you turn the control towards direct. It will go quiet when turned towards USB. 

The mix the levels of the all ready recorded tracks are balanced by the track level controls. And as I pointed out you best make all tracks run through the master bus. in your screen shot this was not happening. 

Edited by John Vere

Share this post


Link to post
Share on other sites
19 hours ago, John Vere said:

So just to be clear. When you say "The recorded track" is that the new track you are recording or is this a already recorded track in Cakewalk?

 If it is, then yes of course it will be part of the "USB" output. The Direct  is for monitoring you live mike input of the interface. When you use headphones and speak into your mike, it should be louder when you turn the control towards direct. It will go quiet when turned towards USB. 

The mix the levels of the all ready recorded tracks are balanced by the track level controls. And as I pointed out you best make all tracks run through the master bus. in your screen shot this was not happening. 

I have made both tracks run through the master bus output and that hasn't changed anything either.

Track 1 is the track that I am recording with my mic/AI, and that output sounds just fine.

Track 2 is an audio track that's been imported (ex. instrumental), with its output sounding metallic/echo-y. 

Regardless of what output I set both of these, I end up in the same scenario. Either both tracks increasing in volume when the USB/Direct knob is turned one way, or both tracks decreasing in volume when turned the other way. 

Share this post


Link to post
Share on other sites

We as slowly getting somewhere so just hang in there and we’ll get you on track. Pun intended 

OK so the sound of the track you recorded into track 1 sounds fine on playback but the download file sucks. This tells me you have everything working properly but there’s an issue with that particular file. 
What does that file sound like when you play it in Windows media player?

Share this post


Link to post
Share on other sites
20 minutes ago, John Vere said:

We as slowly getting somewhere so just hang in there and we’ll get you on track. Pun intended 

OK so the sound of the track you recorded into track 1 sounds fine on playback but the download file sucks. This tells me you have everything working properly but there’s an issue with that particular file. 
What does that file sound like when you play it in Windows media player?

Haha I appreciate your help!!

The track sounds fine in every other player and sounds fine when the output is set to my laptop speakers (when on the WASAPI shared driver). All tracks I import sound metallic, even though they're all normal sounding otherwise.

Share this post


Link to post
Share on other sites

OK. So what you are saying is when you play back a sound track file on any music player it’s fine But when you import it to Cakewalk and use ASIO drivers it sounds Metallic. When you play the same file with Cakewalk and WASAPI mode it sounds fine  

Let’s narrow this down  

When you use ASIO is you master bus going to different speakers? 

Are you listening with headphones or studio monitors connected to your interface?

The metallic sound seems like a good description of what laptops built in speakers sound like. 
 

Double check your output by muting the master bus you should hear nothing 

Share this post


Link to post
Share on other sites
15 hours ago, John Vere said:

OK. So what you are saying is when you play back a sound track file on any music player it’s fine But when you import it to Cakewalk and use ASIO drivers it sounds Metallic. When you play the same file with Cakewalk and WASAPI mode it sounds fine  

Let’s narrow this down  

When you use ASIO is you master bus going to different speakers? 

Are you listening with headphones or studio monitors connected to your interface?

The metallic sound seems like a good description of what laptops built in speakers sound like. 
 

Double check your output by muting the master bus you should hear nothing 

In short, I still have 2 problems:

1.   Metallic sounding imported tracks

2.   USB/Direct knob blending not working

In regards to # 1, Yes, all imported music tracks sound fine when played outside of Cakewalk (or within Cakewalk on a different driver than ASIO). However, with ASIO set as the driver, imported tracks sound metallic when sent to the AI output AND Master output. The recorded track from the AI input sounds fine regardless of what output device I set it to. And like I said, audio sounds fine when the output is my laptop speakers (although I only have the option of setting my laptop speakers as the output with a WASAPI driver (not the ASIO), and my AI only works properly with the ASIO driver.

In regards to #2, the USB/Direct knob seems to act purely as a volume knob right now. It doesn’t blend the two tracks together whatsoever. It either decreases the volume of both when turning it one way, or increases the volume of both by turning it in the opposite direction. And this is the same regardless of what output I have both tracks set to.

I'm listening via headphones through the headphone output on the AI and yes, nothing is heard when the Master is muted.

I’m really wondering if I should just return this M-Audio interface and get the Focusrite Scarlett 2i2 interface instead, since I’ve seen that there aren’t as many problems with its drivers…

Share this post


Link to post
Share on other sites
20 minutes ago, Diana Chahine said:

In regards to # 1, Yes, all imported music tracks sound fine when played outside of Cakewalk (or within Cakewalk on a different driver than ASIO). However, with ASIO set as the driver, imported tracks sound metallic when sent to the AI output AND Master output. The recorded track from the AI input sounds fine regardless of what output device I set it to. And like I said, audio sounds fine when the output is my laptop speakers (although I only have the option of setting my laptop speakers as the output with a WASAPI driver (not the ASIO), and my AI only works properly with the ASIO driver.

Please post images of these preference screens on your PC

http://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=0x22B19

http://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=0x20075

http://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=0x22B17

Double check the sample rate setting in the software supplied with M-Audio Interface and make sure it agrees with the sample rate set in CbB preferences (the last link above)

20 minutes ago, Diana Chahine said:

In regards to #2, the USB/Direct knob seems to act purely as a volume knob right now. It doesn’t blend the two tracks together whatsoever. It either decreases the volume of both when turning it one way, or increases the volume of both by turning it in the opposite direction. And this is the same regardless of what output I have both tracks set to.

The USB/Direct Knob will act as a volume knob if there is no signal at the M-Audio inputs. This is because, the knob mixes the signal from these inputs with the signal coming from the PC. All the way counterclockwise is 100% USB (the signal from the DAW) and 100% clockwise is the signal from the M-Audio Inputs.

Share this post


Link to post
Share on other sites
24 minutes ago, scook said:

The USB/Direct Knob will act as a volume knob if there is no signal at the M-Audio inputs. This is because, the knob mixes the signal from these inputs with the signal coming from the PC. All the way counterclockwise is 100% USB (the signal from the DAW) and 100% clockwise is the signal from the M-Audio Inputs.

I think this is the heart of the issue- You are still not grasping how this system works. I see this thread started in November! That's a long time to wait.  Sorry this is hard stuff to understand if your brand new to recording but everyone goes through the process. 

And you still didn't answer an important question. Are you monitoring with headphones or studio monitors attached to the Audio Interface.  Your laptops system should not be used when in ASIO mode,, only your interface. 

I think from the start your confusion is that the recorded tracks are controlled by the interface. As I said way back the level of recorded tracks are controlled by the faders of each track. Not the interface. That control is for setting input/ record levels. 

Not sure why your music files sound different than the recorded track, Did you make sure there are no effects on that track? Look in the Pro Channel or BYpass all effects using the toggle. 

Edited by John Vere

Share this post


Link to post
Share on other sites
4 hours ago, Diana Chahine said:

In short, I still have 2 problems:

1.   Metallic sounding imported tracks

In regards to # 1, Yes, all imported music tracks sound fine when played outside of Cakewalk (or within Cakewalk on a different driver than ASIO). However, with ASIO set as the driver, imported tracks sound metallic when sent to the AI output AND Master output. The recorded track from the AI input sounds fine regardless of what output device I set it to. And like I said, audio sounds fine when the output is my laptop speakers (although I only have the option of setting my laptop speakers as the output with a WASAPI driver (not the ASIO), and my AI only works properly with the ASIO driver.

To me, this sounds like you have the tracks going to 2 destinations simulataneously (master and direct to the hardware), and if the master is then also going to the hardware output, then potentially you are going to get some phasing (you shouldn't, but there may be something else afoot here) which will affect the sound quality in the way you describe.

I may be misunderstanding your routing however.

Share this post


Link to post
Share on other sites
2 hours ago, Kevin Perry said:

To me, this sounds like you have the tracks going to 2 destinations simulataneously (master and direct to the hardware), and if the master is then also going to the hardware output, then potentially you are going to get some phasing (you shouldn't, but there may be something else afoot here) which will affect the sound quality in the way you describe.

I may be misunderstanding your routing however.

The possibility of phasing does make sense! But the same thing occurs when I set the tracks to go to the same destination (such as the AI as the output).

Share this post


Link to post
Share on other sites
6 hours ago, scook said:

Please post images of these preference screens on your PC

http://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=0x22B19

http://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=0x20075

http://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=0x22B17

Double check the sample rate setting in the software supplied with M-Audio Interface and make sure it agrees with the sample rate set in CbB preferences (the last link above)

The USB/Direct Knob will act as a volume knob if there is no signal at the M-Audio inputs. This is because, the knob mixes the signal from these inputs with the signal coming from the PC. All the way counterclockwise is 100% USB (the signal from the DAW) and 100% clockwise is the signal from the M-Audio Inputs.

image.png.0f31285a4a8a46dc867ea0962b4a6be8.png

 

image.png.4ac665dee5b3598b613930b83560b253.png

 

image.png.91db52118acfbd5f18df3269a3ece45f.png

Share this post


Link to post
Share on other sites
6 hours ago, John Vere said:

I think this is the heart of the issue- You are still not grasping how this system works. I see this thread started in November! That's a long time to wait.  Sorry this is hard stuff to understand if your brand new to recording but everyone goes through the process. 

And you still didn't answer an important question. Are you monitoring with headphones or studio monitors attached to the Audio Interface.  Your laptops system should not be used when in ASIO mode,, only your interface. 

I think from the start your confusion is that the recorded tracks are controlled by the interface. As I said way back the level of recorded tracks are controlled by the faders of each track. Not the interface. That control is for setting input/ record levels. 

Not sure why your music files sound different than the recorded track, Did you make sure there are no effects on that track? Look in the Pro Channel or BYpass all effects using the toggle. 

I just started this thread on Sunday, so definitely not since November! I'd still like to figure this out ASAP though!

I did answer your question, maybe you didn't see my response to it?

7 hours ago, Diana Chahine said:

I'm listening via headphones through the headphone output on the AI and yes, nothing is heard when the Master is muted.

Maybe I'm not understanding what you mean by "faders of each track". I've been going into the Console and adjusting the volume of both tracks, but that hasn't made a difference. Is that what that is? And there's definitely no effects. I've bypassed them all too,  to be sure.

Share this post


Link to post
Share on other sites

Just curious... does the playback quality change any if you solo track 2?    If not, do you have any Sends enabled? 

Also, when you bypassed FX did you use the FX button in the Control Bar's Mix module?  That's the surefire way to do it. 

 

Share this post


Link to post
Share on other sites
27 minutes ago, SteveC said:

Just curious... does the playback quality change any if you solo track 2?    If not, do you have any Sends enabled? 

Also, when you bypassed FX did you use the FX button in the Control Bar's Mix module?  That's the surefire way to do it. 

 

I fixed one problem!! By changing the Interleave-Stereo to Interleave-Mono it plays the track normally! No more metallic or echo sounds!!

Now I just gotta figure out the USB/Direct knob issue!

Share this post


Link to post
Share on other sites

It’s not an issue. It is working correctly by what you say. It has nothing to do with the balance between recorded tracks. It is to balance your mike input with the computer playback WHILE RECORDING. After you have recorded a track the channel faders control the playback level of each track. If these are not working correctly then you are somehow sending the tracks via a aux or effects send   The stereo interleave should not change the sound. 
 

What template did you use to start the project? 

Share this post


Link to post
Share on other sites
12 hours ago, John Vere said:

It’s not an issue. It is working correctly by what you say. It has nothing to do with the balance between recorded tracks. It is to balance your mike input with the computer playback WHILE RECORDING. After you have recorded a track the channel faders control the playback level of each track. If these are not working correctly then you are somehow sending the tracks via a aux or effects send   The stereo interleave should not change the sound. 
 

What template did you use to start the project? 

Even while I'm recording it only acts as a volume knob. I've even set my gain at a 9/10 giving my mic a greater input but that hasn't changed anything either.

I used the basic template.

Share this post


Link to post
Share on other sites

Here is my console view, so I'm not sure if there's anything in there that needs changing? I've also found that when both recording, and on playback, that the sound will just disappear at random times. Nothing will be changed, and there won't be an audio engine dropout or anything, (the track will keep "playing", but it will all go silent... 

image.png.fc84db114de41b1928792dc28c82038c.png

Share this post


Link to post
Share on other sites

I made you a video- There is no sound, didn't have time to hook that up.

 

 

Edited by John Vere

Share this post


Link to post
Share on other sites

image.png.fc84db114de41b1928792dc28c82038c.png.c52e5d0fed7cb6ecf9e06a8257ac2284.png

This might explain the bad sound of the downloaded music track. I would assume it is a stereo track like shown in my video. This interleave would be stereo not mono. If it is a mono track then it might not be very good choice for a backing track. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...