Jump to content
  • 0
Barry de Roode

Brand new computer gives audio drop outs, old computer didn't

Question

I recently bought a new computer to boost loading times. However, the new computer gives constant Audio Drop Outs and hickups sounds.  Both computers have (as far as I can see) identical Cakewalk setups (I checked all settings one-for-one) and I use the same Focusrite Scarlett 20i18 3rd gen audio interface. On both systems I have updated evertything to the latest drivers. All my projects are at 44.100 Hz and 16bit. 

I cannot think of any reason why a 6 year old  computer performs better than a brand new 'beast'. Much appreciated if someone has some thoughts on this or some directions to solve this.

 

OLD COMPUTER

Dell XPS All in One 2720 (april 2015)

Processor: Intel Core i7-4770S CPU@3.10Ghz

Memory: 16 Gb DDR3 1600 MHz

Harddisk: LITEONIT LMT-32L3M mSATA 32Gb + ST2000DM001-1ER164 2000Gb

USB: 3.0

Windows 10 Enterprise

NEW COMPUTER

HP Pavilion All-in-One 27-d0010nd

Processor: Intel® CoreTM i7-10700T (2,0 GHz basisfrequentie, tot 4,4 GHz met Intel® Turbo Boost-
technologie, 16 MB L3-cache, 8 cores)

Memory: 16 GB DDR4-2933 SDRAM (1 x 16 GB)

Harddisk: 512 GB PCIe® NVMeTM M.2 SSD

USB: SuperSpeed USB Type-A poort 5 Gb/s

Windows 10 Home

 

SETTINGS

ASIO

Buffer Size 9.1 msec 400 samples

File System Buffer Size: 256kb

 

 

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

As it's customary with Intel 10th gen cpus, check your thermals. These SKUs are known to run quite hot and enter throttling very often. If that's the case, consider undervolting them.

Share this post


Link to post
Share on other sites
  • 0

I do not know how to undervolt the CPU, but I changed the power plan to "High Performance power plan" and I removed McAfee as well. It looks like there are some improvements, but the Audio Engine Dropouts keep coming.

What bothers me is that I didn't have to do any tricks with the old computer, but now I have to...

Share this post


Link to post
Share on other sites
  • 0

If using the internal sound chip do not use the RealTek ASIO driver. It is not suitable for DAW use.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Run latency monitor  try it on both machines 

ohttps://www.resplendence.com/latencymon

Try a USB 2 port as some older interfaces were reported to act up on USB 3 

There’s a thread in the main forum about optimization 

 

also Focusrite new drivers use normal settings now like 128/ 256  and not ms like 9   So check the web site  for a driver update 

 

Edited by John Vere

Share this post


Link to post
Share on other sites
  • 1

A couple of things to try.

Try disabling C-states and Intel Speedsteep (This is done in the PC's BIOS and the method varies between PCs). 

Try Start + run "control powercfg.cpl,,1" (without quotes) and set CPU Min and Max to 100%. 

In preferences | Audio | Configuration File try adjusting the following:
EnableSetThreadIdealProcessor = False
MixThreadCount = {number of cores minus 1}

You might like to exit Cakewalk by Bandlab, go to the following folder and make a copy of the AUD.INI file before doing this:

%appdata%\Cakewalk\Cakewalk Core

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Thanks for the responses, it helped a lot!

This is what I did (I copy pasted from the answers):

  • Location of Cakewalk Projects. The new computer has 2 HD's: a SSD with the operating system & programs and a SATA for data. I experimented with the location of the Cakewalk projects and it turned out that putting them on the SATA drive performed better (counter intuitive, I know)
  • Boost the CPU. There are several ways that achieve the same result: 
    • Start + run "control powercfg.cpl,,1" (without quotes) and set CPU Min and Max to 100%. 
    • Set the power plan to "High Performance power plan"
    • Note: I did not have any settings in the BIOS to alter
  • Tune Cakewalk.  In preferences | Audio | Configuration File adjusted the following:
    • EnableSetThreadIdealProcessor = False 
    • MixThreadCount = {number of cores minus 1}  (This really made the system run smoother)

All together it makes my new system as good as my old. Still wondering why it isn't much better, but I can live with the result so far.

Share this post


Link to post
Share on other sites
  • 0
51 minutes ago, Barry de Roode said:

Thanks for the responses, it helped a lot!

This is what I did (I copy pasted from the answers):

  • Location of Cakewalk Projects. The new computer has 2 HD's: a SSD with the operating system & programs and a SATA for data. I experimented with the location of the Cakewalk projects and it turned out that putting them on the SATA drive performed better (counter intuitive, I know)
  • Boost the CPU. There are several ways that achieve the same result: 
    • Start + run "control powercfg.cpl,,1" (without quotes) and set CPU Min and Max to 100%. 
    • Set the power plan to "High Performance power plan"
    • Note: I did not have any settings in the BIOS to alter
  • Tune Cakewalk.  In preferences | Audio | Configuration File adjusted the following:
    • EnableSetThreadIdealProcessor = False 
    • MixThreadCount = {number of cores minus 1}  (This really made the system run smoother)

All together it makes my new system as good as my old. Still wondering why it isn't much better, but I can live with the result so far.

I wouldn't count much on boost clocks. The advertised boost is only for a single core out of the 8 you have. The 4770S boosts lower, but his base frequency is higher. 1 GHz higher.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...