Jump to content
kevro2000

Timing of Playback does not match what I see visually

Recommended Posts

Hi, Everyone! HAPPY NEW YEAR!

I have 2 images below: they are each showing that that my MIDI trax (and audio Metronome track) are visually aligned.

However, when I play it, I do not hear beat one of first playback measure, until its on beat two. Which, of course, throws the timing off. So, when I'm listening to the metronome track in solo, for example, the STRONG beat is always falling on beat 2. If I close my eyes to record other trax, its ez enough to follow along and record: but not have the visual line up with the audial is  a bit disconcerting.

Anyone have a solution?

This has been going on for about a week, and for the life of me, I cannot figure out what I've changed, if anything.

 

image.png.afbbca509c5f97e02ffccbeee408b230.png  image.png.8efc9a037c26529c4108783b04b83ce2.png

Thanks, Kevin

image.png

Share this post


Link to post
Share on other sites
15 hours ago, kevro2000 said:

However, when I play it, I do not hear beat one of first playback measure, until its on beat two

Start your songs on beat 1, measure 2. apparently, the buffers need time to react. So beat 1 measure 1 may not be enough time

Share this post


Link to post
Share on other sites

Thank you, CJ Jacobson!

While your solution did not work when I tried your suggestion, my eye spied the little sync icon. It crossed my mind to click on Internal Sync, and voila'! That fixed!! Happy Camper about to record some music now! ☺So, indirectly, your idea led to me figuring it out!!

 

image.png.dc291c44dce5927e446982af95b618ca.png

Share this post


Link to post
Share on other sites

I'm just re-opening this thread, because I've never found a satisfactory solution to my problem.  In order for the playback marker to match the sounds, I have to tap the Internal Sync each time I "play" or "record"  It keeps auto setting itself to Audio Sync, but that causes an audio versus visual misalignment.  Very disconcerting to be trying to record and stay on beat, and I like seeing my waveforms align with what I'm hearing.

This all started occuring soon after installing a new Arturia Keylab 49 Essential  that I got for Christmas. Someone suggested I remove the Arturias drivers from the system, and that fixed their problem. Not working for me 😒

Has anyone had this, or found a solution, PLEEEEAAAAAAAASE?

Maybe, I need to remove and reinstall CW? I don't really wanna do that, but will if I have to.

Share this post


Link to post
Share on other sites

You didn't say which driver mode and audio interface you are using, Syncing issues are common if not using ASIO. 

 

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, John Vere said:

You didn't say which driver mode and audio interface you are using, Syncing issues are common if not using ASIO. 

Yes, sir. UR correct: I am using ASIO via Focusrite Scarlett 18i20 2nd Gen interface. I have played around with the Buffer Size setting, but that does not effect what is happening, here. 

I'm on a Win10 Pro desktop PC, on the latest CW update.

 

image.png.286ae6af61b41a7b94298a1849ff9690.png

I removed the solved tag, since this is not really taken care of.

 

Edited by kevro2000
Not Solved

Share this post


Link to post
Share on other sites

Hold the phone. I just read this again and what I think you’re saying is your watching the wave form as you play and it is out of sync. Yes this is the way it works. If you watch my video it might make more sense to you. As you can see in you settings there is latency that the DAW has to calculate and adjust for.  In your case this is 20 ms. That is probably exactly how much you’re seeing.   Don’t quote me on that I’m only taking a long shot. And I’m not sure about graphic card latency being part of this equation but it probably is. 
I know for sure my wave is always drawn late and then pops into place when I stop. 

Share this post


Link to post
Share on other sites
Posted (edited)

Yes, thats it!

In that case, this has been going on for years, and I've simply never noticed. Until recently . Sherlock, I ain't!

Hah.

<edit> However, if I click on Internal Sync, it lines up properly as it plays and records. Thats what I want it to default to.

Edited by kevro2000
added last line of text

Share this post


Link to post
Share on other sites
Posted (edited)

You should be using your ears, not your eyes to stay in time.

Edited by bdickens

Share this post


Link to post
Share on other sites
7 hours ago, bdickens said:

You should be using your ears, not your eyes to stay in time.

I agree.

If I have a track or tracks,  already recorded, then try to record a new track without hitting the Internal Sync button, this is what happens. I hear when I'm supposed to come in. Record the new track. Then, when I playback the whole thing, the newly recorded track is behind the older track(s).  Now that I'm typing this, I have not reported that part of it before. The old track(s), lets say, starts on the 1st beat of the measure, and visually appears so. My newly recorded track, will be behind by that 20ms or however long the delay is.  Its weird.

If I remember to tap, Internal Sync before recording, then all is well. I've never had to that before Christmas 2020. I've always just armed a track, pressed record and went with it.

As further info, I tested this last nite: I usually record an audio-metronome track. So, on a project last night, I thought I'd play both CW's built in metronome and my audio track metronome: they both sounded at the same time, but slightly behind where the playmarker said they should be.

Share this post


Link to post
Share on other sites

I should have caught this earlier. You do not want to use internal sync. Not sure why that is working because technically it shouldn't. 

From the documentation- 

sync type. Select the sync type. The following sync types are supported:

Internal Sync . Timing is determined by the clock on the computer motherboard.

MIDI Sync . Timing is determined by the clock on an external MIDI device.

SMPTE/MTC Sync . Timing is determined by a time code signal (in SMPTE or some other format) recorded on some external medium or generated and sent by Cakewalk.

Audio Sync . Timing is determined by the clock on the computer’s audio interface.

Here are some screen shots of what your audio preferences SHOULD look like. And you always use the audio sync because that is why we use ASIO drivers. 

Notice that the Focusrite MUST show as the Playback and timing master as well as for Recording Latency adjustment Device .

I  explain in detail in my Why ASIO is important video. I have a feeling it isn't your Focusrite being used for sync. 

 

1469940922_Screenshot(56).png.bf80df2181f5b67b22da408b9e893da9.png348019768_Screenshot(57).png.36540c620da1c0b695879fa6f08d7b18.png1539122496_Screenshot(58).png.558e05ffd4c038fd38f171803395daf1.png

Share this post


Link to post
Share on other sites

Thanks, John!! I'll double check all these settings as soon as I get back to my cw machine. I'm pretty sure I have them set correctly, but will double check. Esp the RECORD AND LATENCY settings. Off the top of my head, don't remember noticing that before.

Share this post


Link to post
Share on other sites
4 hours ago, kevro2000 said:

If I have a track or tracks,  already recorded, then try to record a new track without hitting the Internal Sync button, this is what happens. I hear when I'm supposed to come in. Record the new track. Then, when I playback the whole thing, the newly recorded track is behind the older track(s).  Now that I'm typing this, I have not reported that part of it before. The old track(s), lets say, starts on the 1st beat of the measure, and visually appears so. My newly recorded track, will be behind by that 20ms or however long the delay is.  Its weird.

You didn't make that clear before.

That sounds like too much latency. You probably need to adjust those settings.

Also, like John says, you should always have the sync set to audio.

  • Like 2

Share this post


Link to post
Share on other sites

Also I hope your using direct monitoring . Do not use the Input echo or you will hear the latency.  

  • Like 1

Share this post


Link to post
Share on other sites

Yes, I always use direct monitoring, thanks - - >

27 minutes ago, John Vere said:

Also I hope your using direct monitoring . Do not use the Input echo or you will hear the latency.  

I've checked my settings, too as described above for driver settings and sync and caching: they are what they are supposed to be.

How weird.

Share this post


Link to post
Share on other sites

I've attempted to upload a GIF image: while there is no audible sound, you can see more clearly what I'm talking about. The meters do not activate until beat 2 (or so) of bar 4.  That's when I hear playback, unless I tap on Internal Sync.

1155569279_CWdelayssound.gif.33cbd6fc76481998a30c02a0fcf96cdf.gif

  • Like 1

Share this post


Link to post
Share on other sites

You need to perform a loop back test Follow my instructions in the video I posted above. And download the RTL utility app this will give us some clue as to what is not right.  

Share this post


Link to post
Share on other sites

I'll give that a try this weekend. Thanks, John.

On 3/21/2021 at 6:49 PM, John Vere said:

need to perform a loop back test

 

  • Like 1

Share this post


Link to post
Share on other sites

Like so many issues, the fix to this seems to be:

  1. Reset Focusrite 18i20 to initial values
  2. Uninstall CWbB
  3. Reinstall CWbB

Thanks for all who attempted to help. Quite the long learning experience, but I'm glad to have CW working normally now.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...