Jump to content
Sign in to follow this  
sergedaigno

Something's wrong with Vsti plugins ?

Recommended Posts

I drawn some Midi CC events (CC1 Modulation, CC7 Volume, CC11 Expression, CC10 Panning) into the piano roll. Vsti plugins sometimes respond well to some while been not affected at all by other CC changes . Also changing the velocity value into the Event List has no effect on Kontakt player.

SampleTank 3        : Event List Velocity, Yes   |   CC11, No    |   CC7, No    |   CC10, No    |   CC1, No
Kontakt player 6  : Event List Velocity, No    |   CC11, No    |  CC7, Yes    |   CC10, Yes   |   CC1, Audio Engine dropout
Real Guitar 5         : Event List Velocity, Yes    |   CC11, Yes   |  CC7, Yes   |   CC10, No     |   CC1, Yes

I don't see how to manage a problem that is not evenly distributed among those plugins. Any suggestion is welcome.

Share this post


Link to post
Share on other sites

Well, it's basically up to each respective VST instrument how to react to CC events. With Kontakt, it's up to each sample library how midi CC and velocity (and all other modulations) are handled.

I don't think Cakewalk transmits CC etc. differently to different synths, so check each synth's settings carefully.

Good luck!

Share this post


Link to post
Share on other sites

I'm afraid you are right 🙂. Testing again in standalone mode using Loopmidi lead to same results. I had no doubt about the CC's transmission, but rather about the handling of Vsti's. Midi Learn should help to overpass some CC lacks. Thanks 

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...