Jump to content
Mark MoreThan-Shaw

Trying To Set Up New M-Audio Oxygen PRO controller

Recommended Posts

6 hours ago, tulamide said:

I'm not a technician, I simply don't know about all of that "behind the scenes" stuff (ACT, Mackie, HUI, etc). Isn't there one consistent way to get it to work? It seems so strange, that for some it works by selecting Cubase and Mackie, for others it works like Mike Z described, and yet again others need to select another DAW than Cubase or MPC.

Use Cubase mode on keyboard and 'Mackie control' surface in Cakewalk. In 'Mackie control' configuration, set "Disable handshake" option. Do not insert "ACT" (nor any other) surface plug-ins (so, there should be exactly one 'Mackie control').

Enable one pair of input+output which you think is DAW control. Based on your text "Mackie" (other write MIDIIN3/MIDIOUT3) and assign these to 'Mackie control'.
Check transport is working. Enable primary MIDI input, the one which transfer keys, so you can play soft-synth.

PS There can be difference in resulting functionality, but transport and faders will work the same way in case any Mackie mode is selected on keyboard. But it should be some Mackie mode. Cubase and REAPER are Mackie modes. Other not sure (and some for sure not).

PSPS There are other approaches to use this device with Cakewalk. And there are some advantages and disadvantages of these approaches. That is no "one consistent way", there are "many consistent ways"! But watch out... some suggestions in this thread are not really consistent...

  • Like 2

Share this post


Link to post
Share on other sites
20 hours ago, azslow3 said:

Use Cubase mode on keyboard and 'Mackie control' surface in Cakewalk. In 'Mackie control' configuration, set "Disable handshake" option. Do not insert "ACT" (nor any other) surface plug-ins (so, there should be exactly one 'Mackie control').

Enable one pair of input+output which you think is DAW control. Based on your text "Mackie" (other write MIDIIN3/MIDIOUT3) and assign these to 'Mackie control'.
Check transport is working. Enable primary MIDI input, the one which transfer keys, so you can play soft-synth.

This did it for me! It's not perfect (loop control doesn't work, and all knobs do nothing), but it is a good start! Thanks so much!

  • Like 1

Share this post


Link to post
Share on other sites
On 11/18/2021 at 5:47 PM, Mike Locus said:

Got it.  Works now.  Here's what I did and thanks to   Guerilla Genus above for the clue:  ...don't use Act.  Just Mackie Control.  Set DAW on controller to Cubase.  I think that's all you need to do.  Controller was not stable at first but with a reboot... seems to be stable now.  -All sliders/banks, knobs & banks. Pads& banks.  The only thing 'not'  is the circle button which I expected to arm the track for recording. 

Disable Handshake. >Utilities>Mackie#. Seems to be working for the moment.

Edited by Mike Locus
updating data

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...