Jump to content
Pete Laramee

Problem with Dropouts!

Recommended Posts

New computer.  10th Gen i7, 32GB ram, 1TB SSD (75% free space), and 2TB HDD (80% free space).  I had the buffer at 512 for playback and was getting dropouts.  I've since changed the playback buffer to the max at 1024 and I'm still getting  occasional dropouts.   ERROR code (1).  Average song has a total of about 36 audio tracks, 6 buses, 60 or so sonitus effects and one instance each of Izotope Ozone, LP64, and Boost 11.  Cakewalk by Bandlab 64 bit.  I also have 8.5PE installed, but don't use it.

I'm not super computer savvy.  I'm keeping the song files on the hdd...should I move them to the ssd?  Does my interface have anything to do with it?  It's a 3rd gen focusrite 18i20.  Is my computer not enough?  Maybe an i9?

Any ideas? 

 

 

Edited by Pete Laramee
More Info

Share this post


Link to post
Share on other sites

If you're using ASIO mode on the 18i20,  and you're using Focusrite's own ASIO driver, you should have absolutely no problems with dropouts in normal use.

I've personally had issues with Izotope Ozone... this could be a factor.  Also, the LP64 needs a lookahead buffer so it significantly increases latency, but it shouldn't cause dropouts.

You could try resetting your AUD.INI by going to Preferences->Audio->Configuration File, and clicking the "Reset Config to Defaults..." button.  The only thing I'd recommend changing from the defaults is "Thread Scheduling Model", which I have set at 2.

Having a very low DroputMsec value will cause issues, but the default of 250 should be absolutely fine.

Also make sure your Cakewalk program directories, plugin directories, any sample directories used by plugins and your Cakewalk project directories are excluded from virus scanners / cloud sync apps.

FWIW I'm using a 1st gen 18i20 with a 3rd gen i7 + 16GB RAM, and I'm using an ASIO buffer size of 64.  I hardly ever get dropouts, and if I do, I just up the buffer size to 128.

  • Thanks 2

Share this post


Link to post
Share on other sites

Error 1 (buffer underrun) is the most common dropout code. It means that the computer couldn't fill the output buffer fast enough, so when the interface went to grab the next piece of data there wasn't anything in there. In short, the computer just couldn't keep up.

Since increasing your buffer size didn't help, you're going to have to do some detective work. Something is preventing your CPU from having enough time to fill those buffers, and it probably has nothing to do with your project or your Focusrite. I've run over 80 tracks from a conventional drive (I also have a Focusrite, similar model but with Firewire) without dropouts. And my computer's not nearly as heavy-duty as yours. Your problem is that the CPU is dividing its attention between the DAW and something else.

What could that something-else be? Wi-fi adapters are a frequent culprit. If your computer has one of those, try turning the wi-fi off and see if that makes a difference. But any hardware device can potentially cause similar problems. There are also dozens of background processes that can eat CPU cycles. You're going to have to do some sleuthing. I know, you just want to make music, not be a computer technician. Sadly, sometimes you have no choice.

One tool that's often helpful is called LatencyMon from Resplendence. It's free. If your issue is with hardware, LatencyMon will tell you. Interpreting the information it provides can be a little confusing, but they do have some good tips on their site, and you can post the results here so somebody can have a look at them.

Also check Task Manager, or better, Process Explorer. This free tool will show how much CPU each process is using, and thus identify any background process that's being too greedy with your precious CPU cycles.

Given that it's a brand-new computer, I'd first look for bloatware that often comes preinstalled on new computers. Vendors will throw all kinds of useless crap in there (because software companies pay them to), and some of it is network-intensive (not good; network traffic trumps everything else, including audio). Getting rid of that garbage will make your computer happier in general, not just the DAW.

BTW, what's your project sample rate? 

  • Like 4
  • Thanks 3

Share this post


Link to post
Share on other sites

I set the changes recommended by msmcloud.  It's better, but I'm still getting dropouts...even when the system is at rest w/out playback.  Maybe it's not related, but I'm also getting the following error...

image.png.ab8dbd1fa5f84ac0a87d06b4eb05e098.png

Sample rate is 44.1

Thanks for your help!

Pete

 

Edited by Pete Laramee
More Info

Share this post


Link to post
Share on other sites

What BitFlipper writes above is important to understand: you have buffers from and to the interface, and the computer must be able to read/write from/to them fast enough. It might be that your ASIO buffers are too small, but unlikely with a new system. My PC is not super-powerful and I run a 32 samples buffer with 4ms of roundtrip latency with no issues.

Also as BitFlipper says, there are a few cases of hardware components (or more often, their drivers which are not so well written) which generate lots of interrupts - resulting in high DPC count in Windows, slowing down everything else. Certain motherboard-installed network cards from Intel were notorious for this a few years back, especially in laptops, but in recent years  this has been far less of a problem. Sometimes it's surprising, for example the Corsair keyboard driver I had was using an huge amount of CPU for something so trivial as keyboard scanning. 

So excluding that, first of all, your PC must be optimized for real-time processing. That means disabling anything power-management related (both in the BIOS and Windows). removing any bloatware processes and services (your taskbar should be as empty as possible, and as BitFlipper suggests you can use Technet's process explorer to find out if something is overusing CPU). There's an optimization guide from the fellas at Focusrite which is well put together (https://support.focusrite.com/hc/en-gb/articles/207355205-Optimising-your-PC-for-Audio-on-Windows-10).

You want also to ensure the CPU cores are always on (it's an easy tweak in the Windows registry but you can use the free ParkControl utility for example at https://bitsum.com/parkcontrol/ , just turn it off once you've modified the settings).  And of course a SSD beats a rotating hard drive every day of the week and twice on Sunday.

Also, from the msg you show up it seems you have a motherboard sound card. That's likely gonna create I/O problems, so you want to go in Device Manager and disable all the related elements.

Look also at the Windows Services  that are running  - some are not needed and just steal CPU and I/O resources at the wrong moment. 

Best of luck!

 

  • Thanks 2

Share this post


Link to post
Share on other sites

Is your PC  a Dell.

If so, use TaskManager, Services to disable SupportAssistantRemediation.  Google it to read more.

Doing that solved ALL my dropout issues.  

That service can cause hard long interrupts.

 

Fwiw.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 12/13/2020 at 5:06 PM, Pete Laramee said:

I set the changes recommended by msmcloud.  It's better, but I'm still getting dropouts...even when the system is at rest w/out playback.  Maybe it's not related, but I'm also getting the following error...

image.png.ab8dbd1fa5f84ac0a87d06b4eb05e098.png

Sample rate is 44.1

Thanks for your help!

Pete

 

Ahh - interesting... this is the audio driver for the HDMI output.

This has been known to cause issues for some people. Try disabling it.
 

  • Thanks 1

Share this post


Link to post
Share on other sites

Yes, this is a Dell.  I used the task manager to disable support assistant.  Also, I disabled the HDMI to my monitor.  I'm trying 128 as a buffer setting.  So far I've had dropout with error (1) and another with error (5).  I just don't know enough nor do I trust myself to fool around with the bios or registry.

Thanks, 
Pete

 

Share this post


Link to post
Share on other sites
On 12/13/2020 at 3:00 AM, Pete Laramee said:

New computer.  10th Gen i7, 32GB ram, 1TB SSD (75% free space), and 2TB HDD (80% free space).  I had the buffer at 512 for playback and was getting dropouts.  I've since changed the playback buffer to the max at 1024 and I'm still getting  occasional dropouts.   ERROR code (1).  Average song has a total of about 36 audio tracks, 6 buses, 60 or so sonitus effects and one instance each of Izotope Ozone, LP64, and Boost 11.  Cakewalk by Bandlab 64 bit.  I also have 8.5PE installed, but don't use it.

I'm not super computer savvy.  I'm keeping the song files on the hdd...should I move them to the ssd?  Does my interface have anything to do with it?  It's a 3rd gen focusrite 18i20.  Is my computer not enough?  Maybe an i9?

Any ideas? 

 

 

I think it's not a problem in you hardware. It is something wrong with Cakewalk.

I also face to the problem. But I can give you some hint.

Before drop-out you have late buffer. Late buffer appears first. Then you have drop-out.

We definitely need some developer-level investigation.

BTW I tried with Reaper - same interface, same content - no problem.... I have also MixBus and it does not work smooth.
Moreover, I have problem when imported 19 tracks, and with FX off, WiFi disabled...

buffer.pdf

  • Thanks 1

Share this post


Link to post
Share on other sites

Still no  change for me.  I was texting on my phone - no playback or anything -  my computer was completely still - and I got the dropout error 1 message.

Edited by Pete Laramee
More Info

Share this post


Link to post
Share on other sites

I have a Dell and have seen similar error.  In my case the whenever the Dell's audio driver wants to use the asio soundcard intended for your DAW would cause CW to drop the audio.  I don't think you can disable the Dell's audio driver b/c it would disable your asio as well.  What I had to do is assigned the onboard card (whatever yours might be) to the Windows audio and make sure that the asio soundcard is disable in win audio settings.

  • Thanks 1

Share this post


Link to post
Share on other sites

Still getting dropouts.  Today...I was about to playback a solo I finally nailed I got a blue screen.  After two hours the screen was still there so I had to do a hard shut down.  Is it possible it's not cakewalk or my settings?

EDIT = I just want to mention this is not the first time I've had this happen while using cakewalk.

Thanks for your replies.

image.png.5f58a3205a67f28c4cef0a9eb93aacb2.png

Edited by Pete Laramee
More Info

Share this post


Link to post
Share on other sites
34 minutes ago, Pete Laramee said:

Still getting dropouts.  Today...I was about to playback a solo I finally nailed I got a blue screen.  After two hours the screen was still there so I had to do a hard shut down.  Is it possible it's not cakewalk or my settings?

EDIT = I just want to mention this is not the first time I've had this happen while using cakewalk.

Thanks for your replies.

image.png.5f58a3205a67f28c4cef0a9eb93aacb2.png

Your focusriteusb.sys failed. Download the latest focusrite drivers from their website.  

HERE: Latest Drivers

Also check out this: Solve known PC issue with CbB

Will ✌

Edited by Will_Kaydo
  • Thanks 1

Share this post


Link to post
Share on other sites

Latest focusrite drivers already in.  I'm going through your other link/thread and am going through all the things I understand first. LOL  So far everything is up to date.

 

  • Like 1

Share this post


Link to post
Share on other sites
38 minutes ago, Pete Laramee said:

Latest focusrite drivers already in.  I'm going through your other link/thread and am going through all the things I understand first. LOL  So far everything is up to date.

 

While you at it -  get the new Netframe 5.0 installed as well. It improves a few performance issues in Windows. 

Share this post


Link to post
Share on other sites
On 12/14/2020 at 1:06 AM, Pete Laramee said:

I set the changes recommended by msmcloud.  It's better, but I'm still getting dropouts...even when the system is at rest w/out playback.  Maybe it's not related, but I'm also getting the following error...

image.png.ab8dbd1fa5f84ac0a87d06b4eb05e098.png

Sample rate is 44.1

Thanks for your help!

Pete

 

Do you get this everytime it drops out? This usually means an external monitor is disconnected, so probably a loose hdmi cable or something. I get this whenever I switch my monitors screens to duplicate/extend and back.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...