Jump to content
Sign in to follow this  
Mr. Torture

Buffers issue

Recommended Posts

I use an RME PCIE soundcard running windows 10, 24 gigs of Ram. 

I was running buffers low at around 64 when using multiple soft synths and VST guitars. Now I cannot go below 512 with a single instance of EZ bass, Superior drummer and a real tube head lined in via Suhr reactive load. I just get distorted weird sounds through the guitar channel and a constant clicking. 

Bump up to 512 and all is good, except for the obvious latency..

Windows recently did a bunch of updates, what should I look at to fix this? Thanks!

 

 

Share this post


Link to post
Share on other sites

The RME is pretty old, computer is probably 7-8 years old now.

I will check to see if RME has any updates. They still sell that soundcard, so I imagine they have drivers.

Share this post


Link to post
Share on other sites

Buffer issues are back, same as before. cannot go below 512 with only one instance of EZ Bass running. I have all the latest downloads, drivers and the "Flash update"

 

Before I could run at 64 with multiple VST's and audio tracks going... 

Share this post


Link to post
Share on other sites

Just an update, I went into the task manager of my computer and seen there were about 4-5 of the "Bandlab assistant's" running? I shut them all down and re-opened Cakewalk. Now it seems I can run at 64 without issue?

Share this post


Link to post
Share on other sites
22 hours ago, Mr. Torture said:

Buffer issues are back, same as before. cannot go below 512 with only one instance of EZ Bass running.

I have a RME  UFX II with a buffer of 128  samples and everything works very well.

If you can not go below 512, I think that maybe your RME is a bit outdated.

  • Like 1

Share this post


Link to post
Share on other sites

RME makes very solid professional interfaces which they update regularly during many years. Don't know which of the few PCIe cards you have. I've got the RME PCIe AIO . Model is from 2009 and this year an improved PCIe version was introduced. When looking at the specs and changes I couldn't find any improvement regarding latency/speed, just better audio quality, less potential distortion caused by the environment,  increased signal-to-noise ratio and a lower output impedance at low reference levels etc.  This indicates that the more than 10 year old cards from RME can still be up to the task. There were both a driver and a flash update for my card as recent as this month. 
My PC (AMD Threadripper 1950X, 32GB Ram, SSDs) runs fine with larger projects. I noticed no difference with the latest Windows updates.

Considering you didn't have problems before the recent Windows updates I guess the problem is not the Card.

Just some wild thoughts:

  • Maybe some RAM going bad, HD failure, other hardware component failure
  • Cables that are not properly plugged
  • Another thing: after an update, Windows sometimes has the nasty habit of resetting custom settings, sometimes also re-enabling USB selective suspend... I would definitely double-check those
  • Maybe the updates have also introduced incompatibility with some of your FX plugins ( in case those are loaded as well) and they might need to be updated?
  • Are the Visual C++ Redistributable Runtimes up to date?
  • Did you check processor scheduling in CbB? You could try to play with those settings
  • Are sample rate and bit depth the same as Windows?
  • Do you use the ASIO driver in CbB?
  • Can you recall what you had changed before the issue came back?


 To find out what goes wrong on windows:

  • try Control Panel\All Control Panel Items\Security and Maintenance\Reliability Monitor => click on the alarm signs to find out the details
  • try other tools in the same Security and Maintenance directory like Windows Memory Diagnostics
  • try Windows event viewer. Explanations for use are in the hyperlink. This records anything software does on your PC and might pinpoint a problem you have.
  • try Whats my computer doing
Edited by Teegarden

Share this post


Link to post
Share on other sites

Like I said in the previous post, I found several instances of Bandlab assistant running when I checked task manager. I actually shut off Bandlab assistant in the start up and now Cakewalk operates without any issues. I can record with buffers at 64, even with multiple VST's running.

Share this post


Link to post
Share on other sites

Is it several instances of BA or one instance with several threads?

The later is normal for programs built with the Chrome Embedded Framework.

Share this post


Link to post
Share on other sites

Well, it's back again, With only 2 tracks going I am forced to run the buffers at 256, which is ridiculous.

I have one track of guitar recorded, only running a cabinet & noise gate VST. The same on the second track, with no recorded material yet.

When I have the second track armed the guitar sounds distorted and I start getting this click sound, kinda like a metronome. Only way to get rid of both is to return the buffers to a minimum of 256. If I add anything else to the project, the buffers have to go higher.

 

I could run several VST's in the past at 64 with no issues. I haven't done anything to my system other than the standard updates.

 

RME drivers and flash updates have been done, still the same problem.

Share this post


Link to post
Share on other sites

Here is CW with buffers at 128, yet everything sounds broken up and has this insidious clicking going on. I have 2 tracks of guitars with no plugins, One instance of superior drummer. That's all...

Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz   3.49 GHz

32 Gigs of RAM

screenshot.png

Edited by Mr. Torture

Share this post


Link to post
Share on other sites
2 hours ago, Bruno de Souza Lino said:

Try setting your Thread Scheduling Model to Agressive in Advanced Settings.

How is that done?

Share this post


Link to post
Share on other sites

And did you run Latency Monitor? this is important to do when having dropouts as it will narrow down the list of causes. There's no point randomly changing settings until you narrow it down. Example a week ago this topic came up and it was a Graphic card. Remove the graphic card and use on board video, DPC cut in half. Problem solved. 

Share this post


Link to post
Share on other sites

Changing thread schedule didn't work. Honestly, all my trouble began when I was forced to upgrade to windows 10, never a lick of problems before that. I opened a new project with one instance of superior drummer only, set superior to 16 bit mode, used the smallest kit (Around 500 mb's) 

Set buffers to 64 and if I play any single drum it's all distorted and I get that clicking noise again.

Where do I get a latency monitor? I have never had to do any of this stuff, my PC has been trouble free for many years until Microsoft forced me into this.

Buffers.JPG

Edited by Mr. Torture

Share this post


Link to post
Share on other sites

https://www.resplendence.com/latencymon

 

You buffer setting is obviously set to low. I have to run a 256 with my Motu M4. I can get to 128 with my Scarlett but some projects with lots of goodies will crackle. And this is my Latency monitor report.  

1346099374_2021-01-20(4).thumb.png.086f7fd0efaa8ab8b95bd52d7e592904.png

 

Edited by John Vere

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...