Jump to content

Audio Cutting Out in Cakewalk

Recommended Posts

Here is my LatencyMon Main page. And my drivers tab shows ACPI.sys has a zero value here. Yours is way too high, and may very likely be causing your issues.

That note you got there related to power management is definitely something to follow up with. Did you download and install the latest available drivers for your motherboard from the manufacturer site?


LatencyMon capture.PNG

Share this post

Link to post
Share on other sites

Those 12ms duration DPC events probably means that your CPU is not processing any audio during those events.



When working with streaming audio or video that uses interrupts, DPCs are used to process the audio in each buffer as they stream in. If another DPC (from a poorly written driver) takes too long and another interrupt generates a new buffer of data, before the first one can be processed, a drop-out results.


Share this post

Link to post
Share on other sites
On 11/30/2020 at 10:59 PM, Dustin said:

I am running into audio dropping out when I attempt to either:

  • Play a cakewalk project (any project with any complexity)
  • Record a track in a cakewalk project

This is on a new computer, replacing an 8 or so year old computer. That old computer was able to play those files fine. The new computer, even when I 'freeze' the tracks in the project, it is unable to keep up/dropping tracks periodically.
I have tried all of the following steps outlined in the article at and more: https://www.cakewalk.com/Support/Knowledge-Base/2007013007/Audio-Dropouts-Clicks-and-Pops-When-Playing-and-Recording and https://help.cakewalk.com/hc/en-us/articles/360021858253-I-m-experiencing-latency-or-audio-dropouts-while-recording-

  1. Increasing the 'safety' of the M-Audio M-Track Quad/increasing the buffer time.
  2. I have increased the Hard Disk Buffer Size to 1024.
  3. I have turned off Windows Defender real-time scanning, turned off any/all miscellaneous services running, etc.
  4. I have turned off any/all other sound cards on the system to ensure none of them are interfering in any way.
  5. I have tried replacing the Aud.ini file from my old computer to my new computer.
  6. I have installed/reinstalled the sound card and am using the appropriate Asio setting in Cakewalk for it.
  7. I have reinstalled Cakewalk.

The new computer in question: Windows 10 Pro with an M-Audio M-Track Quad. The M-Track Quad has been installed with the latest drivers (pulled from the site https://www.m-audio.com/support/download/drivers/m-track-quad-windows-driver-v2.9.64). I have no problem opening up any of my files, and they all appear correct. The only difference is my old machine was running Win 7 and this one is Win 10 Pro. The new machine is (obviously) much more beefy than my 8 year old computer - and it ran fine on that one.

Any thoughts?

Make sure the sample rate in windows 10 are the same as that of the settings in your DAW and Audio Interface - Visa-Versa. That's always the issue with dropouts with Cakewalk. All three mentioned, need to work together. 

How to change "sound control panel" settings in Windows 10

Right-click the Speaker icon in your system tray and click Playback devices.

Select your speaker, then click Properties.

Click the Advanced tab.

Click the drop-down and it will show you the sample rate and bit depths options.

Make sure your interface it's plugged in to the correct compatible ports  - either 2.0 or 3.0. Uninstall "Asio4All" if you have that installed. 

Try these steps too (Click on this.)

Edited by Will_Kaydo

Share this post

Link to post
Share on other sites

Not sure if this will solve it but I bought the M4 and immediately was getting artifacts in playback at 256 buffers, the same setting I always used with my Scarlett. I experimented switching between interfaces and the M4 was defiantly screwing up. I contacted Motu and they sent a PDF with the standard list of tweaks and also recommended a PCIe USB 3 card. Seems a common issue with bus powered interfaces are not getting enough juice so they screw up. What a bad design! They should always have the option of using a proper power supply.  I knew this and this is my fault, I would not have bought this interface had I figured that out. 

 I just put the PCIe card in last night and will see how it goes. Only thing I'm sorting out is it has a SATA power cable option and I raan out of connectors from my cheapo HP power supply. Might have to order a better power supply. They say it should work with out it and it's only for if you load up all 5 ports. 

ANyhow you might not need the PCIe card if your new computer has enough USB ports and you can find a USB 3.0 port that is not shared. 

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...