Jump to content

Question

So, I essentially have a kind of "reverse lag" issue. I'm running an Avid Fast Track Solo as an interface, and what is happening is that when I'm playing my guitar through it, the sound is coming through almost instantaneously, with no notable sign of lag. When I play along to a metronome, it sounds on beat. When I play it back, it sounds off-beat, because the guitar comes in consistently 20ms early. If I take the metronome away, and double the guitar beat I just made, once again, it sounds on beat while recording, but is 20ms early on playback. Please note : the most recent track is early, not late due to lag. If I watch a sound file being played and set the graph increments to 20ms, I am hearing the beat just before it reaches where it is supposed to be played, as if the audio was reaching my headphones before it was visually showing up on screen. Unfortunately though, it is recording my guitar as it is played on screen, 20ms ahead of the previous track.

When I listen to a recording back, it sounds off, but if I move the recording to 20ms later, it sounds as it did when I recorded it.

All information I've found had been in regards to a track coming in late, not early. My mixing latency buffer size is set to 128 samples (2.9ms), but if I increase that, there is a noticeable delay between when I hit the strings and when it can be heard, which is enough to totally throw off my playing. 

It's like I need the playback to come through the monitors 20ms later, but the guitar to come through straight away, and I've found nothing similar.

 

ASIO drivers (Avid Fast Track Solo Driver 1.0.4(x64)) on an Acer Predator laptop. Windows 10. Intel i7-7700HQ @ 2.8GHz, 32GB ram.

 

Recording on beat.jpg

First picture : as recorded. There are a couple of notes that seem to be on time....these are the off-time notes, as I'm far from perfect.

Recording moved to 20ms later.jpg

Second picture : after I've moved the track 20ms to the right.

Edited by Daniel Jorgensen
More info.

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

Your best bet is to remove ASIO4ALL and use the proper Avid driver which will report the latency correctly:

Grab the proper Windows driver from here: https://avid.secure.force.com/pkb/articles/download/fast-track-solo-drivers

Unzip it to a handy location (eg: Desktop)

Go into your Control Panel Settings > Add / Remove software and uninstall ASIO4ALL

Make sure your Fast Track Solo is unplugged, and install the correct Avid Drivers

Plug it in, let it detect. Open Cakewalk and go into Preferences > Audio > Driver Settings and choose the Avid driver.

This *should* fix the problem. :)

Share this post


Link to post
Share on other sites
  • 0

Ahh, sorry Lord Tim...Looks like I've given some incorrecto info there. I initially used ASIO4ALL, but it gave me issues, and I eventually did end up changing the driver over to the correct Avid ones. It was that long ago that I forgot that I'd done it. Sorry.

Share this post


Link to post
Share on other sites
  • 0

Aha, OK! Ignore what I said then :)

In which case, in Cakewalk open up Preferences > Audio > Sync and Caching (it may be hidden if you haven't got the Advanced view checked down the bottom of the window)

Look for Record Latency Adjustment and make sure you have the right device selected and Use ASIO Reported Latency is ticked. If that's all correct, you might be able to put in a manual offset and fix the issue that way.

Share this post


Link to post
Share on other sites
  • 0

Yeah...already tried that, unfortunately. I even tried the manual offset, and all it did was to insert a delay between what I was playing and what I was hearing. It's almost like I need it to delay the existing audio out, but not the audio out for what I'm playing. 

It's really quite odd.

Share this post


Link to post
Share on other sites
  • 0

241156975_Waveformduringandafterrecording.thumb.jpg.9e2581fcc9fe4bd939eb71dd9bd1c363.jpgAfter further looking into, it's closer to 10ms, and after making a video of the recording process, it appears that it is recording it at the correct time, then 'shunting' it back when the recording stops. You can see quite clearly that during the recording (top), the second waveform starts on the beat (darker vertical line), but after the recording is done (lower) it starts before this line. No matter what I change in regards to buffer sizes or latency, this happens regardless.

ps...This is just raw input; no plugins.

Edited by Daniel Jorgensen
More info.

Share this post


Link to post
Share on other sites
  • 0

Just for troubleshooting, what happens if you change the driver mode to WASAPI Exclusive in Audio > Playback and Recording? Usually you're always better off with manufacturer supplied ASIO drivers but there's been a lot of work done using Win10's native WASAPI modes over the last couple of years. On my interface, I'm finding around the same latency as my ASIO drivers. I'd be curious to see if you get the same ~10ms offset.

Share this post


Link to post
Share on other sites
  • 0

Yeah, this is an odd one for sure. I'd probably be shooting Support a message in which case. It's hard to say if this is an interface thing, a Windows environment thing or something in Cakewalk that's gotten borked along the line.

As a final thing to try before you do that, though, make sure Cakewalk is closed then open up File Explorer and navigate to %appdata%\Cakewalk\Cakewalk Core

Look for AUD.INI and rename it AUD.OLD

The next time you restart Cakewalk it'll rebuild your configuration file. That will at least rule out some weird-a$s setting or corruption there.

But if that doesn't help matters, shoot Support a line I'd say. Good luck! :)

Edited by Lord Tim
Nabbed by the profanity filter 🤨

Share this post


Link to post
Share on other sites
  • 0

So, in the end, nothing I've done has been able to fix this issue. Cakewalk is still recording at the correct time, then "shunting" the whole thing back 10ms. No amount of ticking boxes or applying a negative offset for the sync has made any change whatsoever. I've basically resigned myself to manually shifting anything I've recorded forward 10ms to compensate.

Share this post


Link to post
Share on other sites
  • 0

Yeah, that's super weird - obviously not typical behaviour. Not even deleting AUD.INI helped?

Out of curiosity, on one of the clips that shifted, if you right click it and choose Revert Clip(s) to Original Time Stamp, does anything move at all?

 

Share this post


Link to post
Share on other sites
  • 0

Since Cakewalk is incapable of time travel, the only reasonable explanation for a recorded signal appearing earlier than it sounded in real time is that the recording was time-shifted after it was recorded. This is done deliberately in a process called delay compensation, for the purpose of time-aligning the tracks when it is anticipated that there will be a delay that would cause a track to be ahead of the other tracks otherwise. The usual cause of this "problem" is that one of the plugins used on any track (not just the affected track) introduces a predictable delay/latency due to a look-ahead buffer, and communicates this expected delay to Cakewalk as part of an automatic delay compensation protocol. Try bypassing all effects to see if the issue persists. If it does not, then you may have to manually set a new delay to compensate for the one that is being incorrectly applied.

https://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=Recording.22.html

 

Share this post


Link to post
Share on other sites
  • 0

I've tried everything here. Changing the "UseHardwareSamplePosition" to "False" made no difference. When I was testing this, there are no effects applied, just raw input. It seems to be overcompensating for what lag it is expecting, but will not let me shift it forward, only back. I also tried the PDC override button, but again, no change.

Share this post


Link to post
Share on other sites
  • 0

My vote is to shoot support a message. This obviously isn't widespread or the forums would be on fire right now, so it's got to be something specific to your environment. There's really only so much we can suggest without being a bit more hands on with your system like support can be.

These weird outlier cases are horrible to diagnose, but if you can solve it, often there's a good knock-on effect for everyone - if the issue actually does work out to be some shortcoming of the CbB engine and it gets fixed, we all win. :)

But yeah, shoot support a line I reckon. If they solve it, definitely report back here - I'm sure a few of us are keen to know what the solution is!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...