Jump to content
siberguy

MIDI Notes recorded early

Recommended Posts

I've seen this problem mentioned but haven't found a fix.   I thought my sense of time was gone.  My attempt at adding MIDI with pre recorded tracks or the metronome is not synced.  I grabbed a copy of Waveform and tried some finger drumming and  my timing is fine. It's  only in Cakewalk that things get messed up.  The notes show up too soon.  It's enough to be painfully obvious.   I've been using Cakewalk  for  years  from when it was only MIDI.   Never had this before.   I'm not sure when it started because I haven't been using it much and mostly audio these days  but I recently got in to finger drumming on a pad controller.  Fun stuff but it's not working in Cakewalk. I'm using a MOTU interface and a nektar pad controller.  It all works as it''s supposed to in at least one other DAW so i'm thinking it's not in my hardware or drivers.  Any ideas.  

Share this post


Link to post
Share on other sites

Did you try turning off all Effects Bins? This is often why my playing is off time but usually late, not early. . Also a while back W10  updated my Roland driver to a generic midi driver and everything fell apart. I re installed the Roland midi driver and all worked fine after that.  If your controller has a midi driver re install it. 

Share this post


Link to post
Share on other sites

I find the easiest is to turn on FX button in command module in toolbar. That bypass all effects.

Another one to try is PDC button, to just ignore plugin delay compensation.
Using large asio buffers can delay your own echo monitor through Cakewalk and you compensate by playing early. Then Cakewalk adjust a clip backwards for the full roundtrip delay as well, and become too much since midi is not roundtrip audio - it's only oneway audio delay of the buffers. Midi delay input may be smaller.

Is interface recording the correct delay?
I create an audio loopback, and record metronome this way to see if on grid.
There is a setting also to adjust recording offset, in Sync and Caching in Audio in Preferences.
This value is added to whatever interface report.
So if not on grid - one thing to adjust.

Last resort - adjust clip manually after record.
There are 3 nudge settings, where you can adjust a clip in various ways you can try what works best.
So a keyboard shortcut can make this done in one go, as you find it differs for midi.

A bunch of ideas....

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...