Jump to content
jono grant

Cakewalk turn off local on keyboard

Recommended Posts

Hey, Cakewalk is turning off the "local" on my keyboard. I'd prefer it didn't.

I forget where the setting is for that. Anyone?

Thanks!

Jono

Share this post


Link to post
Share on other sites

Well, this used to be the way to tell Cakewalk to automatically turn off Local Control... not sure if it's still used.

1. In the directory where SONAR is installed, double-click on the TTSseq.ini file to open it. (In the Cakewalk Core directory).
2. In the [Options] section, add the line:     SendLocalOff=1
3. Save the file and close it.
4. When you launch SONAR, it automatically sends a Local Off message to your keyboard.

If you don't have an Options section with the line SendLocalOff=1  in your TTSseq.ini file, you could try adding it, then change the line to SendLocalOff=0

That should disable it (maybe?) 

Make a backup copy of your TTSseq.ini file before changing it... in case I'm giving you garbage advice 🤪

 

*** UPDATE ***

My keyboard doesn't respond to Local On/Off messages, but I tested the above option with LoopMIDI and MIDI-OX  and it does indeed work.

If SendLocalOff is not in the TTSseq.ini file at all or is present and is set to 1, Cakewalk sends the LocalOff message to each midi device. If SendLocalOff=0 is present in the [Options] section, Cakewalk does not send the LocalOff message.

BTW - The TTSseq.ini file is probably in C:\Users\<USER NAME>\AppData\Roaming\Cakewalk\Cakewalk Core

Edited by Variorum
Tested
  • Like 1

Share this post


Link to post
Share on other sites

Thanks, I'll check it out! I think there might be a preference setting too, I seem to remember dealing with this before.

J

Edited by jono grant

Share this post


Link to post
Share on other sites
On 11/19/2020 at 12:40 AM, Variorum said:

Well, this used to be the way to tell Cakewalk to automatically turn off Local Control... not sure if it's still used.

1. In the directory where SONAR is installed, double-click on the TTSseq.ini file to open it. (In the Cakewalk Core directory).
2. In the [Options] section, add the line:     SendLocalOff=1
3. Save the file and close it.
4. When you launch SONAR, it automatically sends a Local Off message to your keyboard.

If you don't have an Options section with the line SendLocalOff=1  in your TTSseq.ini file, you could try adding it, then change the line to SendLocalOff=0

That should disable it (maybe?) 

Make a backup copy of your TTSseq.ini file before changing it... in case I'm giving you garbage advice 🤪

 

*** UPDATE ***

My keyboard doesn't respond to Local On/Off messages, but I tested the above option with LoopMIDI and MIDI-OX  and it does indeed work.

If SendLocalOff is not in the TTSseq.ini file at all or is present and is set to 1, Cakewalk sends the LocalOff message to each midi device. If SendLocalOff=0 is present in the [Options] section, Cakewalk does not send the LocalOff message.

BTW - The TTSseq.ini file is probably in C:\Users\<USER NAME>\AppData\Roaming\Cakewalk\Cakewalk Core

Hi, I simply can not find that file on my computer. Just updated Cakewalk as well. Do you think they may have changed the file name since bandlab took over?

Share this post


Link to post
Share on other sites

Hmmm... It should be there. The only other possibility might be C:\ProgramData\Cakewalk\Cakewalk Core, but I'm pretty sure it won't be in there.

Just in case you tried searching for the file... I've noticed that using search (in File Explorer) will not find any files in sub-folders if you start the search from the C:\Users\ folder. It won't find the file unless you search from at least the C:\Users\<USER NAME>\AppData\ folder.

The file has to exist somewhere because Cakewalk stores important info about your MIDI ports in it. 

If you can't see the C:\Users\<USER NAME>\AppData\ folder, make sure you have "Hide protected operating system files" unchecked in File Explorer's Folder and Search Options.

 

Capture.PNG

Share this post


Link to post
Share on other sites
7 hours ago, Variorum said:

If you can't see the C:\Users\<USER NAME>\AppData\ folder, make sure you have "Hide protected operating system files" unchecked in File Explorer's Folder and Search Options.

I just checked and it's indeed at C:\Users\<user name>\AppData\Roaming\Cakewalk\Cakewalk Core

But it is a system file, so perhaps Variorum's advice will solve your issue.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...